Timing problem (garbage characters) in lirc-driver for iMon PAD VFD 15c2:0036

Bug #517956 reported by Eduard Iten on 2010-02-06
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux-meta-lts-xenial (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: lirc

In the lirc-driver for the Soundgraph iMon PAD VFD, USB-ID 15c2:0036, there is a timing problem. Packets are sent too fast to the USB-Device. You can see that you are affected by this problem, if you find similar lines in your syslog:

[...]
Feb 6 08:06:09 mythtv kernel: [ 47.727759] lirc_imon: vfd_write: send packet failed for packet #2
Feb 6 08:06:09 mythtv kernel: [ 47.978904] lirc_imon: send_packet: packet tx failed (-32)
Feb 6 08:06:09 mythtv kernel: [ 47.978909] lirc_imon: vfd_write: send packet failed for packet #4
Feb 6 08:06:09 mythtv kernel: [ 48.223802] lirc_imon: send_packet: packet tx failed (-32)
Feb 6 08:06:09 mythtv kernel: [ 48.223807] lirc_imon: vfd_write: send packet failed for packet #2
Feb 6 08:06:09 mythtv kernel: [ 48.471698] lirc_imon: send_packet: packet tx failed (-32)
Feb 6 08:06:09 mythtv kernel: [ 48.471703] lirc_imon: vfd_write: send packet failed for packet #1
[...]

To fix the problem, you can apply the enclosed patch and rebuild the dkms lirc modules:
cd /usr/src/lirc-0.8.6/
sudo dkms remove -m lirc -v 0.8.6 -k `uname -r`
sudo patch -p0 < lirc-0.8.6-VFD_0x0036_timing.patch
sudo dkms add -m lirc -v 0.8.6
sudo dkms build -m lirc -v 0.8.6
sudo dkms install --force -m lirc -v 0.8.6

The patch will add some 20 microseconds delay before each package send. It's not the most beautiful solution, but until there is some corrected upstream, this will help.

HTH, Edi

Guideline informations:
1) Ubuntu-Release:
Description: Ubuntu 9.10
Release: 9.10

2) Package Version:
lirc-modules-source:
  Installed: 0.8.6-0ubuntu2
  Candidate: 0.8.6-0ubuntu2
  Version table:
 *** 0.8.6-0ubuntu2 0
        500 http://archive.ubuntu.com karmic/universe Packages
        100 /var/lib/dpkg/status

3) What should happen:
Correct information displayed on the VFD

4) What happens:
Garbage characters displayed on VFD

ProblemType: Bug
Architecture: amd64
Date: Sat Feb 6 09:07:02 2010
DistroRelease: Ubuntu 9.10
Package: lirc-modules-source 0.8.6-0ubuntu2 [modified: usr/src/lirc-0.8.6/drivers/lirc_imon/lirc_imon.c]
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=de_CH.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-19.56-generic
SourcePackage: lirc
Uname: Linux 2.6.31-19-generic x86_64

Eduard Iten (eiten) wrote :
Eduard Iten (eiten) on 2010-02-07
tags: added: lirc
myself108 (eric-pwb) wrote :

This Bug also applies to the Antec Multimedia Station Elite, or 15c2:0044.

Note: Once the patch was applied the VFD seems to function correctly but the dmesg output still shows occasionally the:

eb 6 08:06:09 mythtv kernel: [ 47.727759] lirc_imon: vfd_write: send packet failed for packet #2
Feb 6 08:06:09 mythtv kernel: [ 47.978904] lirc_imon: send_packet: packet tx failed (-32)
Feb 6 08:06:09 mythtv kernel: [ 47.978909] lirc_imon: vfd_write: send packet failed for packet #4
Feb 6 08:06:09 mythtv kernel: [ 48.223802] lirc_imon: send_packet: packet tx failed (-32)
Feb 6 08:06:09 mythtv kernel: [ 48.223807] lirc_imon: vfd_write: send packet failed for packet #2
Feb 6 08:06:09 mythtv kernel: [ 48.471698] lirc_imon: send_packet: packet tx failed (-32)
Feb 6 08:06:09 mythtv kernel: [ 48.471703] lirc_imon: vfd_write: send packet failed for packet #1
[...]

errors

Eduard Iten (eiten) wrote :

Hm, so maybe you need to increse the value here:
unsigned long timeout = usecs_to_jiffies(20);
The higher it is, the slower the display-updates are, so you may have to experiment a little...

Andreas (ubuntu-forsaken) wrote :

I have a OrigenAE M10 which has the 15c2:0036, I'm still getting these messages from the kernel despite having applied the patch, I've also tested and increased the delay to 30 but still the same. It works though.

Jarod Wilson (jarod-wilsonet) wrote :

I've patched a 5ms exit delay into the send_packet() function in lirc_imon in current lirc cvs (and in the merged-upstream-in-2.6.35 imon driver). The microsecond delays were a bit on the low side. This 5ms delay doesn't show any functional regressions on any of the three imon devices I've got, and does indeed fix garbage displaying on my own 0x0044 (Antec Veris Elite) VFD -- a problem that only cropped up with the latest motherboard in this system, its been just fine w/all other motherboards (*only* the motherboard was changed in this system, all other components are identical to a prior setup where the VFD behaved just fine). lirc 0.8.7 should be released within a week or three, and will carry this fix (as does the imon driver in 2.6.35+).

MarcRandolph (mrand) wrote :

Hopefully 0.8.7 will go to press in time to be released for Ubuntu 10.10... marking in progress based upon lirc developer comments.

Changed in lirc (Ubuntu):
importance: Undecided → Low
status: New → In Progress
Eduard Iten (eiten) wrote :

@jared: I will test the cvs tonight and report back. Tnx.

Dimitris Kounalakis (dcoun) wrote :

The same problem exists for 15c2:0037

Lubor (kemza) wrote :

On Chieftec case (15c2:0036) same problem in maverick RC.

a_user (a-user-sci) wrote :

On Chieftec HM-01 case with imon vfd, running up to date ubuntu maverick 10.10 i have the same issue. (already had this since karmic).
it is a fresh and clean new install.

i read that there is a patch for the module sources but since kernel 2.6.35 includes the imon driver itself it is not recomended to rebuild from module sources, at least so it is written in the documentation.

Cheftec HM-01, iMon-Display: P: Vendor=15c2 ProdID=0036 Rev=00.01

My problem (black imon-screen, remote control not working and _maybe_ computer freezes) was fixed in 10.04 by installing the patch and it is now fixed using 10.10. Thanks for your fix. For me it works. I wonder what the difference is e.g. compared to a_user ...

I use mainboard MSI 790GX-G65.

Alec Leamas (leamas-alec) wrote :

Indeed the kernelk (media subsystem), but possibly the wrong version... sorry

affects: lirc (Ubuntu) → linux-meta-lts-xenial (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers