linux-signed-generic-lts-xenial 4.4.0-143 depends on linux-generic instead of linux-generic-lts-xenial

Bug #1820526 reported by Brendan Boerner on 2019-03-17
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux-meta-lts-xenial (Ubuntu)
Critical
Unassigned

Bug Description

Linux 14.04.6 LTS with HWE stack.

Am on 4.4.0-142, did a dist-update and 3.13.0-167 gets pulled in e.g.

# sudo apt-get install linux-signed-generic-lts-xenial Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  linux-generic linux-headers-3.13.0-167 linux-headers-3.13.0-167-generic
  linux-headers-generic linux-image-3.13.0-167-generic linux-image-generic
  linux-modules-3.13.0-167-generic linux-modules-extra-3.13.0-167-generic
Suggested packages:
  fdutils linux-doc-3.13.0 linux-source-3.13.0 linux-tools
The following NEW packages will be installed:
  linux-generic linux-headers-3.13.0-167 linux-headers-3.13.0-167-generic
  linux-headers-generic linux-image-3.13.0-167-generic linux-image-generic
  linux-modules-3.13.0-167-generic linux-modules-extra-3.13.0-167-generic
  linux-signed-generic-lts-xenial
0 upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/60.2 MB of archives.
After this operation, 275 MB of additional disk space will be used.
Do you want to continue? [Y/n]

apt-cache policy linux-signed-generic-lts-xenial shows dependency on linux-generic instead of linux-generic-lts-xenial.

What I expected to happen is that the 3.x kernel bits wouldn't be installed.

This may also be why building VirtualBox DKMS module is broken:

Processing triggers for linux-image-4.4.0-143-generic (4.4.0-143.169~14.04.2) ...
/etc/kernel/postinst.d/dkms:
Error! Bad return status for module build on kernel: 4.4.0-143-generic (x86_64)
Consult /var/lib/dkms/virtualbox/4.3.36/build/make.log for more information.

description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-meta-lts-xenial (Ubuntu):
status: New → Confirmed
Stéphane Graber (stgraber) wrote :

This is causing MAAS deployments using trusty + hwe-x to silently end up with the wrong kernel.

Changed in linux-meta-lts-xenial (Ubuntu):
importance: Undecided → Critical
Stefan Bader (smb) on 2019-03-19
Changed in linux-meta-lts-xenial (Ubuntu):
status: Confirmed → Fix Committed
rrarra (rrarra) wrote :

WTF? i cannot run virtualbox because of this bug! when does this get fixed?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta-lts-xenial - 4.4.0.143.126

---------------
linux-meta-lts-xenial (4.4.0.143.126) trusty; urgency=medium

  * linux-signed-generic-lts-xenial 4.4.0-143 depends on linux-generic instead
    of linux-generic-lts-xenial (LP: #1820526)
    - [Packaging] Fix signed-meta dependencies

linux-meta-lts-xenial (4.4.0.143.125) trusty; urgency=medium

  * SRU Request: nvidia-*: nvidia-* kernel module failed to build [error: too
    many arguments to function ‘get_user_pages’] (LP: #1573508)
    - Add breaks for nvidia and virtualbox

  * virtualbox dkms modules fail to build with linux 4.4.0-143.169 [error: too
    many arguments to function ‘get_user_pages’] (LP: #1818049)
    - Add breaks for nvidia and virtualbox

linux-meta-lts-xenial (4.4.0.143.124) trusty; urgency=medium

  * signing: only install a signed kernel (LP: #1764794)
    - switch to signed-only binary packages
    - convert linux-signed* into transitional packages

linux-meta-lts-xenial (4.4.0.143.123) trusty; urgency=medium

  * Bump ABI 4.4.0-143

 -- Stefan Bader <email address hidden> Tue, 19 Mar 2019 11:21:44 +0000

Changed in linux-meta-lts-xenial (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
Adan Rehtla (djravine) wrote :

This has broken our DEV VAGRANT BOXES.

Adan Rehtla (djravine) wrote :

Can this patch also be pushed to Xenial 16.04?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers