linux-lts-wily: 4.2.0-22.27~14.04.1 -proposed tracker

Bug #1527538 reported by Brad Figg on 2015-12-18
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Kernel SRU Workflow
Medium
Unassigned
Automated-testing
Medium
Canonical Kernel Team
Certification-testing
Medium
Canonical Hardware Certification
Prepare-package
Medium
Luis Henriques
Prepare-package-meta
Medium
Luis Henriques
Prepare-package-signed
Medium
Luis Henriques
Promote-to-proposed
Medium
Chris J Arges
Promote-to-security
Medium
Chris J Arges
Promote-to-updates
Medium
Chris J Arges
Regression-testing
Medium
Canonical Kernel Team
Security-signoff
Medium
Canonical Security Team
Verification-testing
Medium
Canonical Kernel Team
linux-lts-wily (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned

Bug Description

This bug is for tracking the 4.2.0-22.27~14.04.1 upload package. This bug will contain status and testing results related to that upload.

For an explanation of the tasks and the associated workflow see: https://wiki.ubuntu.com/Kernel/kernel-sru-workflow
kernel-stable-Prepare-package-start:Friday, 18. December 2015 10:20 UTC
kernel-stable-master-bug:1527391
kernel-stable-Security-signoff-end:Friday, 18. December 2015 19:02 UTC
kernel-stable-Prepare-package-end:Friday, 18. December 2015 20:01 UTC
kernel-stable-Promote-to-proposed-start:Friday, 18. December 2015 20:01 UTC
kernel-stable-Promote-to-updates-start:Saturday, 19. December 2015 11:30 UTC
kernel-stable-Certification-testing-end:Saturday, 19. December 2015 11:30 UTC
kernel-stable-Regression-testing-end:Saturday, 19. December 2015 11:30 UTC
kernel-stable-Promote-to-updates-end:Saturday, 19. December 2015 13:00 UTC
kernel-stable-phase:Released
kernel-stable-phase-changed:Saturday, 19. December 2015 14:02 UTC

Brad Figg (brad-figg) on 2015-12-18
tags: added: kernel-release-tracking-bug
tags: added: block-proposed
tags: added: block-proposed-wily
tags: added: block-proposed-trusty
tags: added: trusty
Changed in kernel-sru-workflow:
status: New → In Progress
importance: Undecided → Medium
Changed in linux-lts-wily (Ubuntu):
importance: Undecided → Medium
Changed in linux-lts-wily (Ubuntu Trusty):
importance: Undecided → Medium
Luis Henriques (henrix) on 2015-12-18
Changed in linux-lts-wily (Ubuntu):
status: New → Invalid
Brad Figg (brad-figg) on 2015-12-18
description: updated

All builds are complete, packages in this bug can be copied to -proposed.

description: updated
Luis Henriques (henrix) wrote :

Looks like this kernel is in -proposed yet, so I'm moving this task to 'fix-released':
 linux-lts-wily | 4.2.0-21.25~14.04.1 | trusty-security | source
 linux-lts-wily | 4.2.0-21.25~14.04.1 | trusty-updates | source
 linux-lts-wily | 4.2.0-22.27~14.04.1 | trusty-proposed | source

tags: added: qa-testing-passed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-lts-wily - 4.2.0-22.27~14.04.1

---------------
linux-lts-wily (4.2.0-22.27~14.04.1) trusty; urgency=low

  [ Kamal Mostafa ]

  * Release Tracking Bug
    - LP: #1527538

  [ Jann Horn ]

  * ptrace: being capable wrt a process requires mapped uids/gids
    - LP: #1527374

linux (4.2.0-22.26) wily; urgency=low

  [ Upstream Kernel Changes ]

  * xen: Add RING_COPY_REQUEST()
    - CVE-2015-8550
  * xen-netback: don't use last request to determine minimum Tx credit
    - CVE-2015-8550
  * xen-netback: use RING_COPY_REQUEST() throughout
    - CVE-2015-8550
  * xen-blkback: only read request operation from shared ring once
    - CVE-2015-8550
  * xen-blkback: read from indirect descriptors only once
    - CVE-2015-8550
  * xen-scsiback: safely copy requests
    - CVE-2015-8550
  * xen/pciback: Save xen_pci_op commands before processing it
    - CVE-2015-8550
  * xen/pciback: Return error on XEN_PCI_OP_enable_msi when device has MSI
    or MSI-X enabled
    - CVE-2015-8551, CVE-2015-8552, CVE-2015-8553
  * xen/pciback: Return error on XEN_PCI_OP_enable_msix when device has MSI
    or MSI-X enabled
    - CVE-2015-8551, CVE-2015-8552, CVE-2015-8553
  * xen/pciback: Do not install an IRQ handler for MSI interrupts.
    - CVE-2015-8551, CVE-2015-8552, CVE-2015-8553
  * xen/pciback: For XEN_PCI_OP_disable_msi[|x] only disable if device has
    MSI(X) enabled.
    - CVE-2015-8551, CVE-2015-8552, CVE-2015-8553
  * xen/pciback: Don't allow MSI-X ops if PCI_COMMAND_MEMORY is not set.
    - CVE-2015-8551, CVE-2015-8552, CVE-2015-8553

 -- Luis Henriques <email address hidden> Fri, 18 Dec 2015 10:27:07 +0000

Changed in linux-lts-wily (Ubuntu Trusty):
status: New → Fix Released

 linux-lts-wily | 4.2.0-22.27~14.04.1 | trusty-updates | source
 linux-meta-lts-wily | 4.2.0.22.16 | trusty-updates | source
 linux-signed-lts-wily | 4.2.0-22.27~14.04.1 | trusty-updates | source

Brad Figg (brad-figg) on 2015-12-19
description: updated

The package has been published and the bug is being set to Fix Released

Changed in kernel-sru-workflow:
status: In Progress → Fix Released
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers