Fails to boot on Macbook Air 2013 (Haswell) in SMP mode, needs nosmp to boot

Bug #1487621 reported by Jeff Lane on 2015-08-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-lts-utopic (Ubuntu)
Low
Unassigned
linux-lts-vivid (Ubuntu)
Low
Unassigned

Bug Description

I keep running into issues with booting on a 2013 Macbook Air. After grub, the kernel and initrd load and the system then just hangs with a blinking cursor.

Removing the "quiet" and "splash" options shows me that the kernel hangs bringing up SMP, just as in bug #1197451 which has been marked Fix Released already (some time ago, actually).

I get exactly what was mentioned in the comments about SMP hanging and have had to manually inject nosmp into the boot command when I boot the machine.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.16.0-40-generic 3.16.0-40.54~14.04.1
ProcVersionSignature: Ubuntu 3.16.0-40.54~14.04.1-generic 3.16.7-ckt11
Uname: Linux 3.16.0-40-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.14.1-0ubuntu3.12
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Aug 21 17:17:40 2015
InstallationDate: Installed on 2015-06-11 (71 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64+mac (20150218.1)
SourcePackage: linux-lts-utopic
UpgradeStatus: No upgrade log present (probably fresh install)

Jeff Lane (bladernr) wrote :
Jeff Lane (bladernr) wrote :

added ubuntu-lts-vivid as it gives me the same result. Freezes after loading the kernel and initrd (and booting into SMP). I have to boot with nosmp in order to get a running system.

Booting without "nosmp" freezes to the point that a hard reset is necessary.

Jeff Lane (bladernr) wrote :

Linux Bun-Bun 3.19.0-26-generic #28~14.04.1-Ubuntu SMP Wed Aug 12 14:09:17 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

uname from my current vivid LTS pacakge.

Jeff Lane (bladernr) wrote :

At a suggestion from APW, I tried current mainline:

linux-headers-4.2.0-040200rc8_4.2.0-040200rc8.201508240030_all.deb
linux-headers-4.2.0-040200rc8-generic_4.2.0-040200rc8.201508240030_amd64.deb
linux-image-4.2.0-040200rc8-generic_4.2.0-040200rc8.201508240030_amd64.deb

but that failed to fully install because of issues with dkms for bcmwl:

http://pastebin.ubuntu.com/12186541/
http://paste.ubuntu.com/12186539/

Jeff Lane (bladernr) wrote :

OK, other than the dkms issues, 4.2.0 rc8 did install enough to boot (just didn't have wifi), and it does boot in SMP mode:

bladernr@Bun-Bun:~$ uname -a
Linux Bun-Bun 4.2.0-040200rc8-generic #201508240030 SMP Mon Aug 24 04:31:40 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
bladernr@Bun-Bun:~$ cat /proc/cpuinfo |grep ocessor
processor : 0
processor : 1
processor : 2
processor : 3

so with 4.2.0 rc8, at least, I can boot in SMP mode, and all four CPUs appear (two cores at 2 threads each).

Jeff Lane (bladernr) on 2015-08-24
summary: - Fails to boot on Macbook Air 2013 (Haswell)
+ Fails to boot on Macbook Air 2013 (Haswell) in SMP mode, needs nosmp to
+ boot
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-lts-utopic (Ubuntu):
status: New → Confirmed
Changed in linux-lts-vivid (Ubuntu):
status: New → Confirmed
Jeff Lane (bladernr) wrote :

How long will it take to get this into Trusty? Or would I have a better time installing the Wily Beta?

Since 4.2.0 seems to work in SMP mode, my only issue is lack of drivers for wifi and such. (And trusty in UP mode seems to run very, very hot and is working the fan to death).

Changed in linux-lts-vivid (Ubuntu):
importance: Undecided → Low
Changed in linux-lts-utopic (Ubuntu):
importance: Undecided → Low
tags: added: needs-reverse-bisect
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers