[HP Pavilion g7] fwts high failure: AMLAsmASL_MSG_SYNTAX: Test 1, Assembler error in line 253

Bug #1370338 reported by Taihsiang Ho on 2014-09-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-lts-trusty (Ubuntu)
Low
Unassigned

Bug Description

HP Pavilion g7 on Ubuntu 12.04.5
(CID 201209-11633 201209-11634)

Command: "fwts -q --stdout-summary -r /home/ubuntu/.cache/plainbox/sessions
/pbox-mvbz1d.session/CHECKBOX_DATA/fwts_results.log syntaxcheck".
Running tests: syntaxcheck.

--------------------------------

15980 Checking ACPI table SSDT (#2)
15981
15982 FAILED [HIGH] AMLAsmASL_MSG_SYNTAX: Test 1, Assembler error in line 253
15983 Line | AML source
15984 --------------------------------------------------------------------------------
15985 00250| 0x0000000F
15986 00251| }
15987 00252| })
15988 00253| Package (0x06)
15989 | ^
15990 | Error 6126: syntax error, unexpected PARSEOP_PACKAGE
15991 00254| {
15992 00255| 0x80000000,
15993 00256| 0x80000000,
15994 ================================================================================
15995
15996 ADVICE: (for Error #6126, ASL_MSG_SYNTAX): The disassembled code cannot be
15997 reassembled using the strict IASL compiler as it contains syntax errors.
15998
15999 FAILED [HIGH] SyntaxCheckIASLCompilerAborted: Test 1, Compilation aborted early
16000 due to a parser detected syntax error.
16001
16002 ADVICE: Some subsequent errors may not be detected because the compiler had to
16003 terminate prematurely. If the compiler did not abort early then potentially
16004 correct code may parse incorrectly producing some or many false positive errors.
16005
16006 Table SSDT (2) reassembly: Found 1 errors, 0 warnings, 0 remarks.

--------------------------------

16325 High failures: 2
16326 syntaxcheck: Assembler error in line 253
16327 syntaxcheck: Compilation aborted early due to a parser detected syntax error.

-----------------------------

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.13.0-32-generic 3.13.0-32.57~precise1 [modified: boot/vmlinuz-3.13.0-32-generic]
ProcVersionSignature: Ubuntu 3.13.0-32.57~precise1-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
Date: Wed Sep 17 13:25:41 2014
InstallationMedia: Ubuntu 12.04.5 LTS "Precise Pangolin" - Release amd64 (20140807.1)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-lts-trusty
UpgradeStatus: No upgrade log present (probably fresh install)

----------------------------------------------------

More information:
This bug looks similar to LP: #1370341

Taihsiang Ho (taihsiangho) wrote :
description: updated
tags: removed: 201209-11634
description: updated
Daniel Manrique (roadmr) on 2014-11-25
Changed in linux-lts-trusty (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers