[Dell Inspiron 5721] Brightness control does not work with 12.04.5(with kernel 3.13)

Bug #1354313 reported by Yung Shen on 2014-08-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Edward Lin
linux (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Trusty
Undecided
Edward Lin
Utopic
Undecided
Unassigned
linux-lts-trusty (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Edward Lin
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned

Bug Description

This is a system installed with latest stable 12.04.5 image.

The Brightness key will invoke the osd-notify indicator but the display brightness won't change.

Verifying the value changing in backlight interface, system are using acpi_video0 instead:

Steps to monitor the backlight interfaces:

Press the brightness key until maxium indicator shows:

ubuntu@201210-11863:/sys/class/backlight$ cat intel_backlight/brightness ; cat acpi_video0/brightness
3407
99
ubuntu@201210-11863:/sys/class/backlight$

Press the brightness key until to minimum indicator shows:

ubuntu@201210-11863:/sys/class/backlight$ cat intel_backlight/brightness ; cat acpi_video0/brightness
3407
0

-

The workaround found here could solve this issue:
http://itsfoss.com/fix-brightness-ubuntu-1310/

-
Verified with other kernels:

linux-image-generic 3.2.0.67.79 = brightness control works
linux-image-generic-lts-quantal 3.5.0.54.59 = brightness control works

There is possible regression in following kernels:
linux-image-generic-lts-raring 3.8.0.44.44 = brightness control not work
linux-image-generic-lts-saucy 3.11.0.26.23 = brightness control not work

-

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+12ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-32.57~precise1-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Fri Aug 8 03:51:43 2014
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus: fwts-efi-runtime-dkms, 14.07.00, 3.13.0-32-generic, x86_64: installed
ExtraDebuggingInterest: Yes, even including gdb or git bisection work if needed
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:05ba]
 Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8730M] [1002:6601] (rev ff) (prog-if ff)
InstallationMedia: Ubuntu 12.04.5 LTS "Precise Pangolin" - Release amd64 (20140807.1)
MachineType: Dell Inc. Inspiron 5721
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-32-generic root=UUID=93a24f68-72a1-4335-938a-75f624f57e68 ro quiet splash initcall_debug vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/25/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A12
dmi.board.name: 0KNF68
dmi.board.vendor: Dell Inc.
dmi.board.version: X01
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A12
dmi.modalias: dmi:bvnDellInc.:bvrA12:bd10/25/2013:svnDellInc.:pnInspiron5721:pvrA12:rvnDellInc.:rn0KNF68:rvrX01:cvnDellInc.:ct8:cvrA12:
dmi.product.name: Inspiron 5721
dmi.product.version: A12
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.7.12-0ubuntu4
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1~precise1
version.libgl1-mesa-dri: libgl1-mesa-dri N/A
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core N/A
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Yung Shen (kaxing) wrote :
Changed in xorg (Ubuntu):
importance: Critical → Undecided
description: updated
Yung Shen (kaxing) wrote :
tags: added: 201210-11865
no longer affects: xorg (Ubuntu)
Changed in hwe-next:
assignee: nobody → Edward Lin (airken)
Changed in linux-lts-trusty (Ubuntu):
assignee: nobody → Edward Lin (airken)
Changed in hwe-next:
status: New → Triaged
Edward Lin (airken) wrote :

@kaxing

Can you add kernel parameter to grub without the workaround you found and test the backlight function again?

Either "acpi_video=vendor" or "video.use_native_backlight=1"

Changed in linux-lts-trusty (Ubuntu):
status: New → In Progress
Yung Shen (kaxing) wrote :

@airken ,

"video.use_native_backlight=1" works, brightness can be controlled with this workaround, and the acpi_video0 is disappear under /sys/class/backlight

but "acpi_video=vendor" won't work, it's still using /sys/class/acpi_video0, same as original situation.

Yung Shen (kaxing) on 2014-08-12
description: updated
Edward Lin (airken) wrote :

@kaxing,

Win8 doesn't use ACPI to control backlight but leaves control to gfx driver instead.
If system tells BIOS that it has win8 capability, BIOS will disable ACPI backlight interface.
Linux kernel starts to support Win8 capability after 3.7.
That's why ACPI backlight control works on early kernel version.

For win8 backlight issue, please refer to following article.
http://www.linuxjournal.com/content/july-2013-linux-kernel-news

Edward Lin (airken) wrote :

"acpi_video=vendor" is wrong.
Sorry for the mistake.

The right one should be "acpi_backlight=vendor".

Edward Lin (airken) on 2014-09-04
Changed in linux-lts-trusty (Ubuntu):
status: In Progress → Fix Committed
Tim Gardner (timg-tpi) on 2014-09-04
Changed in linux (Ubuntu Utopic):
status: New → Invalid
Changed in linux-lts-trusty (Ubuntu Utopic):
status: Fix Committed → Invalid
Changed in linux-lts-trusty (Ubuntu Precise):
status: New → Fix Committed
Changed in linux-lts-trusty (Ubuntu Trusty):
status: New → Invalid
Changed in linux (Ubuntu Precise):
status: New → Invalid
Changed in linux (Ubuntu Trusty):
status: New → Fix Committed
Changed in linux-lts-trusty (Ubuntu Precise):
assignee: nobody → Edward Lin (airken)
Changed in linux-lts-trusty (Ubuntu Utopic):
assignee: Edward Lin (airken) → nobody
Changed in linux (Ubuntu Trusty):
assignee: nobody → Edward Lin (airken)
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Yung Shen (kaxing) wrote :

Verification done.
Attaching logs for references.

tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (22.1 KiB)

This bug was fixed in the package linux - 3.13.0-37.64

---------------
linux (3.13.0-37.64) trusty; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1372576

  [ dann frazier ]

  * [Config] CONFIG_HW_RANDOM_XGENE=m on arm64

  [ Edward Lin ]

  * SAUCE: Add use_native_backlight quirk for Dell Inspiron 5721/3521
    - LP: #1354253, #1354313

  [ Tim Gardner ]

  * SAUCE: Fix nfs oops stable regression
    - LP: #1348670
  * [Config] Add mpt3sas to d-i
    - LP: #1368907
  * [Config] CONFIG_X86_16BIT=y
    - LP: #1371601

  [ Timo Aaltonen ]

  * SAUCE: i915_bdw: Rebase to v3.15.8
    - LP: #1359213

  [ Upstream Kernel Changes ]

  * Revert "x86-64, modify_ldt: Make support for 16-bit segments a runtime
    option"
    - LP: #1371601
  * mmc: rtsx: add R1-no-CRC mmc command type handle
    - LP: #1365378
  * rpc_pipe: remove the clntXX dir if creating the pipe fails
    - LP: #1365869
  * sunrpc: add an "info" file for the dummy gssd pipe
    - LP: #1365869
  * rpc_pipe: fix cleanup of dummy gssd directory when notification fails
    - LP: #1365869
  * hwrng: xgene - add support for APM X-Gene SoC RNG support
    - LP: #1365593
  * Documentation: rng: Add X-Gene SoC RNG driver documentation
    - LP: #1365593
  * arm64: dts: add random number generator dts node to APM X-Gene
    platform.
    - LP: #1365593
  * xen/balloon: cancel ballooning if adding new memory failed
    - LP: #1304001
  * x86/xen: resume timer irqs early
    - LP: #1368724
  * xen/manage: Always freeze/thaw processes when suspend/resuming
    - LP: #1368724
  * scsi_transport_sas: move bsg destructor into sas_rphy_remove
    - LP: #1368991
  * drm/i915: Enable 5.4Ghz (HBR2) link rate for Displayport 1.2-capable
    devices
    - LP: #1369633
  * bnx2x: Fix link for KR with swapped polarity lane
    - LP: #1370716
  * drm: add DRM_CAPs for cursor size
    - LP: #1359213
  * drm/dp: Add AUX channel infrastructure
    - LP: #1359213
  * drm/dp: Add drm_dp_dpcd_read_link_status()
    - LP: #1359213
  * drm/dp: Add DisplayPort link helpers
    - LP: #1359213
  * drm/dp: Allow registering AUX channels as I2C busses
    - LP: #1359213
  * drm/dp: let drivers specify the name of the I2C-over-AUX adapter
    - LP: #1359213
  * drm/dp: make aux retries less chatty
    - LP: #1359213
  * Bluetooth: Enable Atheros 0cf3:311e for firmware upload
    - LP: #1371477
  * bnx2x: fix crash during TSO tunneling
    - LP: #1371601
  * inetpeer: get rid of ip_id_count
    - LP: #1371601
  * ip: make IP identifiers less predictable
    - LP: #1371601
  * tcp: Fix integer-overflows in TCP veno
    - LP: #1371601
  * tcp: Fix integer-overflow in TCP vegas
    - LP: #1371601
  * macvlan: Initialize vlan_features to turn on offload support.
    - LP: #1371601
  * net: Correctly set segment mac_len in skb_segment().
    - LP: #1371601
  * iovec: make sure the caller actually wants anything in
    memcpy_fromiovecend
    - LP: #1371601
  * batman-adv: Fix out-of-order fragmentation support
    - LP: #1371601
  * sctp: fix possible seqlock seadlock in sctp_packet_transmit()
    - LP: #1371601
  * sparc64: Fix argument sign extension for compat_sys_futex().
    - LP: #1371601
  ...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (16.5 KiB)

This bug was fixed in the package linux-lts-trusty - 3.13.0-37.64~precise1

---------------
linux-lts-trusty (3.13.0-37.64~precise1) precise; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1372747

  [ dann frazier ]

  * [Config] CONFIG_HW_RANDOM_XGENE=m on arm64

  [ Edward Lin ]

  * SAUCE: Add use_native_backlight quirk for Dell Inspiron 5721/3521
    - LP: #1354253, #1354313

  [ Tim Gardner ]

  * SAUCE: Fix nfs oops stable regression
    - LP: #1348670
  * [Config] Add mpt3sas to d-i
    - LP: #1368907
  * [Config] CONFIG_X86_16BIT=y
    - LP: #1371601

  [ Timo Aaltonen ]

  * SAUCE: i915_bdw: Rebase to v3.15.8
    - LP: #1359213

  [ Upstream Kernel Changes ]

  * Revert "x86-64, modify_ldt: Make support for 16-bit segments a runtime
    option"
    - LP: #1371601
  * mmc: rtsx: add R1-no-CRC mmc command type handle
    - LP: #1365378
  * rpc_pipe: remove the clntXX dir if creating the pipe fails
    - LP: #1365869
  * sunrpc: add an "info" file for the dummy gssd pipe
    - LP: #1365869
  * rpc_pipe: fix cleanup of dummy gssd directory when notification fails
    - LP: #1365869
  * hwrng: xgene - add support for APM X-Gene SoC RNG support
    - LP: #1365593
  * Documentation: rng: Add X-Gene SoC RNG driver documentation
    - LP: #1365593
  * arm64: dts: add random number generator dts node to APM X-Gene
    platform.
    - LP: #1365593
  * xen/balloon: cancel ballooning if adding new memory failed
    - LP: #1304001
  * x86/xen: resume timer irqs early
    - LP: #1368724
  * xen/manage: Always freeze/thaw processes when suspend/resuming
    - LP: #1368724
  * scsi_transport_sas: move bsg destructor into sas_rphy_remove
    - LP: #1368991
  * drm/i915: Enable 5.4Ghz (HBR2) link rate for Displayport 1.2-capable
    devices
    - LP: #1369633
  * bnx2x: Fix link for KR with swapped polarity lane
    - LP: #1370716
  * drm: add DRM_CAPs for cursor size
    - LP: #1359213
  * drm/dp: Add AUX channel infrastructure
    - LP: #1359213
  * drm/dp: Add drm_dp_dpcd_read_link_status()
    - LP: #1359213
  * drm/dp: Add DisplayPort link helpers
    - LP: #1359213
  * drm/dp: Allow registering AUX channels as I2C busses
    - LP: #1359213
  * drm/dp: let drivers specify the name of the I2C-over-AUX adapter
    - LP: #1359213
  * drm/dp: make aux retries less chatty
    - LP: #1359213
  * Bluetooth: Enable Atheros 0cf3:311e for firmware upload
    - LP: #1371477
  * bnx2x: fix crash during TSO tunneling
    - LP: #1371601
  * inetpeer: get rid of ip_id_count
    - LP: #1371601
  * ip: make IP identifiers less predictable
    - LP: #1371601
  * tcp: Fix integer-overflows in TCP veno
    - LP: #1371601
  * tcp: Fix integer-overflow in TCP vegas
    - LP: #1371601
  * macvlan: Initialize vlan_features to turn on offload support.
    - LP: #1371601
  * net: Correctly set segment mac_len in skb_segment().
    - LP: #1371601
  * iovec: make sure the caller actually wants anything in
    memcpy_fromiovecend
    - LP: #1371601
  * batman-adv: Fix out-of-order fragmentation support
    - LP: #1371601
  * sctp: fix possible seqlock seadlock in sctp_packet_transmit()
    - LP: #1371601
  * sparc64: Fix argument sign extension for ...

Changed in linux-lts-trusty (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in hwe-next:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers