[Dell Latitude 6430u] Trackpoint does not work on 12.04.5

Bug #1353240 reported by Po-Hsu Lin on 2014-08-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Medium
AceLan Kao
linux-lts-trusty (Ubuntu)
Medium
Unassigned

Bug Description

CID: 201208-11536 Dell Latitude 6430u

The track point does not work on this system with 12.04.5 dailylive image (8/3)
It's detected in xinput list, but not working at all, this could be a regression.

ubuntu@201208-11536:~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ DualPoint Stick id=13 [slave pointer (2)]
⎜ ↳ AlpsPS/2 ALPS DualPoint TouchPad id=14 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Altair USB2.0 Camera id=10 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD id=11 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=12 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=15 [slave keyboard (3)]

I: Bus=0011 Vendor=0002 Product=0008 Version=0000
N: Name="DualPoint Stick"
P: Phys=isa0060/serio1/input1
S: Sysfs=/devices/platform/i8042/serio1/input/input10
U: Uniq=
H: Handlers=mouse0 event9
B: PROP=0
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.13.0-32-generic 3.13.0-32.57~precise1 [modified: boot/vmlinuz-3.13.0-32-generic]
ProcVersionSignature: Ubuntu 3.13.0-32.57~precise1-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
Date: Tue Aug 5 23:43:43 2014
InstallationMedia: Ubuntu 12.04.5 LTS "Precise Pangolin" - Release amd64 (20140803)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-lts-trusty
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) wrote :
tags: added: taipei-lab
removed: taipie-lab
Anthony Wong (anthonywong) wrote :

The trackpoint works on another machine of the same model and config on 14.04.

@phlin
Could you give 14.04 a try?

Changed in linux-lts-trusty (Ubuntu):
status: New → Incomplete
Po-Hsu Lin (cypressyew) wrote :

14.04 LiveUSB, not working.
12.04.2 (certified), still not working

Even with BIOS upgraded from X28 -> A02, it's still not working

I can't recall whether it works or not back on 12.04.2,
we don't have an explicit test case for it at that time.

But I know it's working on 201208-11537, which is unfortunately dead now
With the keyboard module swapped, the Trackpoint on the keyboard from 11537 does not work on 11536, I would say maybe it's a hardware issue. (if it cannot be reproduced on the same model)

Changed in linux-lts-trusty (Ubuntu):
status: Incomplete → Confirmed
Anthony Wong (anthonywong) wrote :

ok, I am assigning to Keng-yu to check if it is really hardware issue.

Changed in linux-lts-trusty (Ubuntu):
assignee: Anthony Wong (anthonywong) → Keng-Yu Lin (lexical)
Keng-Yu Lin (lexical) on 2014-08-14
Changed in linux-lts-trusty (Ubuntu):
importance: Undecided → High
Keng-Yu Lin (lexical) wrote :

[ 7.944895] input: DualPoint Stick as /devices/platform/i8042/serio1/input/input10
[ 7.957803] input: AlpsPS/2 ALPS DualPoint TouchPad as /devices/platform/i8042/serio1/input/input7

Keng-Yu Lin (lexical) on 2014-08-14
Changed in linux-lts-trusty (Ubuntu):
importance: High → Medium
Anthony Wong (anthonywong) wrote :

@lexical, what is your finding on this issue?

Changed in hwe-next:
assignee: nobody → Keng-Yu Lin (lexical)
Keng-Yu Lin (lexical) on 2015-01-28
Changed in hwe-next:
status: New → Confirmed
importance: Undecided → Medium
Keng-Yu Lin (lexical) on 2015-05-15
Changed in linux-lts-trusty (Ubuntu):
assignee: Keng-Yu Lin (lexical) → nobody
Changed in hwe-next:
assignee: Keng-Yu Lin (lexical) → AceLan Kao (acelankao)
Changed in hwe-next:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers