[Dell Precision T7600] Errors in found dmesg

Bug #1286979 reported by Po-Hsu Lin on 2014-03-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-lts-trusty (Ubuntu)
Medium
Unassigned

Bug Description

CID: 201109-9790 Dell Precision T7600

There are some errors reported in the demsg log, most of them are HDD-releated messages:

ubuntu@201109-9790:/var/log$ cat dmesg | grep -i error
[ 0.646197] ioapic: probe of 0000:00:05.4 failed with error -22
[ 1.821530] sas: ata7: end_device-0:0: dev error handler
[ 8.778074] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[ 13.470149] sas: sas_ata_task_done: SAS error 2
[ 13.470168] sas: ata7: end_device-0:0: cmd error handler
[ 13.470205] sas: ata7: end_device-0:0: dev error handler
[ 13.470221] ata7.00: error: { ABRT }

Please find attachment for the dmesg report

Not sure if this is a blocker, I still have the tags added here.

* Debugging information:
ubuntu@201109-9790:/var/log$ sudo smartctl -H /dev/sda
smartctl 5.41 2011-06-09 r3365 [x86_64-linux-3.11.0-15-generic] (local build)
Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

ubuntu@201109-9790:/var/log$ sudo smartctl -A /dev/sda
smartctl 5.41 2011-06-09 r3365 [x86_64-linux-3.11.0-15-generic] (local build)
Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF READ SMART DATA SECTION ===
SMART Attributes Data Structure revision number: 10
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate 0x000f 116 099 006 Pre-fail Always - 107603597
  3 Spin_Up_Time 0x0003 097 097 000 Pre-fail Always - 0
  4 Start_Stop_Count 0x0032 098 098 020 Old_age Always - 2808
  5 Reallocated_Sector_Ct 0x0033 100 100 036 Pre-fail Always - 0
  7 Seek_Error_Rate 0x000f 067 060 030 Pre-fail Always - 5709068
  9 Power_On_Hours 0x0032 099 099 000 Old_age Always - 1523
 10 Spin_Retry_Count 0x0013 100 100 097 Pre-fail Always - 0
 12 Power_Cycle_Count 0x0032 099 099 020 Old_age Always - 1405
183 Runtime_Bad_Block 0x0032 100 100 000 Old_age Always - 0
184 End-to-End_Error 0x0032 100 100 099 Old_age Always - 0
187 Reported_Uncorrect 0x0032 100 100 000 Old_age Always - 0
188 Command_Timeout 0x0032 100 100 000 Old_age Always - 0
189 High_Fly_Writes 0x003a 100 100 000 Old_age Always - 0
190 Airflow_Temperature_Cel 0x0022 064 053 045 Old_age Always - 36 (Min/Max 36/36)
194 Temperature_Celsius 0x0022 036 047 000 Old_age Always - 36 (0 15 0 0)
195 Hardware_ECC_Recovered 0x001a 037 031 000 Old_age Always - 107603597
197 Current_Pending_Sector 0x0012 100 100 000 Old_age Always - 0
198 Offline_Uncorrectable 0x0010 100 100 000 Old_age Offline - 0
199 UDMA_CRC_Error_Count 0x003e 200 200 000 Old_age Always - 0
240 Head_Flying_Hours 0x0000 100 253 000 Old_age Offline - 265617957458548
241 Total_LBAs_Written 0x0000 100 253 000 Old_age Offline - 1846753461
242 Total_LBAs_Read 0x0000 100 253 000 Old_age Offline - 1688930558

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.11.0-15-generic 3.11.0-15.25~precise1 [modified: boot/vmlinuz-3.11.0-15-generic]
ProcVersionSignature: Ubuntu 3.11.0-15.25~precise1-generic 3.11.10
Uname: Linux 3.11.0-15-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version k3.11.0-15-generic.
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 2091 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 2091 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf3520000 irq 89'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:10ec0269,10280495,00100100'
   Controls : 25
   Simple ctrls : 11
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xf3080000 irq 36'
   Mixer name : 'Nvidia GPU 0b HDMI/DP'
   Components : 'HDA:10de000b,10de0101,00100200'
   Controls : 28
   Simple ctrls : 4
Date: Sun Mar 2 22:33:20 2014
HibernationDevice: RESUME=UUID=c5379217-7d04-475e-9c7b-c773c7d2da61
InstallationMedia: Ubuntu 12.04.4 LTS "Precise Pangolin" - Release amd64 (20140204)
IwConfig:
 eth0 no wireless extensions.

 eth1 no wireless extensions.

 lo no wireless extensions.
MachineType: Dell Inc. Precision T7600
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-15-generic root=UUID=134f0c39-44ec-4e04-9a32-2bc9df654779 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-15-generic N/A
 linux-backports-modules-3.11.0-15-generic N/A
 linux-firmware 1.79.9
RfKill:

SourcePackage: linux-lts-saucy
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/25/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 7
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd10/25/2012:svnDellInc.:pnPrecisionT7600:pvr01:rvnDellInc.:rn:rvr:cvnDellInc.:ct7:cvr:
dmi.product.name: Precision T7600
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

Po-Hsu Lin (cypressyew) wrote :
tags: added: apport-bug blocks-hwcert-enablement
removed: blocks-happort-bug
Daniel Manrique (roadmr) on 2014-03-03
Changed in linux-lts-saucy (Ubuntu):
importance: Undecided → Medium
Changed in linux-lts-saucy (Ubuntu):
assignee: Anthony Wong (anthonywong) → Alex Hung (alexhung)
Alex Hung (alexhung) wrote :

From the error code = -22 (#define EINVAL 22 /* Invalid argument */), this seems to be a driver or hardware issue but not a BIOS issue.

We will need someone who is specified in sata protocol for further investigation.

Alex Hung (alexhung) on 2014-03-27
Changed in linux-lts-saucy (Ubuntu):
assignee: Alex Hung (alexhung) → nobody
Hui Wang (hui.wang) wrote :

From the dmesg, I found the disk (sda) is a SATA 3 disk, the ahci driver will cover this kind of disk. While all errors were reported from sas driver (serial scsi driver, intel isci driver). so from my point of view, it is not a big problem since we don't have a sas disk installed on the machine.

I don't why sas driver will send command to a SATA disk, maybe latest kernel already fix it. It is worth to install a 3.13 kernel to test again.

Ara Pulido (ara) on 2014-04-04
tags: removed: blocks-hwcert blocks-hwcert-enablement
Po-Hsu Lin (cypressyew) wrote :

I opened up the chassis to double confirm that it's the SATA HDD,
not the SAS HDD in this system, but this HDD is connected to the
motherboard with a SAS adapter and a SAS cable.

tested with the daily-live kernel (3.14.0-999, 2014 Apr. 6)
the error still exist
ubuntu@201109-9790:/var/log$ cat dmesg | grep -i error
[ 0.646206] ioapic: probe of 0000:00:05.4 failed with error -22
[ 1.967203] sas: ata7: end_device-0:0: dev error handler
[ 8.272512] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[ 12.687013] sas: ata7: end_device-0:0: cmd error handler
[ 12.687045] sas: ata7: end_device-0:0: dev error handler

tags: added: bios-outdated-a11
affects: linux-lts-saucy (Ubuntu) → linux-lts-trusty (Ubuntu)
To post a comment you must log in.