[HP Pavilion14] Touchpad was detected as PS/2 mouse

Bug #1256213 reported by Po-Hsu Lin on 2013-11-29
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux
Unknown
Unknown
linux-lts-raring (Ubuntu)
Medium
Adam Lee

Bug Description

CID: 201307-13904 HP Pavilion 14

The touchpad on this system was detected as a PS/2 mouse.

Steps:
1. Install 12.04.3 + update (3.8.0-33), boot to desktop
2. Try to do edge scrolling.

Expected result:
- Edge scrolling should work.

Actual result:
- The touchpad was detected as PS/2 mouse, edge scrolling won't work

Debugging information:
$ xinput
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Generic Mouse id=11 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ HP Truevision HD id=9 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=10 [slave keyboard (3)]
    ↳ HP WMI hotkeys id=12 [slave keyboard (3)]

in /proc/bus/input/devices, the touchpad was detected as "PS/2 Generic Mouse"

in dmesg, it seems that the ALPS touchpad was not recognized:
[ 9.760610] psmouse serio1: alps: Unknown ALPS touchpad: E7=73 03 50, EC=73 02 02

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.8.0-33-generic 3.8.0-33.48~precise1
ProcVersionSignature: Ubuntu 3.8.0-33.48~precise1-generic 3.8.13.11
Uname: Linux 3.8.0-33-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version k3.8.0-33-generic.
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: Generic [HD-Audio Generic], device 0: ALC282 Analog [ALC282 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 1728 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 1728 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'HDMI'/'HDA ATI HDMI at 0xf0344000 irq 47'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100300'
   Controls : 7
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xf0340000 irq 16'
   Mixer name : 'Realtek ALC282'
   Components : 'HDA:10ec0282,103c2169,00100003'
   Controls : 20
   Simple ctrls : 9
Date: Thu Nov 28 22:44:59 2013
HibernationDevice: RESUME=UUID=803edd91-ef6d-41c5-835c-65db44b01055
InstallationMedia: Ubuntu 12.04.3 LTS "Precise Pangolin" - Release amd64 (20130820.1)
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
MachineType: Hewlett-Packard HP Pavilion 14 Notebook PC
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-33-generic root=UUID=e37c0bc3-93c5-4bcf-9e05-8d76ddb1455a ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-33-generic N/A
 linux-backports-modules-3.8.0-33-generic N/A
 linux-firmware 1.79.7
RfKill:

SourcePackage: linux-lts-raring
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/12/2013
dmi.bios.vendor: Insyde
dmi.bios.version: B.0C
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 2169
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 30.0F
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrB.0C:bd07/12/2013:svnHewlett-Packard:pnHPPavilion14NotebookPC:pvr088E100000005910000630100:rvnHewlett-Packard:rn2169:rvr30.0F:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion 14 Notebook PC
dmi.product.version: 088E100000005910000630100
dmi.sys.vendor: Hewlett-Packard

Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) wrote :

Verified with the latest mainline kernel (3.13-rc1)
Kernel panic occurred, unable to test

Anthony Wong (anthonywong) wrote :

How about 3.12?

Po-Hsu Lin (cypressyew) wrote :

Verified with 3.12.2, system will be boot in low-graphic mode.
And with 3.11.10, system will hang on boot due to some modules failed to load

Po-Hsu Lin (cypressyew) wrote :

Hello Anthony,
 I tried again with the proprietary driver, now it can be boot to the desktop with 3.13-rc2 and 3.12.2
 However, the touchpad still recognized as a PS/2 mouse.

So please ignore comment #4

Po-Hsu Lin (cypressyew) wrote :

Also affects 201304-13249 HP HP Pavilion 14
With the same message in dmesg:
psmouse serio1: alps: Unknown ALPS touchpad: E7=73 03 50, EC=73 02 02

tags: added: 201304-13249
Po-Hsu Lin (cypressyew) wrote :

Also affects 201303-13115 HP Pavilion 14

As requested from upstream,
I've also verified with Win 7 Ent. Sp1 on 201303-13115,
I'm not sure how to debug this in windows, but according to device manager, the touchpad was detected as PS/2 Compatible Mouse as well

For 201303-13115, 201304-13249 and 201307-13904 the udev resource attachment from pre-install image shows:
path: /devices/virtual/input/input14
bus: input
category: KEYBOARD
product_id: 0
vendor_id: 0
product: GlidePoint Virtual Touchpad

Maybe this is the real name for it?

tags: added: 201303-13115
Daniel Manrique (roadmr) on 2014-01-17
Changed in linux-lts-raring (Ubuntu):
importance: Undecided → Medium
Anthony Wong (anthonywong) wrote :

@PHLin
Can you check if the pre-install image has any Alps glidepoint driver package installed? If so, what is the udev output when it is removed from the system?

Po-Hsu Lin (cypressyew) wrote :

Hello Anthony,
Tried with the GM OEM image on the very same hardware, but it still detected as PS/2 mouse

QA engineer said that sometimes the touchpad cannot be correctly detected, you have to reboot or recovery, I tried but no luck.

Also, I found two packages for alps
oem-input-alps-1101112
oem-touchpad-alps-detect-1101112
and 2 for synaptics
oem-input-synaptics-1057412
xserver-xorg-input-synaptics-lts-quantal

Po-Hsu Lin (cypressyew) wrote :

Also affect 201308-14040 HP Pavilion 14
psmouse serio1: alps: Unknown ALPS touchpad: E7=73 03 50, EC=73 02 02

Since vertical scrolling is now a blocker for 12.04.4, I will add the necessary tags.

Maybe this bug is identical to bug 1190867 ?

tags: added: 201308-14040 blocks-hwcert blocks-hwcert-enablement
Changed in linux-lts-raring (Ubuntu):
assignee: Anthony Wong (anthonywong) → Adam Lee (adam8157)
Adam Lee (adam8157) wrote :

Yes, it's the same issue as Bug 1190867.

lts-raring will be end-of-life soon, and we already missed the last day for kernel commits for last lts-raring cycle. should it be Won't fix?

Anthony Wong (anthonywong) wrote :

@PHlin
Are you looking for a fix for 12.04.4 as well?

Po-Hsu Lin (cypressyew) wrote :

@Anthony
For now, yes
But I think we're ok to certify it with 14.04
Thanks!

Adam Lee (adam8157) wrote :

@PHlin

Hi, unfortunately, it's not possible to fix this on 12.04.4 as #13 saying.

I will close linux-lts-raring branch as Won't fix. Please you test it on 14.04(same as Bug 1190867, no need?) and close this bug, thanks.

Changed in linux-lts-raring (Ubuntu):
status: New → Won't Fix
Adam Lee (adam8157) wrote :

amend for #16, not possible to fix this on lts-quantal, lts-raring and lts-saucy, they are all EOL or missed the last day for kernel commits for last cycle.

Ara Pulido (ara) wrote :

This was a mistake.

Last SRU cycle including lts backports starts the 24th of July, so we still have plenty of time.

Reopening this one, as it is quite important to have it fixed.

Changed in linux-lts-raring (Ubuntu):
status: Won't Fix → New
Adam Lee (adam8157) on 2014-04-29
Changed in linux-lts-raring (Ubuntu):
status: New → In Progress
Adam Lee (adam8157) wrote :

"[lts-backport-raring][PATCH] Input: ALPS - add support for "Dolphin" devices" has been sent to kernel-team@

Tim Gardner (timg-tpi) on 2014-04-30
Changed in linux-lts-raring (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (17.9 KiB)

This bug was fixed in the package linux-lts-raring - 3.8.0-41.60~precise1

---------------
linux-lts-raring (3.8.0-41.60~precise1) precise; urgency=low

  [ Kamal Mostafa ]

  * Revert "rtlwifi: Set the link state"
    - LP: #1289429
    - LP: #1319735
  * Release Tracking Bug
    - re-used previous tracking bug

linux-lts-raring (3.8.0-41.59~precise1) precise; urgency=low

  [ Kamal Mostafa ]

  * Merged back Ubuntu-3.8.0-39.58 security release
  * Revert: "n_tty: Fix n_tty_write crash when echoing in raw mode"
    - LP: #1317242
  * Release Tracking Bug
    - LP: #1317246

  [ Upstream Kernel Changes ]

  * Input: ALPS - add support for "Dolphin" devices
    - LP: #1256213
  * n_tty: Fix n_tty_write crash when echoing in raw mode
    - LP: #1317242
    - LP: #1314762
    - CVE-2014-0196
  * floppy: ignore kernel-only members in FDRAWCMD ioctl input
    - LP: #1317242
    - LP: #1316729
    - CVE-2014-1737
  * floppy: don't write kernel-only members to FDRAWCMD ioctl output
    - LP: #1317242
    - LP: #1316735
    - CVE-2014-1738
  * Linux 3.8.13.23
    - LP: #1317242

linux-lts-raring (3.8.0-40.58~precise1) precise; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1314348

  [ Upstream Kernel Changes ]

  * Revert "sparc64: Fix __copy_{to,from}_user_inatomic defines."
    - LP: #1313767
  * rds: prevent dereference of a NULL device in rds_iw_laddr_check
    - LP: #1302222
    - CVE-2014-2678
  * 6lowpan: fix lockdep splats
    - LP: #1307561
  * 9p/trans_virtio.c: Fix broken zero-copy on vmalloc() buffers
    - LP: #1307561
  * ipv4: Fix runtime WARNING in rtmsg_ifa()
    - LP: #1307561
  * net: fix 'ip rule' iif/oif device rename
    - LP: #1307561
  * net: qmi_wwan: add Netgear Aircard 340U
    - LP: #1307561
  * tcp: tsq: fix nonagle handling
    - LP: #1307561
  * tg3: Fix deadlock in tg3_change_mtu()
    - LP: #1307561
  * net: asix: add missing flag to struct driver_info
    - LP: #1307561
  * bonding: 802.3ad: make aggregator_identifier bond-private
    - LP: #1307561
  * ipv4: fix counter in_slow_tot
    - LP: #1307561
  * net: sctp: fix sctp_connectx abi for ia32 emulation/compat mode
    - LP: #1307561
  * net: add and use skb_gso_transport_seglen()
    - LP: #1307561
  * net: core: introduce netif_skb_dev_features
    - LP: #1307561
  * net: ip, ipv6: handle gso skbs in forwarding path
    - LP: #1307561
  * net: use __GFP_NORETRY for high order allocations
    - LP: #1307561
  * net-tcp: fastopen: fix high order allocations
    - LP: #1307561
  * virtio-net: alloc big buffers also when guest can receive UFO
    - LP: #1307561
  * ipv6: reuse ip6_frag_id from ip6_ufo_append_data
    - LP: #1307561
  * sfc: check for NULL efx->ptp_data in efx_ptp_event
    - LP: #1307561
  * ipv6: ipv6_find_hdr restore prev functionality
    - LP: #1307561
  * tg3: Don't check undefined error bits in RXBD
    - LP: #1307561
  * net: sctp: fix sctp_sf_do_5_1D_ce to verify if we/peer is AUTH capable
    - LP: #1307561
  * mac80211: send control port protocol frames to the VO queue
    - LP: #1307561
  * mac80211: fix AP powersave TX vs. wakeup race
    - LP: #1307561
  * iwlwifi: dvm: clear IWL_STA_UCODE_INPROGRESS when asso...

Changed in linux-lts-raring (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.