Ubuntu

kernel headers are missing from 3.8

Reported by seph on 2013-02-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-lts-raring (Ubuntu)
Medium
Unassigned
Precise
Undecided
Tim Gardner

Bug Description

I'm sorry if I'm reporting this in the wrong place.... This is installed via the xswat archives, and I can't really tell how I'm suppose to report bugs.

Anyhow, I think the kernel headers package is incomplete. It seems to be missing content from /usr/src/linux-headers-3.8.0.7/

seph@lts$ dpkg -s linux-generic-lts-raring | grep Status
Status: install ok installed
seph@lts$ dpkg -s linux-headers-3.8.0-7 | grep Status
Status: install ok installed

seph@lts$ ls -l /usr/src/linux-headers-3.8.0*/Makefile
lrwxrwxrwx 1 root root 33 Feb 26 12:36 /usr/src/linux-headers-3.8.0-7-generic/Makefile -> ../linux-headers-3.8.0-7/Makefile

seph@lts$ ls -l /usr/src/linux-headers-3.8.0-7
ls: cannot access /usr/src/linux-headers-3.8.0-7: No such file or directory

seph@lts$ dpkg -L linux-headers-3.8.0-7
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/linux-headers-3.8.0-7
/usr/share/doc/linux-headers-3.8.0-7/copyright
/usr/share/doc/linux-headers-3.8.0-7/changelog.Debian.gz

So where's /usr/src/linux-headers-3.8.0-7/Makefile

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1134441

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: raring
seph (seph) wrote :

I can't run apport-collect on this server. I can probably find other information if there's a specific question.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
Andy Whitcroft (apw) wrote :

The master raring ones seem ok and have the headers, so this seems specific to the lts kernel only.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Tim Gardner (timg-tpi) on 2013-02-28
affects: linux (Ubuntu Precise) → linux-lts-raring (Ubuntu Precise)
Changed in linux-lts-raring (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux-lts-raring (Ubuntu):
status: Triaged → Invalid
Tim Gardner (timg-tpi) on 2013-03-05
Changed in linux-lts-raring (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers