linux-generic-lts-quantal is missing linux-tools

Bug #1088454 reported by H.-Dirk Schmitt on 2012-12-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-lts-quantal (Ubuntu)
Medium
Tim Gardner
Precise
Undecided
Unassigned
linux-meta-lts-quantal (Ubuntu)
Undecided
Tim Gardner
Precise
Undecided
Unassigned

Bug Description

In precise is only linux-tools pointing to linux-tools-3.2.0-* available.

The description notes:

> This package provides the architecture dependant parts for kernel
> version locked tools (such as perf and x86_energy_perf_policy) for
> version 3.2.0-34 on
> 64 bit x86.

Try to use the linux-tools rise the following error:

> $ x86_energy_perf_policy
> x86_energy_perf_policy_3.5.0-19 not found
> You may need to install linux-tools-3.5.0-19
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.0.1-0ubuntu17
Architecture: amd64
AudioDevicesInUse:
 BEN. PID ZUGR. BEFEHL
 /dev/snd/controlC1: dirk 8309 F.... pulseaudio
 /dev/snd/controlC0: dirk 8309 F.... pulseaudio
 /dev/snd/pcmC0D0p: dirk 8309 F...m pulseaudio
CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfdff4000 irq 16'
   Mixer name : 'Realtek ALC889'
   Components : 'HDA:10ec0889,1458a102,00100004'
   Controls : 51
   Simple ctrls : 22
Card1.Amixer.info:
 Card hw:1 'U0x46d0x802'/'USB Device 0x46d:0x802 at usb-0000:00:12.2-4.2, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0802'
   Controls : 2
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 6144
   Mono: Capture 6144 [100%] [30.00dB] [on]
DistroRelease: Ubuntu 12.04
HibernationDevice:
 # regenerated Fri, 11 May 2012 00:24:40 +0200
 # $HeadURL: svn://svn.computer42.org:3691/c42CfgRepos/trunk/etc/c42CfgRepos/data/initramfs-tools/conf.d/resume.dilbert $
 # $Revision: 5358 $ $Date: 2012-06-25 10:12:24 +0200 (Mon, 25 Jun 2012) $
 # $Author: root@garfield $
 RESUME=UUID=b7459bbd-b448-499d-a587-881ee3f453ec
IwConfig: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
MachineType: Gigabyte Technology Co., Ltd. GA-890FXA-UD5
MarkForUpload: True
Package: linux (not installed)
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.5.0-19-generic root=/dev/mapper/system-root ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.5.0-19.30~precise1-generic 3.5.7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-19-generic N/A
 linux-backports-modules-3.5.0-19-generic N/A
 linux-firmware 1.79.1
RfKill: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
Tags: precise
UdevDb: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
Uname: Linux 3.5.0-19-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserAsoundrc:
 # ALSA library configuration file

 # Include settings that are under the control of asoundconf(1).
 # (To disable these settings, comment out this line.)
 </c42home/dirk/.asoundrc.asoundconf>
UserGroups: adm audio cdrom plugdev users video
dmi.bios.date: 07/23/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F4
dmi.board.name: GA-890FXA-UD5
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF4:bd07/23/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-890FXA-UD5:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-890FXA-UD5:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-890FXA-UD5
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

apt-cache search linux-tools

linux-tools - Linux kernel versioned Tools
linux-tools-3.2.0-23 - Linux kernel version specific tools for version 3.2.0-23
linux-tools-3.2.0-24 - Linux kernel version specific tools for version 3.2.0-24
linux-tools-3.2.0-25 - Linux kernel version specific tools for version 3.2.0-25
linux-tools-3.2.0-26 - Linux kernel version specific tools for version 3.2.0-26
linux-tools-3.2.0-27 - Linux kernel version specific tools for version 3.2.0-27
linux-tools-3.2.0-29 - Linux kernel version specific tools for version 3.2.0-29
linux-tools-3.2.0-30 - Linux kernel version specific tools for version 3.2.0-30
linux-tools-3.2.0-31 - Linux kernel version specific tools for version 3.2.0-31
linux-tools-3.2.0-32 - Linux kernel version specific tools for version 3.2.0-32
linux-tools-3.2.0-33 - Linux kernel version specific tools for version 3.2.0-33
linux-tools-3.2.0-34 - Linux kernel version specific tools for version 3.2.0-34
linux-tools-common - Linux kernel version specific tools for version 3.2.0
linux-tools-3.2.0-35 - Linux kernel version specific tools for version 3.2.0-35

tags: added: backport precise
description: updated

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1088454

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

The bug described an missing dependency / missing package.
It is not an defect of the software correlated to the system.

So skip the last 20-21 comments as policy enforced bloated ballast ;-)

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key
Tim Gardner (timg-tpi) on 2012-12-11
affects: linux (Ubuntu) → linux-lts-quantal (Ubuntu)
Changed in linux-lts-quantal (Ubuntu):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → In Progress
Tim Gardner (timg-tpi) on 2013-01-14
Changed in linux-meta-lts-quantal (Ubuntu):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Tim Gardner (timg-tpi) on 2013-01-15
Changed in linux-lts-quantal (Ubuntu):
status: In Progress → Fix Committed
Changed in linux-lts-quantal (Ubuntu Precise):
status: New → Fix Committed
Changed in linux-lts-quantal (Ubuntu):
status: Fix Committed → Invalid
Changed in linux-meta-lts-quantal (Ubuntu Precise):
status: New → In Progress
Changed in linux-meta-lts-quantal (Ubuntu):
status: In Progress → Invalid
Luis Henriques (henrix) wrote :

I can confirm the linux-tools-lts-quantal package is now available in Precise:

$ apt-cache search linux-tools
linux-tools - Linux kernel versioned Tools
linux-tools-3.2.0-23 - Linux kernel version specific tools for version 3.2.0-23
linux-tools-3.2.0-24 - Linux kernel version specific tools for version 3.2.0-24
linux-tools-3.2.0-25 - Linux kernel version specific tools for version 3.2.0-25
linux-tools-3.2.0-26 - Linux kernel version specific tools for version 3.2.0-26
linux-tools-3.2.0-27 - Linux kernel version specific tools for version 3.2.0-27
linux-tools-3.2.0-29 - Linux kernel version specific tools for version 3.2.0-29
linux-tools-3.2.0-30 - Linux kernel version specific tools for version 3.2.0-30
linux-tools-3.2.0-31 - Linux kernel version specific tools for version 3.2.0-31
linux-tools-3.2.0-32 - Linux kernel version specific tools for version 3.2.0-32
linux-tools-3.2.0-33 - Linux kernel version specific tools for version 3.2.0-33
linux-tools-3.2.0-34 - Linux kernel version specific tools for version 3.2.0-34
linux-tools-3.2.0-35 - Linux kernel version specific tools for version 3.2.0-35
linux-tools-3.2.0-36 - Linux kernel version specific tools for version 3.2.0-36
linux-tools-common - Linux kernel version specific tools for version 3.2.0
linux-tools-3.2.0-37 - Linux kernel version specific tools for version 3.2.0-37
linux-tools-3.5.0-23 - Linux kernel version specific tools for version 3.5.0-23
linux-tools-lts-quantal - Linux kernel versioned Tools

Tagging bug as verified.

tags: added: verification-done-precise

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-lts-quantal - 3.5.0-23.35~precise1

---------------
linux-lts-quantal (3.5.0-23.35~precise1) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1105149

  [ Tim Gardner ]

  * UBUNTU: [Config] Build binary dependent tools package
    - LP: #1088454

  [ Upstream Kernel Changes ]

  * Revert "fsnotify: change locking order"
    - LP: #1101666
  * Revert "fsnotify: dont put marks on temporary list when clearing marks
    by group"
    - LP: #1101666
  * Revert "fsnotify: introduce locked versions of fsnotify_add_mark() and
    fsnotify_remove_mark()"
    - LP: #1101666
  * Revert "fsnotify: pass group to fsnotify_destroy_mark()"
    - LP: #1101666
  * Revert "fsnotify: use a mutex instead of a spinlock to protect a groups
    mark list"
    - LP: #1101666
  * Revert "fanotify: add an extra flag to mark_remove_from_mask that
    indicates wheather a mark should be destroyed"
    - LP: #1101666
  * Revert "fsnotify: take groups mark_lock before mark lock"
    - LP: #1101666
  * Revert "fsnotify: use reference counting for groups"
    - LP: #1101666
  * Revert "fsnotify: introduce fsnotify_get_group()"
    - LP: #1101666
  * radeon/kms: force rn50 chip to always report connected on analog output
    - LP: #1103320
 -- Luis Henriques <email address hidden> Fri, 25 Jan 2013 16:13:29 +0000

Changed in linux-lts-quantal (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta-lts-quantal - 3.5.0.23.30

---------------
linux-meta-lts-quantal (3.5.0.23.30) precise-proposed; urgency=low

  [ Luis Henriques ]

  * Ubuntu-lts-3.5.0-23.35

  [ Tim Gardner ]

  * UBUNTU: [Config] Build binary dependent tools package
    - LP: #1088454
 -- Luis Henriques <email address hidden> Fri, 25 Jan 2013 16:21:18 +0000

Changed in linux-meta-lts-quantal (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers