EDID information on IGEPv2 not exported to userspace

Bug #654594 reported by Mathieu Poirier on 2010-10-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-linaro (Ubuntu)
Undecided
Mathieu Poirier
Maverick
Undecided
Unassigned

Bug Description

EDID information needs to be exported to userspace in order to be processed by 'decode-edid' and 'parse-edid'.

Changed in linux (Ubuntu):
assignee: nobody → Mathieu Poirier (mathieu.poirier)

SRU Justification:

Impact: This patch is part of a series of fix for the IGEPv2 board. The monitor's EDID information needs to be exported to userspace for application such as 'decode-edid' and 'parse-edid' to decode.

Fix: To do this a 3rd "i2c_board_info" instance is declared and initialized in "igep2_i2c_init", part of the board initialization sequence. This patch depends on [PATCH 4/6], applied to BugLink: https://bugs.launchpad.net/bugs/654590.

Testcase: Without this patch, 'decode-edid' and 'parse-edid' will return error messages. Otherwise the monitor' specific EDID information is displayed.

SRU Justification:

Impact: This patch is part of a series of fix for the IGEPv2 board. The monitor's EDID information needs to be exported to userspace for application such as 'decode-edid' and 'parse-edid' to decode.

Fix: To do this a 3rd "i2c_board_info" instance is declared and initialized in "igep2_i2c_init", part of the board initialization sequence.

Testcase: Without this patch, 'decode-edid' and 'parse-edid' will return error messages. Otherwise the monitor' specific EDID information is displayed.

Accepted linux-linaro into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

affects: linux (Ubuntu) → linux-linaro (Ubuntu)
Changed in linux-linaro (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted linux into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by Thursday, November 11, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Launchpad Janitor (janitor) wrote :
Download full text (4.9 KiB)

This bug was fixed in the package linux-linaro - 2.6.35-1008.15

---------------
linux-linaro (2.6.35-1008.15) maverick-proposed; urgency=low

  [ Robert Nelson ]

  * SRU: Fix DVI for Beagle xM rev A3
    - LP: #663642

linux-linaro (2.6.35-1008.14) maverick-proposed; urgency=low

  [ Andy Whitcroft ]

  * reduce disk usage during buildd builds
    - LP: #645653

  [ Enric Balletbo i Serra ]

  * ARM: igepv2: Adding support for VBUS and overcurrent
    - LP: #651589
  * ARM: igepv2: Fix and improve LED handling
    - LP: #654582
  * ARM: igepv2: Introduce function to dectect HW version
    - LP: #654586
  * ARM: igepv2: Fix handling of GPIOs for WLAN-BT combo
    - LP: #654590
  * ARM: igepv2: Add i2c eeprom driver to read EDID
    - LP: #654594
  * ARM: igepv2: Remove VMMC2 regulator
    - LP: #654595

  [ Maurus Cuelenaere ]

  * SAUCE: ARM: OMAP3: Add S-Video output to IGEPv2 board
    - LP: #607250

  [ Upstream Stable ]
  * Linux 2.6.35.7

  [ Upstream MMC updates ]

  * mmc: recognize CSD structure
  * mmc: split mmc_sd_init_card()
  * mmc: implement SD-combo (IO+mem) support
  * sdhci: remove useless set_clock() check
  * sdhci: 8-bit data transfer width support
  * sdhci: don't assign mmc->caps at SDHCI directly
  * mmc: only set blockaddressed for > 2GiB cards
  * mmc: omap: fix for bus width which improves SD card's peformance.
  * sdhci-pltfm: switch to module device table matching
  * sdhci-pltfm: reorganize Makefile entries to support SoC devices
  * sdhci-pltfm: add support for CNS3xxx SoC devices
  * omap hsmmc: fix processing of all dma interrupts as block completion
  * sdhci: add regulator support
  * sdhci: add no hi-speed bit quirk support
  * mmc: avoid getting CID on SDIO-only cards
  * omap_hsmmc: remove unused local `state'
  * omap hsmmc: fix a racing case between kmmcd and omap_hsmmc_suspend
  * drivers/mmc/host/imxmmc.c: adjust confusing if indentation
  * mmc: sdhci-pltfm: Add structure for host-specific data
  * mmc: sdhci-pltfm: move .h file into appropriate subdir
  * mmc: sdhci: introduce get_ro private write-protect hook
  * mmc: sdhci_pltfm: pass more data on custom init call
  * mmc: sdhci-of-esdhc: factor out common stuff
  * mmc: sdhci-pltfm: add -pltfm driver for imx35/51
  * mmc: quirk fix for timeout problem
  * babbage: esdhc device registration
  * babbage: update mx51_defconfig
    - LP: #656966

  [ Upstream ARM fixes ]

  * Make PTRACE_SINGLESTEP work with user helpers
  * ARM: fix section mismatch warnings in Versatile Express
  * ARM: use memblock to remove memory from available memory
  * video: omap: vram: remove from normal memory
    - LP: #627779

  [ John Rigby ]
  * LINARO: update configs
    - LP: #659799

linux-linaro (2.6.35-1007.13) maverick; urgency=low

  [ Upstream Ubuntu ]

  * Ubuntu-2.6.35-22.33
  * Ubuntu-2.6.35-22.34

  [ Upstream ARM Fixes ]

  * ARM: vexpress: set RAM latencies to 1 cycle for PL310 on ct-ca9x4 tile
  * ARM: vexpress: set RAM latencies to 1 cycle for PL310 on ct-ca9x4 tile
  * ARM: add a vma entry for the user accessible vector page
  * ARM: plug a race with the alignment trap handler
  * arm: fix really nasty sigreturn bug
  * ARM: prevent multiple syscall ...

Read more...

Changed in linux-linaro (Ubuntu Maverick):
status: Fix Committed → Fix Released
Download full text (6.8 KiB)

Tested on:

ubuntu@ubuntu:~$ uname -a
Linux ubuntu 2.6.35-1008-linaro-omap #15-Ubuntu Fri Oct 22 11:56:29
UTC 2010 armv7l GNU/Linux

root@ubuntu:/home/ubuntu# modprobe eeprom
root@ubuntu:/home/ubuntu# decode-edid
decode-edid: using bus 3 (autodetected)
decode-edid: decode-edid version 1.1
parse-edid: parse-edid version 2.0.0
parse-edid: EDID checksum passed.

 # EDID version 1 revision 3
Section "Monitor"
 # Block type: 2:0 3:fd
 # Block type: 2:0 3:fc
 Identifier "SyncMaster"
 VendorName "SAM"
 ModelName "SyncMaster"
 # Block type: 2:0 3:fd
 HorizSync 30-81
 VertRefresh 56-75
 # Max dot clock (video bandwidth) 140 MHz
 # Block type: 2:0 3:fc
 # Block type: 2:0 3:ff
 # DPMS capabilities: Active off:yes Suspend:no Standby:no

 Mode "1680x1050" # vfreq 59.883Hz, hfreq 64.674kHz
  DotClock 119.000000
  HTimings 1680 1728 1760 1840
  VTimings 1050 1053 1059 1080
  Flags "-HSync" "+VSync"
 EndMode
 # Block type: 2:0 3:fd
 # Block type: 2:0 3:fc
 # Block type: 2:0 3:ff
EndSection

2010/11/8 Launchpad Bug Tracker <email address hidden>:
> This bug was fixed in the package linux-linaro - 2.6.35-1008.15
>
> ---------------
> linux-linaro (2.6.35-1008.15) maverick-proposed; urgency=low
>
>  [ Robert Nelson ]
>
>  * SRU: Fix DVI for Beagle xM rev A3
>    - LP: #663642
>
> linux-linaro (2.6.35-1008.14) maverick-proposed; urgency=low
>
>  [ Andy Whitcroft ]
>
>  * reduce disk usage during buildd builds
>    - LP: #645653
>
>  [ Enric Balletbo i Serra ]
>
>  * ARM: igepv2: Adding support for VBUS and overcurrent
>    - LP: #651589
>  * ARM: igepv2: Fix and improve LED handling
>    - LP: #654582
>  * ARM: igepv2: Introduce function to dectect HW version
>    - LP: #654586
>  * ARM: igepv2: Fix handling of GPIOs for WLAN-BT combo
>    - LP: #654590
>  * ARM: igepv2: Add i2c eeprom driver to read EDID
>    - LP: #654594
>  * ARM: igepv2: Remove VMMC2 regulator
>    - LP: #654595
>
>  [ Maurus Cuelenaere ]
>
>  * SAUCE: ARM: OMAP3: Add S-Video output to IGEPv2 board
>    - LP: #607250
>
>  [ Upstream Stable ]
>  * Linux 2.6.35.7
>
>  [ Upstream MMC updates ]
>
>  * mmc: recognize CSD structure
>  * mmc: split mmc_sd_init_card()
>  * mmc: implement SD-combo (IO+mem) support
>  * sdhci: remove useless set_clock() check
>  * sdhci: 8-bit data transfer width support
>  * sdhci: don't assign mmc->caps at SDHCI directly
>  * mmc: only set blockaddressed for > 2GiB cards
>  * mmc: omap: fix for bus width which improves SD card's peformance.
>  * sdhci-pltfm: switch to module device table matching
>  * sdhci-pltfm: reorganize Makefile entries to support SoC devices
>  * sdhci-pltfm: add support for CNS3xxx SoC devices
>  * omap hsmmc: fix processing of all dma interrupts as block completion
>  * sdhci: add regulator support
>  * sdhci: add no hi-speed bit quirk support
>  * mmc: avoid getting CID on SDIO-only cards
>  * omap_hsmmc: remove unused local `state'
>  * omap hsmmc: fix a racing case between kmmcd and omap_hsmmc_suspend
>  * drivers/mmc/host/imxmmc.c: adjust confusing if indentation
>  * mmc: sdhci-pltfm: Add structure for host-specific data
>  * mmc: sdhci-pltfm: move .h file into appropriate subdir
>  * mmc: sdhci: introduce get_ro private write-p...

Read more...

Steve Langasek (vorlon) on 2010-11-08
tags: added: verification-done
removed: verification-needed

Also tested with 2.6.35-23-omap.

Test environment:

ubuntu@ubuntu:~$ uname -a
Linux ubuntu 2.6.35-23-omap #37-Ubuntu Sat Nov 6 02:01:12 UTC 2010
armv7l GNU/Linux
ubuntu@ubuntu:~$ cat /proc/version
Linux version 2.6.35-23-omap (buildd@gourd) (gcc version 4.4.5
(Ubuntu/Linaro 4.4.4-14ubuntu5) ) #37-Ubuntu Sat Nov 6 02:01:12 UTC
2010

Test case 1 : Read EDID information from monitor

ubuntu@ubuntu:~$ sudo modprobe eeprom
ubuntu@ubuntu:~$ decode-edid
decode-edid: using bus 3 (autodetected)
decode-edid: decode-edid version 1.1
parse-edid: parse-edid version 2.0.0
parse-edid: EDID checksum passed.

 # EDID version 1 revision 3
Section "Monitor"
 # Block type: 2:0 3:fd
 # Block type: 2:0 3:fc
 Identifier "SyncMaster"
 VendorName "SAM"
 ModelName "SyncMaster"
 # Block type: 2:0 3:fd
 HorizSync 30-81
 VertRefresh 56-75
 # Max dot clock (video bandwidth) 140 MHz
 # Block type: 2:0 3:fc
 # Block type: 2:0 3:ff
 # DPMS capabilities: Active off:yes Suspend:no Standby:no

 Mode "1680x1050" # vfreq 59.883Hz, hfreq 64.674kHz
  DotClock 119.000000
  HTimings 1680 1728 1760 1840
  VTimings 1050 1053 1059 1080
  Flags "-HSync" "+VSync"
 EndMode
 # Block type: 2:0 3:fd
 # Block type: 2:0 3:fc
 # Block type: 2:0 3:ff
EndSection

- Result : PASS

2010/11/8 Steve Langasek <email address hidden>:
> ** Tags added: verification-done
> ** Tags removed: verification-needed
>
> --
> EDID information on IGEPv2 not exported to userspace
> https://bugs.launchpad.net/bugs/654594
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux-linaro” package in Ubuntu: New
> Status in “linux-linaro” source package in Maverick: Fix Released
>
> Bug description:
> EDID information needs to be exported to userspace in order to be processed by 'decode-edid' and 'parse-edid'.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/linux-linaro/+bug/654594/+subscribe
>

John Rigby (jcrigby) on 2011-01-05
Changed in linux-linaro (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers