WLAN-BT GPIOs need proper initialization

Bug #654590 reported by Mathieu Poirier on 2010-10-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-linaro (Ubuntu)
Undecided
Mathieu Poirier
Maverick
Undecided
Unassigned
linux-linaro-omap (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Some GPIO's used by WLAN-BT combo on IGEP v2 depends on hardware revision - initialization need to be done properly.

Changed in linux (Ubuntu):
assignee: nobody → Mathieu Poirier (mathieu.poirier)

SRU Justification:

Impact: This patch is part of a series of fix for the IGEPv2 board. Initialization of the GPIOs used by the WLAN-BT must be tailored to the underlying HW.

Fix: The fix entails checking the "hwrev" flag and make the proper configuration. This patch depends on [PATCH 3/6], applied to fix BugLink: https://bugs.launchpad.net/bugs/654586

Testcase: Without this patch the WLAN BT combo simply won't work on newer boards.

Accepted linux-linaro into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

affects: linux (Ubuntu) → linux-linaro (Ubuntu)
Changed in linux-linaro (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted linux into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by Thursday, November 11, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Launchpad Janitor (janitor) wrote :
Download full text (4.9 KiB)

This bug was fixed in the package linux-linaro - 2.6.35-1008.15

---------------
linux-linaro (2.6.35-1008.15) maverick-proposed; urgency=low

  [ Robert Nelson ]

  * SRU: Fix DVI for Beagle xM rev A3
    - LP: #663642

linux-linaro (2.6.35-1008.14) maverick-proposed; urgency=low

  [ Andy Whitcroft ]

  * reduce disk usage during buildd builds
    - LP: #645653

  [ Enric Balletbo i Serra ]

  * ARM: igepv2: Adding support for VBUS and overcurrent
    - LP: #651589
  * ARM: igepv2: Fix and improve LED handling
    - LP: #654582
  * ARM: igepv2: Introduce function to dectect HW version
    - LP: #654586
  * ARM: igepv2: Fix handling of GPIOs for WLAN-BT combo
    - LP: #654590
  * ARM: igepv2: Add i2c eeprom driver to read EDID
    - LP: #654594
  * ARM: igepv2: Remove VMMC2 regulator
    - LP: #654595

  [ Maurus Cuelenaere ]

  * SAUCE: ARM: OMAP3: Add S-Video output to IGEPv2 board
    - LP: #607250

  [ Upstream Stable ]
  * Linux 2.6.35.7

  [ Upstream MMC updates ]

  * mmc: recognize CSD structure
  * mmc: split mmc_sd_init_card()
  * mmc: implement SD-combo (IO+mem) support
  * sdhci: remove useless set_clock() check
  * sdhci: 8-bit data transfer width support
  * sdhci: don't assign mmc->caps at SDHCI directly
  * mmc: only set blockaddressed for > 2GiB cards
  * mmc: omap: fix for bus width which improves SD card's peformance.
  * sdhci-pltfm: switch to module device table matching
  * sdhci-pltfm: reorganize Makefile entries to support SoC devices
  * sdhci-pltfm: add support for CNS3xxx SoC devices
  * omap hsmmc: fix processing of all dma interrupts as block completion
  * sdhci: add regulator support
  * sdhci: add no hi-speed bit quirk support
  * mmc: avoid getting CID on SDIO-only cards
  * omap_hsmmc: remove unused local `state'
  * omap hsmmc: fix a racing case between kmmcd and omap_hsmmc_suspend
  * drivers/mmc/host/imxmmc.c: adjust confusing if indentation
  * mmc: sdhci-pltfm: Add structure for host-specific data
  * mmc: sdhci-pltfm: move .h file into appropriate subdir
  * mmc: sdhci: introduce get_ro private write-protect hook
  * mmc: sdhci_pltfm: pass more data on custom init call
  * mmc: sdhci-of-esdhc: factor out common stuff
  * mmc: sdhci-pltfm: add -pltfm driver for imx35/51
  * mmc: quirk fix for timeout problem
  * babbage: esdhc device registration
  * babbage: update mx51_defconfig
    - LP: #656966

  [ Upstream ARM fixes ]

  * Make PTRACE_SINGLESTEP work with user helpers
  * ARM: fix section mismatch warnings in Versatile Express
  * ARM: use memblock to remove memory from available memory
  * video: omap: vram: remove from normal memory
    - LP: #627779

  [ John Rigby ]
  * LINARO: update configs
    - LP: #659799

linux-linaro (2.6.35-1007.13) maverick; urgency=low

  [ Upstream Ubuntu ]

  * Ubuntu-2.6.35-22.33
  * Ubuntu-2.6.35-22.34

  [ Upstream ARM Fixes ]

  * ARM: vexpress: set RAM latencies to 1 cycle for PL310 on ct-ca9x4 tile
  * ARM: vexpress: set RAM latencies to 1 cycle for PL310 on ct-ca9x4 tile
  * ARM: add a vma entry for the user accessible vector page
  * ARM: plug a race with the alignment trap handler
  * arm: fix really nasty sigreturn bug
  * ARM: prevent multiple syscall ...

Read more...

Changed in linux-linaro (Ubuntu Maverick):
status: Fix Committed → Fix Released

Test environment:
ubuntu@ubuntu:~$ uname -a
Linux ubuntu 2.6.35-23-omap #37-Ubuntu Sat Nov 6 02:01:12 UTC 2010 armv7l GNU/Linux
ubuntu@ubuntu:~$ cat /proc/version
Linux version 2.6.35-23-omap (buildd@gourd) (gcc version 4.4.5 (Ubuntu/Linaro 4.4.4-14ubuntu5) ) #37-Ubuntu Sat Nov 6 02:01:12 UTC 2010

Testcase 1 : Check for correct GPIOs for WLAN/BT on IGEP v2 Rev. B

 - Expected result :
    - GPIO_WIFI_NPD 94
    - GPIO_WIFI_NRESET 95
    - GPIO_BT_NRESET 137

 - Step 1 : Boot an IGEP v2 Rev. B board and check for WIFI/BT GPIOs

  ubuntu@ubuntu:~$ cat /sys/kernel/debug/gpio | grep GPIO_WIFI_NPD
  gpio-94 (GPIO_WIFI_NPD ) out hi
  ubuntu@ubuntu:~$ cat /sys/kernel/debug/gpio | grep GPIO_WIFI_NRESET
  gpio-95 (GPIO_WIFI_NRESET ) out hi
  ubuntu@ubuntu:~$ cat /sys/kernel/debug/gpio | grep GPIO_BT_NRESET
  gpio-137 (GPIO_BT_NRESET ) out hi

 - Result, PASS, GPIOs are correctly configured.

Testcase 1 : Check for correct GPIOs for WLAN/BT on IGEP v2 Rev. C

 - Expected result :
    - GPIO_WIFI_NPD 138
    - GPIO_WIFI_NRESET 139
    - GPIO_BT_NRESET 137

 - Step 1 : Boot an IGEP v2 Rev. C board and check for WIFI/BT GPIOs

 ubuntu@ubuntu:~$ cat /sys/kernel/debug/gpio | grep GPIO_WIFI_NPD
 gpio-138 (GPIO_WIFI_NPD ) out hi
 ubuntu@ubuntu:~$ cat /sys/kernel/debug/gpio | grep GPIO_WIFI_NRESET
 gpio-139 (GPIO_WIFI_NRESET ) out hi
 ubuntu@ubuntu:~$ cat /sys/kernel/debug/gpio | grep GPIO_BT_NRESET
 gpio-137 (GPIO_BT_NRESET ) out hi

 - Result, PASS, GPIOs are correctly configured.

tags: added: verification-done
removed: verification-needed
John Rigby (jcrigby) on 2011-03-11
Changed in linux-linaro (Ubuntu):
status: New → Invalid
Chase Qi (chase-qi) wrote :
Rolf Leggewie (r0lf) wrote :

Maverick has long since stopped to receive any updates. Marking the Maverick task for this ticket as "Won't Fix".

Changed in linux-linaro-omap (Ubuntu Maverick):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.