No functionality to detect IGEPv2 board version

Bug #654586 reported by Mathieu Poirier on 2010-10-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-linaro (Ubuntu)
Undecided
Mathieu Poirier
Maverick
Undecided
Unassigned

Bug Description

There is 2 version of the board and there is currently no functionality in the code to differentiate them.

Changed in linux (Ubuntu):
assignee: nobody → Mathieu Poirier (mathieu.poirier)

SRU Justification:

Impact: This patch is part of a series for fix for the IGEPv2 board. There are currently two version of the board but no functionality to differentiate them from the code.

Fix: Introducing functionality in the board file to probe GPIOs and set the "hwrev" flag.

Testcase: Without this patch, the code has no way to know which board is it working on and therefore can't take decisions on specific actions to take on each board.

Accepted linux-linaro into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

affects: linux (Ubuntu) → linux-linaro (Ubuntu)
Changed in linux-linaro (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted linux into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by Thursday, November 11, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Launchpad Janitor (janitor) wrote :
Download full text (4.9 KiB)

This bug was fixed in the package linux-linaro - 2.6.35-1008.15

---------------
linux-linaro (2.6.35-1008.15) maverick-proposed; urgency=low

  [ Robert Nelson ]

  * SRU: Fix DVI for Beagle xM rev A3
    - LP: #663642

linux-linaro (2.6.35-1008.14) maverick-proposed; urgency=low

  [ Andy Whitcroft ]

  * reduce disk usage during buildd builds
    - LP: #645653

  [ Enric Balletbo i Serra ]

  * ARM: igepv2: Adding support for VBUS and overcurrent
    - LP: #651589
  * ARM: igepv2: Fix and improve LED handling
    - LP: #654582
  * ARM: igepv2: Introduce function to dectect HW version
    - LP: #654586
  * ARM: igepv2: Fix handling of GPIOs for WLAN-BT combo
    - LP: #654590
  * ARM: igepv2: Add i2c eeprom driver to read EDID
    - LP: #654594
  * ARM: igepv2: Remove VMMC2 regulator
    - LP: #654595

  [ Maurus Cuelenaere ]

  * SAUCE: ARM: OMAP3: Add S-Video output to IGEPv2 board
    - LP: #607250

  [ Upstream Stable ]
  * Linux 2.6.35.7

  [ Upstream MMC updates ]

  * mmc: recognize CSD structure
  * mmc: split mmc_sd_init_card()
  * mmc: implement SD-combo (IO+mem) support
  * sdhci: remove useless set_clock() check
  * sdhci: 8-bit data transfer width support
  * sdhci: don't assign mmc->caps at SDHCI directly
  * mmc: only set blockaddressed for > 2GiB cards
  * mmc: omap: fix for bus width which improves SD card's peformance.
  * sdhci-pltfm: switch to module device table matching
  * sdhci-pltfm: reorganize Makefile entries to support SoC devices
  * sdhci-pltfm: add support for CNS3xxx SoC devices
  * omap hsmmc: fix processing of all dma interrupts as block completion
  * sdhci: add regulator support
  * sdhci: add no hi-speed bit quirk support
  * mmc: avoid getting CID on SDIO-only cards
  * omap_hsmmc: remove unused local `state'
  * omap hsmmc: fix a racing case between kmmcd and omap_hsmmc_suspend
  * drivers/mmc/host/imxmmc.c: adjust confusing if indentation
  * mmc: sdhci-pltfm: Add structure for host-specific data
  * mmc: sdhci-pltfm: move .h file into appropriate subdir
  * mmc: sdhci: introduce get_ro private write-protect hook
  * mmc: sdhci_pltfm: pass more data on custom init call
  * mmc: sdhci-of-esdhc: factor out common stuff
  * mmc: sdhci-pltfm: add -pltfm driver for imx35/51
  * mmc: quirk fix for timeout problem
  * babbage: esdhc device registration
  * babbage: update mx51_defconfig
    - LP: #656966

  [ Upstream ARM fixes ]

  * Make PTRACE_SINGLESTEP work with user helpers
  * ARM: fix section mismatch warnings in Versatile Express
  * ARM: use memblock to remove memory from available memory
  * video: omap: vram: remove from normal memory
    - LP: #627779

  [ John Rigby ]
  * LINARO: update configs
    - LP: #659799

linux-linaro (2.6.35-1007.13) maverick; urgency=low

  [ Upstream Ubuntu ]

  * Ubuntu-2.6.35-22.33
  * Ubuntu-2.6.35-22.34

  [ Upstream ARM Fixes ]

  * ARM: vexpress: set RAM latencies to 1 cycle for PL310 on ct-ca9x4 tile
  * ARM: vexpress: set RAM latencies to 1 cycle for PL310 on ct-ca9x4 tile
  * ARM: add a vma entry for the user accessible vector page
  * ARM: plug a race with the alignment trap handler
  * arm: fix really nasty sigreturn bug
  * ARM: prevent multiple syscall ...

Read more...

Changed in linux-linaro (Ubuntu Maverick):
status: Fix Committed → Fix Released
Torez Smith (lnxtorez) wrote :

the problem being is fixed is not well defined here. Looking for a description of exactly what is broken and how to detect it has been fixed. If this is a new feature, there needs to be description specifying what the changes are and how to verify they work.

Also tested with 2.6.35-23-omap.

Test environment:

ubuntu@ubuntu:~$ uname -a
Linux ubuntu 2.6.35-23-omap #37-Ubuntu Sat Nov 6 02:01:12 UTC 2010
armv7l GNU/Linux
ubuntu@ubuntu:~$ cat /proc/version
Linux version 2.6.35-23-omap (buildd@gourd) (gcc version 4.4.5
(Ubuntu/Linaro 4.4.4-14ubuntu5) ) #37-Ubuntu Sat Nov 6 02:01:12 UTC
2010

Test case 1: Check IGEP v2 Rev. B is detected.
  - Step 1 : Boot an IGEP v2 Rev. B board.
  - Step 2 : Check if revision is detected correctly
      ubuntu@ubuntu:~$ dmesg | grep "IGEP2: Hardware Revision"
      [ 0.000000] IGEP2: Hardware Revision B/C (B compatible)

  - Result: PASS, kernel detects IGEP v2 Rev. B

Test case 2: Check IGEP v2 Rev. C is detected.
  - Step 1 : Boot an IGEP v2 Rev. C board.
  - Step 2 : Check if revision is detected correctly
      ubuntu@ubuntu:~$ dmesg | grep "IGEP2: Hardware Revision"
      [ 0.000000] IGEP2: Hardware Revision C (B-NON compatible

  - Result: PASS, kernel detects IGEP v2 Rev. C

Note: What happens if revision is not correctly detected ?
Basically the difference between revisions are the GPIO's to control
the WIFI/BT combo, so if revision is not detected WIFI/BT shouldn't
work on Rev. C boards.

2010/11/10 Torez Smith <email address hidden>:
> the problem being is fixed is not well defined here. Looking for a
> description of exactly what is broken and how to detect it has been
> fixed. If this is a new feature, there needs to be description
> specifying what the changes are and how to verify they work.
>
> --
> No functionality to detect IGEPv2 board version
> https://bugs.launchpad.net/bugs/654586
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux-linaro” package in Ubuntu: New
> Status in “linux-linaro” source package in Maverick: Fix Released
>
> Bug description:
> There is 2 version of the board and there is currently no functionality in the code to differentiate them.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/linux-linaro/+bug/654586/+subscribe
>

Steve Conklin (sconklin) on 2010-11-10
tags: added: verification-done
removed: verification-needed
John Rigby (jcrigby) on 2011-01-05
Changed in linux-linaro (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers