4 LEDs on IGEPv2 board are not initialized/working

Bug #654582 reported by Mathieu Poirier on 2010-10-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-linaro (Ubuntu)
Undecided
Mathieu Poirier
Maverick
Undecided
Unassigned
linux-linaro-omap (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

The LEDs on the IGEPv2 board are not working.

Changed in linux (Ubuntu):
assignee: nobody → Mathieu Poirier (mathieu.poirier)

SRU Justification:

Impact: This patch is part of a series of fix for the IGEPv2. The board features 4 LED that must be declared and linked to GPIOs.

Fix: The LEDs are initialized and controlled via the LED class if CONFIG_LEDS_GPIO is selected
or using the General Purpose Input/Output (GPIO) interface if CONFIG_LEDS_GPIO is not selected. This patch depends on [PATCH 1/6] of the same patch set, applied to BugLink: https://bugs.launchpad.net/bugs/651589 .

Testcase: Without this patch LEDs are simply not working.

Accepted linux-linaro into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

affects: linux (Ubuntu) → linux-linaro (Ubuntu)
Changed in linux-linaro (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted linux into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by Thursday, November 11, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Launchpad Janitor (janitor) wrote :
Download full text (4.9 KiB)

This bug was fixed in the package linux-linaro - 2.6.35-1008.15

---------------
linux-linaro (2.6.35-1008.15) maverick-proposed; urgency=low

  [ Robert Nelson ]

  * SRU: Fix DVI for Beagle xM rev A3
    - LP: #663642

linux-linaro (2.6.35-1008.14) maverick-proposed; urgency=low

  [ Andy Whitcroft ]

  * reduce disk usage during buildd builds
    - LP: #645653

  [ Enric Balletbo i Serra ]

  * ARM: igepv2: Adding support for VBUS and overcurrent
    - LP: #651589
  * ARM: igepv2: Fix and improve LED handling
    - LP: #654582
  * ARM: igepv2: Introduce function to dectect HW version
    - LP: #654586
  * ARM: igepv2: Fix handling of GPIOs for WLAN-BT combo
    - LP: #654590
  * ARM: igepv2: Add i2c eeprom driver to read EDID
    - LP: #654594
  * ARM: igepv2: Remove VMMC2 regulator
    - LP: #654595

  [ Maurus Cuelenaere ]

  * SAUCE: ARM: OMAP3: Add S-Video output to IGEPv2 board
    - LP: #607250

  [ Upstream Stable ]
  * Linux 2.6.35.7

  [ Upstream MMC updates ]

  * mmc: recognize CSD structure
  * mmc: split mmc_sd_init_card()
  * mmc: implement SD-combo (IO+mem) support
  * sdhci: remove useless set_clock() check
  * sdhci: 8-bit data transfer width support
  * sdhci: don't assign mmc->caps at SDHCI directly
  * mmc: only set blockaddressed for > 2GiB cards
  * mmc: omap: fix for bus width which improves SD card's peformance.
  * sdhci-pltfm: switch to module device table matching
  * sdhci-pltfm: reorganize Makefile entries to support SoC devices
  * sdhci-pltfm: add support for CNS3xxx SoC devices
  * omap hsmmc: fix processing of all dma interrupts as block completion
  * sdhci: add regulator support
  * sdhci: add no hi-speed bit quirk support
  * mmc: avoid getting CID on SDIO-only cards
  * omap_hsmmc: remove unused local `state'
  * omap hsmmc: fix a racing case between kmmcd and omap_hsmmc_suspend
  * drivers/mmc/host/imxmmc.c: adjust confusing if indentation
  * mmc: sdhci-pltfm: Add structure for host-specific data
  * mmc: sdhci-pltfm: move .h file into appropriate subdir
  * mmc: sdhci: introduce get_ro private write-protect hook
  * mmc: sdhci_pltfm: pass more data on custom init call
  * mmc: sdhci-of-esdhc: factor out common stuff
  * mmc: sdhci-pltfm: add -pltfm driver for imx35/51
  * mmc: quirk fix for timeout problem
  * babbage: esdhc device registration
  * babbage: update mx51_defconfig
    - LP: #656966

  [ Upstream ARM fixes ]

  * Make PTRACE_SINGLESTEP work with user helpers
  * ARM: fix section mismatch warnings in Versatile Express
  * ARM: use memblock to remove memory from available memory
  * video: omap: vram: remove from normal memory
    - LP: #627779

  [ John Rigby ]
  * LINARO: update configs
    - LP: #659799

linux-linaro (2.6.35-1007.13) maverick; urgency=low

  [ Upstream Ubuntu ]

  * Ubuntu-2.6.35-22.33
  * Ubuntu-2.6.35-22.34

  [ Upstream ARM Fixes ]

  * ARM: vexpress: set RAM latencies to 1 cycle for PL310 on ct-ca9x4 tile
  * ARM: vexpress: set RAM latencies to 1 cycle for PL310 on ct-ca9x4 tile
  * ARM: add a vma entry for the user accessible vector page
  * ARM: plug a race with the alignment trap handler
  * arm: fix really nasty sigreturn bug
  * ARM: prevent multiple syscall ...

Read more...

Changed in linux-linaro (Ubuntu Maverick):
status: Fix Committed → Fix Released
Download full text (6.5 KiB)

Tested on:
ubuntu@ubuntu:~$ uname -a
Linux ubuntu 2.6.35-1008-linaro-omap #15-Ubuntu Fri Oct 22 11:56:29
UTC 2010 armv7l GNU/Linux

ubuntu@ubuntu:/sys/class/leds$ ls /sys/class/leds/
gpio-led:green:d0 gpio-led:green:d1 gpio-led:red:d0 gpio-led:red:d1

root@ubuntu:/sys/class/leds# echo 1 > gpio-led\:green\:d0/brightness
root@ubuntu:/sys/class/leds# echo 0 > gpio-led\:green\:d0/brightness

root@ubuntu:/sys/class/leds# echo 0 > gpio-led\:green\:d1/brightness
root@ubuntu:/sys/class/leds# echo 1 > gpio-led\:green\:d1/brightness

root@ubuntu:/sys/class/leds# echo 0 > gpio-led\:red\:d0/brightness
root@ubuntu:/sys/class/leds# echo 1 > gpio-led\:red\:d0/brightness

root@ubuntu:/sys/class/leds# echo 1 > gpio-led\:red\:d1/brightness
root@ubuntu:/sys/class/leds# echo 0 > gpio-led\:red\:d1/brightness

2010/11/8 Launchpad Bug Tracker <email address hidden>:
> This bug was fixed in the package linux-linaro - 2.6.35-1008.15
>
> ---------------
> linux-linaro (2.6.35-1008.15) maverick-proposed; urgency=low
>
>  [ Robert Nelson ]
>
>  * SRU: Fix DVI for Beagle xM rev A3
>    - LP: #663642
>
> linux-linaro (2.6.35-1008.14) maverick-proposed; urgency=low
>
>  [ Andy Whitcroft ]
>
>  * reduce disk usage during buildd builds
>    - LP: #645653
>
>  [ Enric Balletbo i Serra ]
>
>  * ARM: igepv2: Adding support for VBUS and overcurrent
>    - LP: #651589
>  * ARM: igepv2: Fix and improve LED handling
>    - LP: #654582
>  * ARM: igepv2: Introduce function to dectect HW version
>    - LP: #654586
>  * ARM: igepv2: Fix handling of GPIOs for WLAN-BT combo
>    - LP: #654590
>  * ARM: igepv2: Add i2c eeprom driver to read EDID
>    - LP: #654594
>  * ARM: igepv2: Remove VMMC2 regulator
>    - LP: #654595
>
>  [ Maurus Cuelenaere ]
>
>  * SAUCE: ARM: OMAP3: Add S-Video output to IGEPv2 board
>    - LP: #607250
>
>  [ Upstream Stable ]
>  * Linux 2.6.35.7
>
>  [ Upstream MMC updates ]
>
>  * mmc: recognize CSD structure
>  * mmc: split mmc_sd_init_card()
>  * mmc: implement SD-combo (IO+mem) support
>  * sdhci: remove useless set_clock() check
>  * sdhci: 8-bit data transfer width support
>  * sdhci: don't assign mmc->caps at SDHCI directly
>  * mmc: only set blockaddressed for > 2GiB cards
>  * mmc: omap: fix for bus width which improves SD card's peformance.
>  * sdhci-pltfm: switch to module device table matching
>  * sdhci-pltfm: reorganize Makefile entries to support SoC devices
>  * sdhci-pltfm: add support for CNS3xxx SoC devices
>  * omap hsmmc: fix processing of all dma interrupts as block completion
>  * sdhci: add regulator support
>  * sdhci: add no hi-speed bit quirk support
>  * mmc: avoid getting CID on SDIO-only cards
>  * omap_hsmmc: remove unused local `state'
>  * omap hsmmc: fix a racing case between kmmcd and omap_hsmmc_suspend
>  * drivers/mmc/host/imxmmc.c: adjust confusing if indentation
>  * mmc: sdhci-pltfm: Add structure for host-specific data
>  * mmc: sdhci-pltfm: move .h file into appropriate subdir
>  * mmc: sdhci: introduce get_ro private write-protect hook
>  * mmc: sdhci_pltfm: pass more data on custom init call
>  * mmc: sdhci-of-esdhc: factor out common stuff
>  * mmc: sdhci-pltfm: add -pltfm driver for imx35/51
>  * mmc: quir...

Read more...

Torez Smith (lnxtorez) wrote :

I've tested and verified the Maverick proposed kernel from http://launchpadlibrarian.net/58060627/linux-image-2.6.35-1008-linaro-omap_2.6.35-1008.15_armel.deb does resolve and fix this bug.

Tests were made on IGEPv2 board and Beagle XM (to assure no regression).

kernel config......
        CONFIG_LEDS=y
        CONFIG_MAC80211_LEDS=y
        CONFIG_RFKILL_LEDS=y
        CONFIG_RTL8187_LEDS=y
        CONFIG_AR9170_LEDS=y
        CONFIG_B43_LEDS=y
        CONFIG_B43LEGACY_LEDS=y
        CONFIG_P54_LEDS=y
        CONFIG_RT2X00_LIB_LEDS=y
        CONFIG_JOYSTICK_XPAD_LEDS=y
        CONFIG_HID_PICOLCD_LEDS=y
        CONFIG_NEW_LEDS=y
        CONFIG_LEDS_CLASS=m
        CONFIG_LEDS_88PM860X=m
        CONFIG_LEDS_PCA9532=m
        CONFIG_LEDS_GPIO=m
        CONFIG_LEDS_GPIO_PLATFORM=y
        CONFIG_LEDS_LP3944=m
        CONFIG_LEDS_PCA955X=m
        CONFIG_LEDS_WM831X_STATUS=m
        CONFIG_LEDS_WM8350=m
        CONFIG_LEDS_DA903X=m
        CONFIG_LEDS_DAC124S085=m
        CONFIG_LEDS_REGULATOR=m
        CONFIG_LEDS_BD2802=m
        CONFIG_LEDS_LT3593=m
        CONFIG_LEDS_ADP5520=m
        CONFIG_LEDS_MC13783=m
        CONFIG_LEDS_TRIGGERS=y
        CONFIG_LEDS_TRIGGER_TIMER=m
        CONFIG_LEDS_TRIGGER_HEARTBEAT=m
        CONFIG_LEDS_TRIGGER_BACKLIGHT=m
        CONFIG_LEDS_TRIGGER_GPIO=m
        CONFIG_LEDS_TRIGGER_DEFAULT_ON=m

IGEPv2 board....
        cd /sys/class/leds
        echo 0 > gpio-led\:green\:d0/brightness
        echo 0 > gpio-led\:green\:d1/brightness
        echo 0 > gpio-led\:red\:d0/brightness
        echo 0 > gpio-led\:red\:d1/brightness
        # the gpio-led:green:d1 led remains on...on with value of 0

        echo 1 > gpio-led\:green\:d0/brightness
        echo 1 > gpio-led\:green\:d1/brightness
        echo 1 > gpio-led\:red\:d0/brightness
        echo 1 > gpio-led\:red\:d1/brightness
         # all leds turn on. However, gpio-led:green:d1 turns off

Beagle XM board....
        cd /lib/modules/2.6.35-1008-linaro-omap/kernel/drivers/leds
        insmod led-class.ko
        insmod leds-gpio.ko

        cd /sys/class/leds
        echo 0 > beagleboard::pmu_stat/brightness
        echo 0 > beagleboard::usr0/brightness
        echo 0 > beagleboard::usr1/brightness
        # all leds are now off...

        echo 1 > beagleboard::pmu_stat/brightness
        echo 1 > beagleboard::usr0/brightness
        echo 1 > beagleboard::usr1/brightness
        # all leds are now on....

Steve Langasek (vorlon) on 2010-11-08
tags: added: verification-done
removed: verification-needed
John Rigby (jcrigby) on 2011-03-11
Changed in linux-linaro-omap (Ubuntu):
status: New → Incomplete
Changed in linux-linaro (Ubuntu):
status: New → Invalid
Chase Qi (chase-qi) wrote :
Rolf Leggewie (r0lf) wrote :

Maverick has long since stopped to receive any updates. Marking the Maverick task for this ticket as "Won't Fix".

Changed in linux-linaro-omap (Ubuntu Maverick):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.