Ubuntu

omapdss kernel hang on shutdown

Reported by Steve Langasek on 2010-09-13
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-linaro (Ubuntu)
Undecided
Unassigned

Bug Description

Trying to reboot my beagle board resulted in a kernel hang and the following trace dumped to the serial console. I'm afraid it's a little garbled, but at the moment it's all I have.

[28355.802062] Unable to handle kernel 000000
[28355.810363] pgd = cb464000
[28ked in: nls_iso8859_1 nls_cp437 vfat fat asix usbnet mu CPU: 0 Not tainted (2.6.35-1004-linaro-omx84/0xc4
[28355.859436] pc : [<c31d64
[28355.871154] r10: 00000000003
[28355.883117] r3 : 000000055.897064] Control: 10c5387d Table: 8b464019 Stack: (0xcb531d58 to 0xcb532000)
[28355.913574] 1d40: a050400 c0721b10 cb531d94 cb531d80 c02d8710 c0cb531d98 c02e00e8 c02d86f4 c02e011 c02e011c cb531dfc cb531dd8 c03107d8 c02d48001e00 c02d4a44 c031077c
[28355.963623] 1e00: ] 1e40: cb531e5c cb531e50 c0097468 c030d05c cb5.997009] 1e80: 00000000 00000000 00000200 c00] 1ea0: 00000000 7fffffff 00000000007
[28356.022033] 1ee0: c0717f34 4024c3cc 34 cb531f28
[28356.038696] 1f20: c0171a54 ce40
[28356.047058] 1f40: cb531f01447d4
[28356.055389] 1f60: cb5a4 c5c078f3
[28356.063720] 1f80:000000 cb531fa8
 fee1dead 00000000 00000000
_bug+0x24/0x2c) from [<c02cdabc>] ([28356.123779] [<c02cdabc>] (dss_clk_disable+0x98/0xa8) from [<c02d8710>] (o4)
[ble+0x28/0x44) from [<c02e00e8>] (gev+0x68/0x94) from [<c02d4a44>] (dss_disable_a [<c02ccdd0>] (omap_dss_shutdown+0x24/0x38)
hutdown+0x20/0x24)
_drv_shutdown+0x20/0x24) from [<c034/0x3c)
[[28356.275787] [<c0 [<c0042ac0>] (ret_fast_syscall+0x0/0x30)
582] OMAPFB: setcmap
[28356.343475] OMAPFB:

Steve Langasek (vorlon) wrote :
Download full text (5.1 KiB)

Ah, the serial console needed to be reset. Here's a proper stack trace.

[ 6024.913665] kernel BUG at /build/buildd/linux-linaro-2.6.35/drivers/video/oma
p2/dss/core.c:323!
[ 6024.927551] Unable to handle kernel NULL pointer dereference at virtual addre
ss 00000000
[ 6024.940643] pgd = ce4c0000
[ 6024.948333] [00000000] *pgd=00000000
[ 6024.956970] Internal error: Oops: 805 [#1]
[ 6024.966064] last sysfs file: /sys/kernel/uevent_seqnum
[ 6024.976226] Modules linked in: nls_iso8859_1 nls_cp437 vfat fat asix musb_hdrc usbnet leds_gpio omap_wdt omap2_mcspi led_class joydev gpio_keys twl4030_usb twl4030_pwrbutton usbhid hid
[ 6025.003662] CPU: 0 Not tainted (2.6.35-1004-linaro-omap #9-Ubuntu)
[ 6025.015655] PC is at __bug+0x24/0x2c
[ 6025.024627] LR is at release_console_sem+0x84/0xc4
[ 6025.034790] pc : [<c0046ba4>] lr : [<c0081254>] psr: 60000013
[ 6025.034820] sp : cdd55d58 ip : c0769094 fp : cdd55d64
[ 6025.057128] r10: 00000000 r9 : cdd54000 r8 : 00000003
[ 6025.067749] r7 : c02d47f4 r6 : cdd55dd8 r5 : 00000000 r4 : 00000003
[ 6025.079742] r3 : 00000000 r2 : c072d8f8 r1 : 7df0760c r0 : 00000069
[ 6025.091705] Flags: nZCv IRQs on FIQs on Mode SVC_32 ISA ARM Segment user
[ 6025.104248] Control: 10c5387d Table: 8e4c0019 DAC: 00000015
[ 6025.115447] Process halt (pid: 744, stack limit = 0xcdd542e8)
[ 6025.126617] Stack: (0xcdd55d58 to 0xcdd56000)
[ 6025.136383] 5d40: cdd55d7c cdd55d68
[ 6025.150024] 5d60: c02cdabc c0046b8c fa050400 c0721b10 cdd55d94 cdd55d80 c02d8710 c02cda30
[ 6025.163787] 5d80: c0062678 c0721b10 cdd55dac cdd55d98 c02e00e8 c02d86f4 c02e0110 c0721b10
[ 6025.177642] 5da0: cdd55dc4 cdd55db0 c02e0124 c02e00cc c02e0110 00000000 cdd55dd4 cdd55dc8
[ 6025.191589] 5dc0: c02d4818 c02e011c cdd55dfc cdd55dd8 c03107d8 c02d4800 cec58738 ce6341b0
[ 6025.205505] 5de0: c0721fb8 c0721fc4 c0818a74 4321fedc cdd55e0c cdd55e00 c02d4a44 c031077c
[ 6025.219421] 5e00: cdd55e1c cdd55e10 c02ccdd0 c02d4a2c cdd55e2c cdd55e20 c0312598 c02ccdb8
[ 6025.233367] 5e20: cdd55e4c cdd55e30 c030d0bc c0312584 c0769028 00000002 4321fedc c076908c
[ 6025.247375] 5e40: cdd55e64 cdd55e50 c0097314 c030d05c fee1dead 00000000 cdd55e74 cdd55e68
[ 6025.261413] 5e60: c0097484 c00972e4 cdd55fa4 cdd55e78 c009768c c009747c ceda0c70 c072d358
[ 6025.275482] 5e80: 00000000 00000000 00000200 c0042280 c050c10c c006ca18 ffffffff cdece01c
[ 6025.289550] 5ea0: cee70780 ceda0c40 cdd55ed4 cdd55eb8 c007b924 c0104e40 fffff
[ 6025.303588] 5ec0: ceda6200 ceda0c40 cdd55f2c cdd55ed8 c0507b3c c007b8f0 c007cc5c 00000007
[ 6025.317657] 5ee0: c0717f34 401783cc cdd55fb0 00000006 00000000 40022f3c cdd55fac cdd55f08
[ 6025.331756] 5f00: c0042280 c050bca4 cec02440 c073c28c cdd55f8c c016757c cdd54000 cec02600
[ 6025.345825] 5f20: cdd55f44 cdd55f30 c0507ef0 c0507864 cdd12440 cdd12440 cdd12400 cdd12440
[ 6025.359893] 5f40: cdd55f5c cdd55f50 00000000 cdd12400 cdd55f84 cdd55f60 c0144ab4 c01447d4
[ 6025.373931] 5f60: cdd55f8c 00000002 00000000 00000024 c0042c68 00000000 cdd55fa4 7df0760c
[ 6025.387878] 5f80: c01675f8 40022f3c 00000002 00000000 00000058 c0042c68 00000000 cdd55fa8
[ 6025.401763] 5fa0: c0042ac0 c0097510 40022f3c 000...

Read more...

Michael Hudson-Doyle (mwhudson) wrote :

I get this when I run 'poweroff' on my xM too. It happens with the 15-1 daily. I *think* it might have started when I upgraded to the 2.6.35-1005-linaro-omap from the beta, but I'm not sure about that.

Changed in linux-linaro (Ubuntu):
status: New → Confirmed
Michael Hudson-Doyle (mwhudson) wrote :

But it doesn't seem to happen if I reboot/poweroff straight away, only if I've used the board for "a while". That's going to make it fun to debug :-)

John Rigby (jcrigby) wrote :

I think this ubuntu commit should fix this:

http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-maverick.git;a=commit;h=4e90adae43f52db35c99bcaccb2e2a912b8299d5

Which is part of Ubuntu-2.6.35-21.30 so it should be fixed in Linaro-2.6.35-1006.11 which was rebased on Ubuntu-2.6.35-22.32.

Michael Hudson-Doyle (mwhudson) wrote :

That does look plausible. When will a kernel with the fix hit the archive?

Guilherme Salgado (salgado) wrote :

I've seen this as well (on an xM) but can't reproduce it on 2.6.35-1006.12, so the commit mentioned by John must have fixed this.

Michael Hudson-Doyle (mwhudson) wrote :

I agree. Closing the bug.

Changed in linux-linaro (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers