Please re-enable crypto-modules udeb

Bug #826021 reported by Colin Watson on 2011-08-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-linaro-vexpress (Ubuntu)
High
John Rigby

Bug Description

debian-installer fails to build on armel+linaro-vexpress because netcfg now depends on crypto-modules (for WPA support) and that udeb is not built by linux-linaro-vexpress. I can't make this dependency subarchitecture-dependent, so please enable the necessary config options to build a useful crypto-modules udeb.

  https://launchpadlibrarian.net/77173097/buildlog_ubuntu-oneiric-armel.debian-installer_20101020ubuntu53_FAILEDTOBUILD.txt.gz

Colin Watson (cjwatson) on 2011-08-13
Changed in linux-linaro-vexpress (Ubuntu):
importance: Undecided → High
Colin Watson (cjwatson) wrote :

FYI, I have disabled the relevant d-i build target until this is fixed.

Loïc Minier (lool) wrote :

crypto-modules will include these modules if present:
aes_generic ?
blowfish ?
twofish ?
serpent ?
sha256_generic ?
cbc ?
ecb ?
crc32c ?

This is:
- CONFIG_CRYPTO_AES for aes_generic
- CONFIG_CRYPTO_BLOWFISH for blowfish
- CONFIG_CRYPTO_TWOFISH for twofish_generic which has a twofish alias
- CONFIG_CRYPTO_SERPENT for serpent
- CONFIG_CRYPTO_SHA256 for sha256_generic
- CONFIG_CRYPTO_CBC for cbc
- CONFIG_CRYPTO_ECB for ecb
- CONFIG_CRYPTO_CRC32C for crc32c

(These configs might be shadowed by others that we set/don't set, or might depend on other configs.)

John Rigby (jcrigby) on 2011-09-26
Changed in linux-linaro-vexpress (Ubuntu):
assignee: nobody → John Rigby (jcrigby)
John Rigby (jcrigby) wrote :

I have fixed this but Beta 2 is passed so is it too late for Oneiric?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-linaro-vexpress - 3.0.0-1007.9

---------------
linux-linaro-vexpress (3.0.0-1007.9) oneiric; urgency=low

  [ John Rigby ]

  * Enable crypto modules and remove crypto-modules from
    exclude-module files
    LP: #826021
 -- John Rigby <email address hidden> Mon, 26 Sep 2011 10:44:23 -0600

Changed in linux-linaro-vexpress (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers