Missing proper support for Beagle XM rev B and C

Bug #770679 reported by Ricardo Salveti on 2011-04-26
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned
Oneiric
Medium
Unassigned
linux-linaro-omap (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned
u-boot-linaro (Ubuntu)
Low
Unassigned
Natty
Low
Unassigned
Oneiric
Low
Unassigned

Bug Description

Current code only checks for Beagle XM rev A (the first ones to get out), but now should also take care of the new revisions, mostly rev C as EHCI power got inverted again.

Ricardo Salveti (rsalveti) wrote :

Robert is working to include the proper support at the kernel with upstream, and he'll probably forward the first 5 patches at http://bazaar.launchpad.net/~beagleboard-kernel/+junk/2.6-stable/files/head:/patches/wip_to_be_pushed/

I removed the cosmetic changes and applied just what's need to have support (less patches as it's not yet upstream), and published them at http://kernel.ubuntu.com/git?p=rsalveti/ubuntu-natty.git;a=summary.

I'm building the kernel and will publish the deb files once I'm done.

Ricardo Salveti (rsalveti) wrote :

For u-boot it seems we need 2 patches:
 * http://patchwork.ozlabs.org/patch/85303/
 * http://patchwork.ozlabs.org/patch/92334/

They were sent upstream, but not yet applied.

Ricardo Salveti (rsalveti) wrote :

The kernel packages can be located at http://people.canonical.com/~rsalveti/770679/

Robert, can you help testing this package for us? I believe you're one of the few who have a Beagle xM C (and probably also B).

Tested with my xM A and worked as expected:
ubuntu@ubuntu:~$ dmesg | grep xM
[ 0.280242] OMAP3 Beagle Rev: xM A

linux-image-2.6.38-9-omap - 2.6.38-9.43xmbc

Robert Nelson (robertcnelson) wrote :

Hi Ricardo,

Sure i'll give it a test. I have an xM B at my desk now (it actually comes up as xM A, last i talked to Gerald, none of the xM B's are actually "xM B's" as far as the gpio identification..) But the xM C left yesterday with another developer, should have it back tomorrow..

Regards,

John Rigby (jcrigby) wrote :

I have added the three kernel patches to the packaged kernel. What about the u-boot patches? Do we need them?

On Fri, Apr 29, 2011 at 6:33 PM, John Rigby <email address hidden> wrote:
> I have added the three kernel patches to the packaged kernel.  What
> about the u-boot patches?  Do we need them?

It seems that the only important part of the u-boot patches is where
it sets the default case to behave like an xM, so we can have higher
changes to have the released image working with future board
revisions. Besides that it's basically used to print the correct board
revision to the user.

So I'd recommend to apply them, but be sure that as we remove the
mpurate settings (from first patch) we may need additional patches to
set up the correct mpurate value depending on the cpu type. Check
http://patchwork.ozlabs.org/patch/71995/ for more information. Sakoman
may also help here.

Matt Ownby (matt-ownby) wrote :

I tested the patched kernel with my xM rev C and it works. Also GLES2 works too (which was previously broken for me).

My dmesg output is at:
http://paste.ubuntu.com/604270/

Ricardo Salveti (rsalveti) wrote :

@Matt: interested that you said you had a rev C but the GPIO reported something else, as you can see from the logs:
[ 0.143920] OMAP3 Beagle Rev: unknown 3, assuming xM C or newer

So it could be the case that the GPIO is not set as 010 for xM C. As I can't find the proper hardware manuals now I believe this could be wrong, but luckily the other cases are all xM rev C now, so it worked fine for you.

Robert, can you check with your xM to see if this GPIO configuration is actually fine for rev C?

Robert Nelson (robertcnelson) wrote :

Hi Ricardo,

The kernel looks good on the "xM C"..

ubuntu@omap:~$ lsusb
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
ubuntu@omap:~$ dmesg | grep Beagle
[ 0.000000] Machine: OMAP3 Beagle Board
[ 0.154510] OMAP3 Beagle Rev: xM C
[ 4.019317] OMAP3 Beagle/Devkit8000 SoC init
ubuntu@omap:~$ uname -a
Linux omap 2.6.38-9-omap #43xmbc Tue Apr 26 02:54:23 BRT 2011 armv7l armv7l armv7l GNU/Linux

(used rootstock with your *.deb, as the headless image was a little bit of a pain.)

Regards,

Robert Nelson (robertcnelson) wrote :

u-boot notes: (with natty headless image):

Texas Instruments X-Loader 1.5.0 (Apr 11 2011 - 09:47:05)
Beagle xM
Reading boot sector
Loading u-boot.bin from mmc

U-Boot 2011.03 (Apr 20 2011 - 07:19:53)

OMAP3630/3730-GP ES2.1, CPU-OPP2, L3-165MHz, Max CPU Clock 1 Ghz
OMAP3 Beagle board + LPDDR/NAND
I2C: ready
DRAM: 512 MiB
NAND: 0 MiB
MMC: OMAP SD/MMC: 0
*** Warning - readenv() failed, using default environment

In: serial
Out: serial
Err: serial
Beagle unknown 0x02
No EEPROM on expansion board
Die ID #15ce00029ff80000015f26ad0f02000c

Ricardo Salveti (rsalveti) wrote :

On Wed, May 18, 2011 at 5:17 PM, Robert Nelson <email address hidden> wrote:
> Hi Ricardo,
>
> The kernel looks good on the "xM C"..
>
> ubuntu@omap:~$ lsusb
> Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
> Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> ubuntu@omap:~$ dmesg | grep Beagle
> [    0.000000] Machine: OMAP3 Beagle Board
> [    0.154510] OMAP3 Beagle Rev: xM C
> [    4.019317] OMAP3 Beagle/Devkit8000 SoC init
> ubuntu@omap:~$ uname -a
> Linux omap 2.6.38-9-omap #43xmbc Tue Apr 26 02:54:23 BRT 2011 armv7l armv7l armv7l GNU/Linux

Nice, thanks for testing it.

Interesting that it worked well for you, as described at the hardware
changes document (010). I wonder why Matt's board got 011, but good
now that newer boards should all behave as a xM rev C.

Matt Ownby (matt-ownby) wrote :

I also noticed that mine was unidentified. When I say I have a rev C, I am
going off what the box says that my beagleboard came in. I know of no other
way to ID it.

On Wed, May 18, 2011 at 3:05 PM, Ricardo Salveti <email address hidden>wrote:

> On Wed, May 18, 2011 at 5:17 PM, Robert Nelson <email address hidden>
> wrote:
> > Hi Ricardo,
> >
> > The kernel looks good on the "xM C"..
> >
> > ubuntu@omap:~$ lsusb
> > Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
> > Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
> > Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> > ubuntu@omap:~$ dmesg | grep Beagle
> > [ 0.000000] Machine: OMAP3 Beagle Board
> > [ 0.154510] OMAP3 Beagle Rev: xM C
> > [ 4.019317] OMAP3 Beagle/Devkit8000 SoC init
> > ubuntu@omap:~$ uname -a
> > Linux omap 2.6.38-9-omap #43xmbc Tue Apr 26 02:54:23 BRT 2011 armv7l
> armv7l armv7l GNU/Linux
>
> Nice, thanks for testing it.
>
> Interesting that it worked well for you, as described at the hardware
> changes document (010). I wonder why Matt's board got 011, but good
> now that newer boards should all behave as a xM rev C.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/770679
>
> Title:
> Missing proper support for Beagle XM rev B and C
>
> Status in “linux” package in Ubuntu:
> New
> Status in “linux-linaro-omap” package in Ubuntu:
> New
> Status in “u-boot-linaro” package in Ubuntu:
> New
>
> Bug description:
> Current code only checks for Beagle XM rev A (the first ones to get
> out), but now should also take care of the new revisions, mostly rev C
> as EHCI power got inverted again.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/770679/+subscribe
>

--
*Reminder*: E-mail is /not secure/! Do not send confidential info through
email (such as passwords).
To send secure e-mail, use Enigmail (http://enigmail.mozdev.org/)
------------------------------------------------------------------------
Get my PGP/GPG public key at http://www.rulecity.com/~matt/public_gmail.asc
Use this to send me encrypted (private) email.
Key Fingerprint is: F5F8 0B59 C0FB 2C65 47A6 F2FF B13E 8200 6502 46A4

Ricardo Salveti (rsalveti) wrote :

Pull request: https://lists.ubuntu.com/archives/kernel-team/2011-May/015591.html

SRU Justification:

Impact: Owners of Beagle xM rev C (newer ones) can't boot with current Natty's kernel.

Fix: Detect the rev C revision and proper initialize it (like older xM).

Testcase: Boot the kernel with a Beagle xM rev C board. If you boot fine you'll also be able to see the detected revision at dmesg, like:
ubuntu at omap:~$ dmesg | grep Beagle
[ 0.000000] Machine: OMAP3 Beagle Board
[ 0.154510] OMAP3 Beagle Rev: xM C

Robert Nelson (robertcnelson) wrote :

Matt,

Your ID of (011) doesn't make a lot of sense, since that would be the next logical "xM C++" aka "xM D" revision would be.. ;)

Maybe Koen knows something we don't, when he implemented the "omap3: beagle: if rev unknown, assume xM revision C" part of the xM C changeset...

Regards,

Tim Gardner (timg-tpi) on 2011-05-25
Changed in linux (Ubuntu):
status: New → Fix Committed
Changed in linux (Ubuntu Natty):
status: New → Fix Committed
Changed in linux (Ubuntu Oneiric):
importance: Undecided → Medium
Changed in linux (Ubuntu Natty):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.39-3.10

---------------
linux (2.6.39-3.10) oneiric; urgency=low

  [ Colin Ian King ]

  * SAUCE: S3 early resume debug via keyboard LEDs

  [ Ingo Molnar ]

  * ubuntu: nx-emu - i386: NX emulation
  * ubuntu: nx-emu - i386: mmap randomization for executable mappings

  [ Leann Ogasawara ]

  * Revert "[Config] Disable CONFIG_FT1000 on powerpc64-smp"
  * Revert "[Config] Disable CONFIG_DM_RAID45"
  * [Config] enable CONFIG_BRCMFMAC=y
  * [Config] enable CONFIG_MDIO_BITBANG=m across all arch's and flavors
  * [Config] enable CONFIG_VIDEO_OUTPUT_CONTROL=m on armel-omap

  [ Robert Nelson ]

  * SAUCE: omap3: beagle: detect new xM revision B
    - LP: #770679
  * SAUCE: omap3: beagle: detect new xM revision C
    - LP: #770679
  * SAUCE: omap3: beagle: if rev unknown, assume xM revision C
    - LP: #770679

  [ Stefan Bader ]

  * SAUCE: Convert dm-raid45 to new block plugging
 -- Leann Ogasawara <email address hidden> Mon, 23 May 2011 11:46:43 -0700

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel in -proposed solves
the problem. Please test the kernel and update this bug with the
results. If the problem is solved, change the tag
'verification-needed-natty' to 'verification-done-natty'.

If verification is not done by one week from today, this fix will be
dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how
to enable and use -proposed. Thank you!

tags: added: verification-needed-natty
Robert Nelson (robertcnelson) wrote :

Guys,

I won't be able to verify this in time, as another developer has the "C" board at another location.. By now, more users on irc should have the "C" board..

Regards,

Tobin Davis (gruemaster) wrote :

Normally, as the QA guy, I would test this and report back asap. Unfortunately, I cannot test this properly as I do not have one of the affected boards. I will reach out to the community on IRC and see if I can drum up volunteers.

Matt Ownby (matt-ownby) wrote :

I have a rev C board and am willing to test it if someone can walk me
through it and help me recover if it goes badly :)
I hang out in the #ubuntu-arm IRC channel ( Matt_O )

On Tue, Jun 7, 2011 at 9:16 AM, Tobin Davis <email address hidden>wrote:

> Normally, as the QA guy, I would test this and report back asap.
> Unfortunately, I cannot test this properly as I do not have one of the
> affected boards. I will reach out to the community on IRC and see if I
> can drum up volunteers.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/770679
>
> Title:
> Missing proper support for Beagle XM rev B and C
>
> Status in “linux” package in Ubuntu:
> Fix Released
> Status in “linux-linaro-omap” package in Ubuntu:
> New
> Status in “u-boot-linaro” package in Ubuntu:
> New
> Status in “linux” source package in Natty:
> Fix Committed
> Status in “linux-linaro-omap” source package in Natty:
> New
> Status in “u-boot-linaro” source package in Natty:
> New
> Status in “linux” source package in Oneiric:
> Fix Released
> Status in “linux-linaro-omap” source package in Oneiric:
> New
> Status in “u-boot-linaro” source package in Oneiric:
> New
>
> Bug description:
> Current code only checks for Beagle XM rev A (the first ones to get
> out), but now should also take care of the new revisions, mostly rev C
> as EHCI power got inverted again.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/770679/+subscribe
>

--
*Reminder*: E-mail is /not secure/! Do not send confidential info through
email (such as passwords).
To send secure e-mail, use Enigmail (http://enigmail.mozdev.org/)
------------------------------------------------------------------------
Get my PGP/GPG public key at http://www.rulecity.com/~matt/public_gmail.asc
Use this to send me encrypted (private) email.
Key Fingerprint is: F5F8 0B59 C0FB 2C65 47A6 F2FF B13E 8200 6502 46A4

Matt Ownby (matt-ownby) wrote :

I just tested the kernel and it seems to be working fine for me.
Here is my dmesg dump: http://paste.ubuntu.com/621469/

On Tue, Jun 7, 2011 at 9:46 PM, Matt Ownby <email address hidden> wrote:

> I have a rev C board and am willing to test it if someone can walk me
> through it and help me recover if it goes badly :)
> I hang out in the #ubuntu-arm IRC channel ( Matt_O )
>
>
> On Tue, Jun 7, 2011 at 9:16 AM, Tobin Davis <email address hidden>wrote:
>
>> Normally, as the QA guy, I would test this and report back asap.
>> Unfortunately, I cannot test this properly as I do not have one of the
>> affected boards. I will reach out to the community on IRC and see if I
>> can drum up volunteers.
>>
>> --
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>> https://bugs.launchpad.net/bugs/770679
>>
>> Title:
>> Missing proper support for Beagle XM rev B and C
>>
>> Status in “linux” package in Ubuntu:
>> Fix Released
>> Status in “linux-linaro-omap” package in Ubuntu:
>> New
>> Status in “u-boot-linaro” package in Ubuntu:
>> New
>> Status in “linux” source package in Natty:
>> Fix Committed
>> Status in “linux-linaro-omap” source package in Natty:
>> New
>> Status in “u-boot-linaro” source package in Natty:
>> New
>> Status in “linux” source package in Oneiric:
>> Fix Released
>> Status in “linux-linaro-omap” source package in Oneiric:
>> New
>> Status in “u-boot-linaro” source package in Oneiric:
>> New
>>
>> Bug description:
>> Current code only checks for Beagle XM rev A (the first ones to get
>> out), but now should also take care of the new revisions, mostly rev C
>> as EHCI power got inverted again.
>>
>> To unsubscribe from this bug, go to:
>> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/770679/+subscribe
>>
>
>
>
> --
> *Reminder*: E-mail is /not secure/! Do not send confidential info through
> email (such as passwords).
> To send secure e-mail, use Enigmail (http://enigmail.mozdev.org/)
> ------------------------------------------------------------------------
> Get my PGP/GPG public key at
> http://www.rulecity.com/~matt/public_gmail.asc
> Use this to send me encrypted (private) email.
> Key Fingerprint is: F5F8 0B59 C0FB 2C65 47A6 F2FF B13E 8200 6502 46A4
>

--
*Reminder*: E-mail is /not secure/! Do not send confidential info through
email (such as passwords).
To send secure e-mail, use Enigmail (http://enigmail.mozdev.org/)
------------------------------------------------------------------------
Get my PGP/GPG public key at http://www.rulecity.com/~matt/public_gmail.asc
Use this to send me encrypted (private) email.
Key Fingerprint is: F5F8 0B59 C0FB 2C65 47A6 F2FF B13E 8200 6502 46A4

Changed in u-boot-linaro (Ubuntu Oneiric):
importance: Undecided → Low
Changed in u-boot-linaro (Ubuntu Natty):
importance: Undecided → Low
Ricardo Salveti (rsalveti) wrote :

From Matt's log:
[ 0.000000] Linux version 2.6.38-10-omap (buildd@crabapple) (gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4) ) #44-Ubuntu Fri Jun 3 06:51:06 UTC 2011 (Ubuntu 2.6.38-10.44-omap 2.6.38.7)
...
[ 0.150482] OMAP3 Beagle Rev: xM C

So it's working fine on a Rev C.

Thanks for helping testing the package!

tags: added: verification-done-natty
removed: verification-needed-natty
Launchpad Janitor (janitor) wrote :
Download full text (26.1 KiB)

This bug was fixed in the package linux - 2.6.38-10.46

---------------
linux (2.6.38-10.46) natty-proposed; urgency=low

  [ Steve Conklin ]

  * Release Tracking Bug
    - LP: #802464

  [ Upstream Kernel Changes ]

  * Revert "put stricter guards on queue dead checks"
  * Revert "fix oops in scsi_run_queue()"

linux (2.6.38-10.45) natty-proposed; urgency=low

  [ Upstream Kernel Changes ]

  * Revert "af_unix: Only allow recv on connected seqpacket sockets."

linux (2.6.38-10.44) natty-proposed; urgency=low

  [ Steve Conklin ]

  * Release Tracking Bug
    - LP: #792013

  [ Robert Nelson ]

  * SAUCE: omap3: beagle: detect new xM revision B
    - LP: #770679
  * SAUCE: omap3: beagle: detect new xM revision C
    - LP: #770679
  * SAUCE: omap3: beagle: if rev unknown, assume xM revision C
    - LP: #770679

  [ Stefan Bader ]

  * Include nls_iso8859-1 for virtual images
    - LP: #732046

  [ Thomas Schlichter ]

  * SAUCE: vesafb: mtrr module parameter is uint, not bool
    - LP: #778043

  [ Tim Gardner ]

  * Revert "SAUCE: acpi battery -- move first lookup asynchronous"
    - LP: #775809
  * updateconfigs after update to v2.6.38.6

  [ Upstream Kernel Changes ]

  * Revert "ALSA: hda - Fix pin-config of Gigabyte mobo"
    - LP: #780546
  * Revert "[SCSI] Retrieve the Caching mode page"
    - LP: #788691
  * Revert "USB: xhci - fix unsafe macro definitions"
  * Revert "USB: xhci - fix math in xhci_get_endpoint_interval()"
  * Revert "USB: xhci - also free streams when resetting devices"
  * ath9k_hw: fix stopping rx DMA during resets
    - LP: #775809
  * netxen: limit skb frags for non tso packet
    - LP: #775809
  * ath: add missing regdomain pair 0x5c mapping
    - LP: #775809
  * block, blk-sysfs: Fix an err return path in blk_register_queue()
    - LP: #775809
  * p54: Initialize extra_len in p54_tx_80211
    - LP: #775809
  * qlcnic: limit skb frags for non tso packet
    - LP: #775809
  * nfsd4: fix struct file leak on delegation
    - LP: #775809
  * nfsd4: Fix filp leak
    - LP: #775809
  * virtio: Decrement avail idx on buffer detach
    - LP: #775809
  * x86, gart: Set DISTLBWALKPRB bit always
    - LP: #775809
  * x86, gart: Make sure GART does not map physmem above 1TB
    - LP: #775809
  * intel-iommu: Fix use after release during device attach
    - LP: #775809
  * intel-iommu: Unlink domain from iommu
    - LP: #775809
  * intel-iommu: Fix get_domain_for_dev() error path
    - LP: #775809
  * drm/radeon/kms: pll tweaks for r7xx
    - LP: #775809
  * drm/nouveau: fix notifier memory corruption bug
    - LP: #775809
  * drm/radeon/kms: fix bad shift in atom iio table parser
    - LP: #775809
  * drm/i915/tv: Remember the detected TV type
    - LP: #775809
  * tty/n_gsm: fix bug in CRC calculation for gsm1 mode
    - LP: #775809
  * serial/imx: read cts state only after acking cts change irq
    - LP: #775809
  * ASoC: Fix output PGA enabling in wm_hubs CODECs
    - LP: #775809
  * ASoC: codecs: JZ4740: Fix OOPS
    - LP: #775809
  * ALSA: hda - Add a fix-up for Acer dmic with ALC271x codec
    - LP: #775809
  * ahci: don't enable port irq before handler is registered
    - LP: #775809
  * libata: Implement ATA_FLAG_NO_...

Changed in linux (Ubuntu Natty):
status: Fix Committed → Fix Released
John Rigby (jcrigby) on 2012-07-24
Changed in u-boot-linaro (Ubuntu):
status: New → Fix Released
Changed in u-boot-linaro (Ubuntu Natty):
status: New → Fix Released
Changed in u-boot-linaro (Ubuntu Oneiric):
status: New → Fix Released
Chase Qi (chase-qi) wrote :
Rolf Leggewie (r0lf) wrote :

natty has seen the end of its life and is no longer receiving any updates. Marking the natty task for this ticket as "Won't Fix".

Changed in linux-linaro-omap (Ubuntu Natty):
status: New → Won't Fix
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in linux-linaro-omap (Ubuntu Oneiric):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.