Packaging request: Either replace TTF with OTF or make two packages available

Bug #200204 reported by Kess Vargavind on 2008-03-09
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux-libertine (Debian)
Fix Released
Unknown
linux-libertine (Ubuntu)
Wishlist
MOTU
Declined for Lucid by Andrew Starr-Bochicchio

Bug Description

Binary package hint: linux-libertine

A request for the packaging of this font.

Background
 • To use “Linux Libertine O” with OpenType features in XeTeX one has to install it oneself, as the OpenType version is not available in the repository.
 • Only the TrueType version of “Linux Libertine” is available in the repositories, and no package depends on it.

Suggestion, one of the following
 • Replace the TrueType version with the OpenType version.
 • Make available an OpenType version package in the repository alongside the TrueType version.

Daniel T Chen (crimsun) on 2008-12-01
Changed in linux-libertine:
importance: Undecided → Wishlist
status: New → Confirmed
Joseph Wakeling (webdrake) wrote :

Should surely be two packages, since e.g. OpenOffice will not work with an OpenType version of the font. (OOo does not recognise e.g. the ADF fonts which are in OpenType format.)

Ben M. (bmhm) wrote :

Hi,

OpenOffice.org 3.2, which comes with lucid, does recognize OTF.
Can we expect an update for lucid?

Changed in linux-libertine (Ubuntu):
assignee: nobody → MOTU (motu)
Changed in linux-libertine (Debian):
status: Unknown → New
Apteryx (maxco) wrote :

I'm not sure I understand. Is the current linux libertine package in Lucid Lynx not OpenType? If it's not, why would they have added an 'O' at the end? (Linux Libertine O). I'm confused.

Hi there.

I am working on this in Debian right now (you can see the commits that I've made this afternoon). I really dislike having only TTF versions of the fonts, but I am stuck for the moment with the packaging that I inherited.

Things will be fixed soon. Not sure if in time for the next release, but I really want this wart removed not only for Linux Libertine, but also for some other font packages which I happen to use, BTW.

Regards, Rogério Brito.
(Member of the Debian Fonts team).

Changed in linux-libertine (Debian):
status: New → Fix Released

Hi there.

Could you please test the situation with the linux-libertine package that I have uploaded to my PPA? You can see the pertinent information at:

    https://launchpad.net/~rbrito/+archive/ppa

I am only providing OTF fonts from now on.

Regards.

Evan Langlois (uudruid74) wrote :

You can always convert the fonts with fontforge?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.