test_bpf in net from ubuntu_kernel_selftests failed on cloud kernels

Bug #1812189 reported by Po-Hsu Lin on 2019-01-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
linux-gke (Ubuntu)
Undecided
Unassigned
linux-kvm (Ubuntu)
Undecided
Unassigned
linux-oracle (Ubuntu)
Undecided
Unassigned

Bug Description

This test will attempt to insert the test_bpf module, but this module does not exist in KVM kernels:

$ sudo modprobe test_bpf
modprobe: FATAL: Module test_bpf not found in directory /lib/modules/4.15.0-1028-kvm

The script:
$ sudo ./test_bpf.sh
test_bpf: [FAIL]

$ cat test_bpf.sh
#!/bin/sh
# SPDX-License-Identifier: GPL-2.0
# Runs bpf test using test_bpf kernel module

if /sbin/modprobe -q test_bpf ; then
 /sbin/modprobe -q -r test_bpf;
 echo "test_bpf: ok";
else
 echo "test_bpf: [FAIL]";
 exit 1;
fi

This test_bpf module will need the CONFIG_TEST_BPF to be enabled.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-image-4.15.0-1028-kvm 4.15.0-1028.28
ProcVersionSignature: User Name 4.15.0-1028.28-kvm 4.15.18
Uname: Linux 4.15.0-1028-kvm x86_64
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
Date: Thu Jan 17 08:29:29 2019
SourcePackage: linux-kvm
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :

Failed on Cosmic kernel as well.
$ sudo modprobe test_bpf
modprobe: FATAL: Module test_bpf not found in directory /lib/modules/4.18.0-14-generic

summary: - test_bpf in net from ubuntu_kernel_selftests failed on KVM kernels
+ test_bpf in net from ubuntu_kernel_selftests failed on KVM / Cosmic
+ kernels

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1812189

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

Found on Xenial s390x as well. (only on s390x, passed on other architectures)

Po-Hsu Lin (cypressyew) wrote :

Passed on B-4.18
 selftests: net: test_bpf.sh
 ========================================
 test_bpf: ok
 ok 1..8 selftests: net: test_bpf.sh [PASS]

Changed in ubuntu-kernel-tests:
status: New → Fix Released
Po-Hsu Lin (cypressyew) wrote :

Checked X/B/C, test passed.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in linux (Ubuntu Xenial):
status: New → Invalid
Changed in linux (Ubuntu Bionic):
status: New → Invalid
Changed in linux (Ubuntu Cosmic):
status: New → Invalid
Changed in linux-kvm (Ubuntu):
status: New → Invalid
Changed in linux-kvm (Ubuntu Xenial):
status: New → Opinion
Changed in linux-kvm (Ubuntu Bionic):
status: New → Invalid
Changed in linux-kvm (Ubuntu Xenial):
status: Opinion → Invalid
Changed in linux-kvm (Ubuntu Cosmic):
status: New → Invalid
Po-Hsu Lin (cypressyew) on 2019-06-24
tags: added: linux-kvm sru-20190603 ubuntu-kernel-selftests
tags: removed: sru-20190603
Po-Hsu Lin (cypressyew) wrote :

This is still valid for KVM kernels. Re-open the bug.

$ sudo ./test_bpf.sh
test_bpf: [FAIL]
sudo /sbin/modprobe test_bpf
modprobe: FATAL: Module test_bpf not found in directory /lib/modules/4.18.0-1015-kvm

Changed in linux-kvm (Ubuntu):
status: Invalid → Confirmed
Changed in linux-kvm (Ubuntu Bionic):
status: Invalid → Confirmed
Changed in linux-kvm (Ubuntu Xenial):
status: Invalid → Confirmed
Changed in linux-kvm (Ubuntu Cosmic):
status: Invalid → Confirmed
Changed in ubuntu-kernel-tests:
status: Fix Released → Confirmed
Po-Hsu Lin (cypressyew) wrote :

BTW fix in comment #5 is for generic kernel.

Po-Hsu Lin (cypressyew) on 2019-07-22
tags: added: sru-20190701
tags: added: 5.0 disco
Po-Hsu Lin (cypressyew) wrote :

Failed on GKE 5.0 as well.

tags: added: gke
Sean Feole (sfeole) on 2019-08-29
Changed in ubuntu-kernel-tests:
status: Confirmed → Invalid
Changed in linux-kvm (Ubuntu):
status: Confirmed → Invalid
Changed in linux-kvm (Ubuntu Xenial):
status: Confirmed → Invalid
Changed in linux-kvm (Ubuntu Bionic):
status: Confirmed → Invalid
Changed in linux-kvm (Ubuntu Cosmic):
status: Confirmed → Invalid
Po-Hsu Lin (cypressyew) wrote :

Re-open this bug as this is still an issue.

The test_bpf test in net failed with GKE 5.0.0-1030.31:
  test_bpf: [FAIL]
  not ok 1..9 selftests: net: test_bpf.sh [FAIL]

Further investigate shows this module will require config_test_bpf to be enabled in the kernel config.

Changed in ubuntu-kernel-tests:
status: Invalid → Confirmed
Changed in linux (Ubuntu):
status: Invalid → Confirmed
no longer affects: linux (Ubuntu Cosmic)
summary: - test_bpf in net from ubuntu_kernel_selftests failed on KVM / Cosmic
- kernels
+ test_bpf in net from ubuntu_kernel_selftests failed on cloud kernels
Changed in linux-kvm (Ubuntu):
status: Invalid → Confirmed
no longer affects: linux-kvm (Ubuntu Cosmic)
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Po-Hsu Lin (cypressyew) wrote :

This is not affecting the generic kernel as we have config_test_bpf set to m.

tags: added: sru-20200127
Po-Hsu Lin (cypressyew) on 2020-02-05
no longer affects: linux (Ubuntu Xenial)
no longer affects: linux-kvm (Ubuntu Xenial)
no longer affects: linux (Ubuntu Bionic)
no longer affects: linux-kvm (Ubuntu Bionic)
Changed in linux-gke (Ubuntu):
status: New → Confirmed
Sean Feole (sfeole) on 2020-02-26
tags: added: sru-20200217
Po-Hsu Lin (cypressyew) on 2020-07-15
tags: added: sru-20200629
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers