dccp test in ubuntu_stress_smoke_test failed with 4.4/4.15 KVM kernel

Bug #1760638 reported by Po-Hsu Lin on 2018-04-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Colin Ian King
linux (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned
Bionic
Medium
Unassigned
linux-kvm (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
stress-ng (Ubuntu)
Undecided
Colin Ian King
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

The test failed with:
16:26:24 DEBUG| [stdout] dccp STARTING
16:26:24 DEBUG| [stdout] dccp RETURNED 2
16:26:24 DEBUG| [stdout] dccp FAILED
16:26:24 DEBUG| [stdout] stress-ng: debug: [2228] 2 processors online, 2 processors configured
16:26:24 DEBUG| [stdout] stress-ng: info: [2228] dispatching hogs: 4 dccp
16:26:24 DEBUG| [stdout] stress-ng: debug: [2228] cache allocate: reducing cache level from L3 (too high) to L2
16:26:24 DEBUG| [stdout] stress-ng: debug: [2228] cache allocate: default cache size: 4096K
16:26:24 DEBUG| [stdout] stress-ng: debug: [2228] starting stressors
16:26:24 DEBUG| [stdout] stress-ng: debug: [2228] 4 stressors spawned
16:26:24 DEBUG| [stdout] stress-ng: debug: [2231] stress-ng-dccp: started [2231] (instance 2)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2232] stress-ng-dccp: started [2232] (instance 3)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2229] stress-ng-dccp: started [2229] (instance 0)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2230] stress-ng-dccp: started [2230] (instance 1)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2231] stress-ng-dccp: process [2231] using socket port 10002
16:26:24 DEBUG| [stdout] stress-ng: debug: [2229] stress-ng-dccp: process [2229] using socket port 10000
16:26:24 DEBUG| [stdout] stress-ng: debug: [2232] stress-ng-dccp: process [2232] using socket port 10003
16:26:24 DEBUG| [stdout] stress-ng: debug: [2230] stress-ng-dccp: process [2230] using socket port 10001
16:26:24 DEBUG| [stdout] stress-ng: debug: [2231] stress-ng-dccp: socket failed, errno=94 (Socket type not supported)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2231] stress-ng-dccp: 0 messages sent
16:26:24 DEBUG| [stdout] stress-ng: debug: [2231] stress-ng-dccp: exited [2231] (instance 2)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2239] stress-ng-dccp: socket failed, errno=94 (Socket type not supported)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2230] stress-ng-dccp: socket failed, errno=94 (Socket type not supported)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2230] stress-ng-dccp: 0 messages sent
16:26:24 DEBUG| [stdout] stress-ng: debug: [2230] stress-ng-dccp: exited [2230] (instance 1)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2232] stress-ng-dccp: socket failed, errno=94 (Socket type not supported)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2232] stress-ng-dccp: 0 messages sent
16:26:24 DEBUG| [stdout] stress-ng: debug: [2232] stress-ng-dccp: exited [2232] (instance 3)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2235] stress-ng-dccp: socket failed, errno=94 (Socket type not supported)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2229] stress-ng-dccp: socket failed, errno=94 (Socket type not supported)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2229] stress-ng-dccp: 0 messages sent
16:26:24 DEBUG| [stdout] stress-ng: debug: [2229] stress-ng-dccp: exited [2229] (instance 0)
16:26:24 DEBUG| [stdout] stress-ng: error: [2228] process 2229 (stress-ng-dccp) terminated with an error, exit status=1 (stress-ng core failure)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2228] process [2229] terminated
16:26:24 DEBUG| [stdout] stress-ng: error: [2228] process 2230 (stress-ng-dccp) terminated with an error, exit status=1 (stress-ng core failure)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2228] process [2230] terminated
16:26:24 DEBUG| [stdout] stress-ng: error: [2228] process 2231 (stress-ng-dccp) terminated with an error, exit status=1 (stress-ng core failure)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2228] process [2231] terminated
16:26:24 DEBUG| [stdout] stress-ng: error: [2228] process 2232 (stress-ng-dccp) terminated with an error, exit status=1 (stress-ng core failure)
16:26:24 DEBUG| [stdout] stress-ng: debug: [2228] process [2232] terminated
16:26:24 DEBUG| [stdout] stress-ng: info: [2228] unsuccessful run completed in 0.01s
16:26:24 DEBUG| [stdout]

Steps to reproduce:
  Deploy the node with Xenial 4.4 kernel, install linux-kvm
  sudo apt-get install python-minimal
  git clone --depth=1 git://kernel.ubuntu.com/ubuntu/autotest-client-tests -b master-next
  git clone --depth=1 git://kernel.ubuntu.com/ubuntu/autotest
  rm -fr autotest/client/tests
  ln -sf ~/autotest-client-tests autotest/client/tests
  AUTOTEST_PATH=/home/ubuntu/autotest sudo -E autotest/client/autotest-local --verbose autotest/client/tests/ubuntu_stress_smoke_test/control

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.4.0-1019-kvm 4.4.0-1019.24
ProcVersionSignature: User Name 4.4.0-1019.24-kvm 4.4.98
Uname: Linux 4.4.0-1019-kvm x86_64
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
Date: Mon Apr 2 16:31:05 2018
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-kvm
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :
summary: - dccp test in ubuntu_stress_smoke_test failed with 4.4 X-KVM kernel Edit
+ dccp test in ubuntu_stress_smoke_test failed with 4.4 X-KVM kernel

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1760638

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

Can be found on B-KVM as well.

summary: - dccp test in ubuntu_stress_smoke_test failed with 4.4 X-KVM kernel
+ dccp test in ubuntu_stress_smoke_test failed with 4.4/4.15 KVM kernel
Changed in linux (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
Changed in linux (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
tags: added: kernel-da-key
Po-Hsu Lin (cypressyew) on 2018-04-12
tags: added: bionic
Po-Hsu Lin (cypressyew) on 2018-07-20
Changed in linux (Ubuntu):
status: Triaged → Invalid
Changed in linux-kvm (Ubuntu):
status: New → Invalid
Changed in ubuntu-kernel-tests:
status: New → Fix Released
Changed in linux (Ubuntu Xenial):
status: Triaged → Invalid
Changed in linux (Ubuntu Bionic):
status: Triaged → Invalid
Changed in linux-kvm (Ubuntu Xenial):
status: New → Invalid
Changed in linux-kvm (Ubuntu Bionic):
status: New → Invalid
Changed in stress-ng (Ubuntu):
status: New → Fix Released
assignee: nobody → Colin Ian King (colin-king)
Changed in ubuntu-kernel-tests:
assignee: nobody → Colin Ian King (colin-king)
Colin Ian King (colin-king) wrote :

See also: https://bugs.launchpad.net/ubuntu/+source/linux-kvm/+bug/1782727

DCCP is not enabled in this kernel

..and updates stress-ng to warn and not fail if the protocol is disabled:

http://kernel.ubuntu.com/git/cking/stress-ng.git/commit/?id=1c54d53b33d8e2b11c9c47b9cff04612ba9d7e14

Po-Hsu Lin (cypressyew) on 2018-07-20
Changed in stress-ng (Ubuntu Xenial):
status: New → Fix Released
Changed in stress-ng (Ubuntu Bionic):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers