af-alg test in ubuntu_stress_smoke_test failed with 4.4/4.15 KVM kernel

Bug #1760637 reported by Po-Hsu Lin on 2018-04-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Colin Ian King
linux (Ubuntu)
Undecided
Unassigned
Nominated for Bionic by Po-Hsu Lin
Nominated for Xenial by Po-Hsu Lin
linux-kvm (Ubuntu)
Undecided
Unassigned
Nominated for Bionic by Po-Hsu Lin
Nominated for Xenial by Po-Hsu Lin
stress-ng (Ubuntu)
Undecided
Colin Ian King
Nominated for Bionic by Po-Hsu Lin
Nominated for Xenial by Po-Hsu Lin

Bug Description

The test failed with:
16:23:49 DEBUG| [stdout] af-alg STARTING
16:23:54 DEBUG| [stdout] af-alg RETURNED 2
16:23:54 DEBUG| [stdout] af-alg FAILED
16:23:54 DEBUG| [stdout] stress-ng: debug: [3569] 2 processors online, 2 processors configured
16:23:54 DEBUG| [stdout] stress-ng: info: [3569] dispatching hogs: 4 af-alg
16:23:54 DEBUG| [stdout] stress-ng: debug: [3569] cache allocate: reducing cache level from L3 (too high) to L2
16:23:54 DEBUG| [stdout] stress-ng: debug: [3569] cache allocate: default cache size: 4096K
16:23:54 DEBUG| [stdout] stress-ng: debug: [3569] starting stressors
16:23:54 DEBUG| [stdout] stress-ng: debug: [3569] 4 stressors spawned
16:23:54 DEBUG| [stdout] stress-ng: debug: [3570] stress-ng-af-alg: started [3570] (instance 0)
16:23:54 DEBUG| [stdout] stress-ng: debug: [3573] stress-ng-af-alg: started [3573] (instance 3)
16:23:54 DEBUG| [stdout] stress-ng: debug: [3571] stress-ng-af-alg: started [3571] (instance 1)
16:23:54 DEBUG| [stdout] stress-ng: debug: [3572] stress-ng-af-alg: started [3572] (instance 2)
16:23:54 DEBUG| [stdout] stress-ng: fail: [3570] stress-ng-af-alg: socket failed, errno=97 (Address family not supported by protocol)
16:23:54 DEBUG| [stdout] stress-ng: debug: [3570] stress-ng-af-alg: exited [3570] (instance 0)
16:23:54 DEBUG| [stdout] stress-ng: error: [3569] process 3570 (stress-ng-af_alg) terminated with an error, exit status=1 (stress-ng core failure)
16:23:54 DEBUG| [stdout] stress-ng: debug: [3569] process [3570] terminated
16:23:54 DEBUG| [stdout] stress-ng: fail: [3571] stress-ng-af-alg: socket failed, errno=97 (Address family not supported by protocol)
16:23:54 DEBUG| [stdout] stress-ng: debug: [3571] stress-ng-af-alg: exited [3571] (instance 1)
16:23:54 DEBUG| [stdout] stress-ng: error: [3569] process 3571 (stress-ng-af_alg) terminated with an error, exit status=1 (stress-ng core failure)
16:23:54 DEBUG| [stdout] stress-ng: debug: [3569] process [3571] terminated
16:23:54 DEBUG| [stdout] stress-ng: fail: [3573] stress-ng-af-alg: socket failed, errno=97 (Address family not supported by protocol)
16:23:54 DEBUG| [stdout] stress-ng: debug: [3573] stress-ng-af-alg: exited [3573] (instance 3)
16:23:54 DEBUG| [stdout] stress-ng: fail: [3572] stress-ng-af-alg: socket failed, errno=97 (Address family not supported by protocol)
16:23:54 DEBUG| [stdout] stress-ng: debug: [3572] stress-ng-af-alg: exited [3572] (instance 2)
16:23:54 DEBUG| [stdout] stress-ng: error: [3569] process 3572 (stress-ng-af_alg) terminated with an error, exit status=1 (stress-ng core failure)
16:23:54 DEBUG| [stdout] stress-ng: debug: [3569] process [3572] terminated
16:23:54 DEBUG| [stdout] stress-ng: error: [3569] process 3573 (stress-ng-af_alg) terminated with an error, exit status=1 (stress-ng core failure)
16:23:54 DEBUG| [stdout] stress-ng: debug: [3569] process [3573] terminated
16:23:54 DEBUG| [stdout] stress-ng: info: [3569] unsuccessful run completed in 5.01s
16:23:54 DEBUG| [stdout]

Steps to reproduce:
  Deploy the node with Xenial 4.4 kernel, install linux-kvm
  sudo apt-get install python-minimal
  git clone --depth=1 git://kernel.ubuntu.com/ubuntu/autotest-client-tests -b master-next
  git clone --depth=1 git://kernel.ubuntu.com/ubuntu/autotest
  rm -fr autotest/client/tests
  ln -sf ~/autotest-client-tests autotest/client/tests
  AUTOTEST_PATH=/home/ubuntu/autotest sudo -E autotest/client/autotest-local --verbose autotest/client/tests/ubuntu_stress_smoke_test/control

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.4.0-1019-kvm 4.4.0-1019.24
ProcVersionSignature: User Name 4.4.0-1019.24-kvm 4.4.98
Uname: Linux 4.4.0-1019-kvm x86_64
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
Date: Mon Apr 2 16:25:57 2018
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-kvm
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :
description: updated

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1760637

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Po-Hsu Lin (cypressyew) wrote :

Can be found on B-KVM as well.

summary: - af-alg test in ubuntu_stress_smoke_test failed with 4.4 X-KVM kernel
+ af-alg test in ubuntu_stress_smoke_test failed with 4.4/4.15 KVM kernel
Po-Hsu Lin (cypressyew) on 2018-04-12
tags: added: bionic
Po-Hsu Lin (cypressyew) on 2018-07-20
Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in linux-kvm (Ubuntu):
status: New → Invalid
Changed in ubuntu-kernel-tests:
assignee: nobody → Colin Ian King (colin-king)
status: New → Fix Released
Changed in stress-ng (Ubuntu):
assignee: nobody → Colin Ian King (colin-king)
status: New → Fix Released
Colin Ian King (colin-king) wrote :
Colin Ian King (colin-king) wrote :

I've also added changes to stress-ng to warn this protocol is not supported rather than fail:

http://kernel.ubuntu.com/git/cking/stress-ng.git/commit/?id=3ec28f2f54381910771299df03c0dfa90a3bdbf5

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers