port80 test in kvm-unit-test failed on E4v3 azure node with 4.13/4.14 kernel

Bug #1748105 reported by Po-Hsu Lin on 2018-02-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-azure (Ubuntu)
Undecided
Unassigned
linux-azure-edge (Ubuntu)
Undecided
Unassigned
linux-kvm (Ubuntu)
Undecided
Unassigned

Bug Description

With Joshua's comment in bug 1719524: "Nested KVM can only be tried on instance sizes with nested Hypervisor support: Ev3 and Dv3.", although the instance name is E4v3 here but I can start a KVM on it.

Test port80 test will timeout on it.

Steps:
1. git clone --depth=1 https://git.kernel.org/pub/scm/virt/kvm/kvm-unit-tests.git
2. cd kvm-unit-tests; ./configure; make
3. Run the port80 test as root:

# TESTNAME=port80 TIMEOUT=90s ACCEL= ./x86/run x86/port80.flat -smp 1
timeout -k 1s --foreground 90s /usr/bin/qemu-system-x86_64 -nodefaults -device pc-testdev -device isa-debug-exit,iobase=0xf4,iosize=0x4 -vnc none -serial stdio -device pci-testdev -machine accel=kvm -kernel x86/port80.flat -smp 1 # -initrd /tmp/tmp.3p9PWc2SRi
enabling apic
begining port 0x80 write test
qemu-system-x86_64: terminating on signal 15 from pid 7790

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.14.0-1004-azure-edge 4.14.0-1004.4
ProcVersionSignature: User Name 4.14.0-1004.4-username-edge 4.14.14
Uname: Linux 4.14.0-1004-azure-edge x86_64
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
Date: Thu Feb 8 06:13:18 2018
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-azure-edge
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) on 2018-02-08
summary: - port80 test in kvm-unit-test failed on E4v3 azure node with 4.14 kernel
+ port80 test in kvm-unit-test failed on E4v3 azure node with 4.13/4.14
+ kernel

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1748105

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Po-Hsu Lin (cypressyew) wrote :

Spotted on X-KVM.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers