no connection anymore with r8152 on 4.13.0-26

Bug #1742922 reported by Corben on 2018-01-12
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
linux-hwe (Ubuntu)
Medium
Unassigned

Bug Description

Since yesterdays upgrade to linux-image-4.13.0-26-generic:amd64 my wired network is not working anymore. In the system log files I see hundrets of messages like this:

kernel: r8152 2-2.2:1.0 enx949aa925a648: Tx status -71

The network card is detected, but it's not working properly.

It still works with Kernel 4.10.

lsb_release -rd
Description: Ubuntu 16.04.3 LTS
Release: 16.04

apt policy linux-signed-image-generic-hwe-16.04
linux-signed-image-generic-hwe-16.04:
  Installiert: 4.13.0.26.46
  Installationskandidat: 4.13.0.26.46
  Versionstabelle:
 *** 4.13.0.26.46 500
        500 http://de.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.13.0-26-generic 4.13.0-26.29~16.04.2
ProcVersionSignature: Ubuntu 4.13.0-26.29~16.04.2-generic 4.13.13
Uname: Linux 4.13.0-26-generic x86_64
NonfreeKernelModules: zfs zunicode zavl zcommon znvpair
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Jan 12 12:39:32 2018
InstallationDate: Installed on 2015-11-12 (792 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
SourcePackage: linux-hwe
UpgradeStatus: Upgraded to xenial on 2016-07-29 (531 days ago)

Corben (tobias-krummen) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-hwe (Ubuntu):
status: New → Confirmed
MGGermany (max-gutberlet) wrote :

Same issue as user above - downgrade to .21 makes system stable again

linux-image-4.13.0-25-generic:
  Installiert: 4.13.0-25.29
  Installationskandidat: 4.13.0-25.29
  Versionstabelle:
 *** 4.13.0-25.29 500
        500 http://de.archive.ubuntu.com/ubuntu artful-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu artful-security/main amd64 Packages
        100 /var/lib/dpkg/status

Corben (tobias-krummen) wrote :

Looks like the r8152 driver is working with the device that has the usb id: 0bda:0307, which is an usb 3.0 to ethernet adapter with three usb 3.0 ports on it.

The affected device where the driver is not working, has the usb id 045Ep:07C6d, which is in a docking station (2 x display port, 2 x usb 2.0, 2 x usb 3.0).

Corben (tobias-krummen) wrote :

Issue still present with today's kernel update:

apt policy linux-signed-image-generic-hwe-16.04
linux-signed-image-generic-hwe-16.04:
  Installed: 4.13.0.36.55
  Candidate: 4.13.0.36.55
  Version table:
 *** 4.13.0.36.55 500
        500 http://de.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
        100 /var/lib/dpkg/status

Corben (tobias-krummen) wrote :

Still broken in 4.13.0.37.56 with r8152 v1.09.9

I tried the driver from the realteak page v2.09.0 with no difference. That driver works with other realtek usb network devices, but not with the Microsoft Dock anymore. So it might not be directly driver related but something that changed inside the kernel?

Mathias Radtke (raddirad) wrote :

This problem still exists.
is there anyone working on this issue?

Corben (tobias-krummen) wrote :

Looks like the USB ID of the dock's network interface is removed in the r8152 driver since 4.10+, and should be handled by the cdc_ether driver, which doesn't work because it's blocked in that driver.

Someone on reddit gave me this information (see: https://www.reddit.com/r/SurfaceLinux/comments/860cuy/regressions_dock_ethernet_r8152_intel_pstate_with/dw1uxlo/?context=3).
Maybe it got pushed upstream: https://github.com/jakeday/linux-surface/pull/9

Haven't tried a newer kernel yet, maybe with Ubuntu 18.04 LTS the situation changed, or will change with the first point release of 18.04 when also a newer kernel of 16.04 LTS will be available.

Mathias Radtke (raddirad) wrote :

thanks for the hint, I had to edit the patch a bit but now it works fine. Did this on 4.17.6

Cheers

tags: added: patch
Joseph Salisbury (jsalisbury) wrote :

Thank you for providing a patch, and making Ubuntu better.

Can you provide some information on the status of the patch with regards to getting it merged upstream? Has it been sent upstream, what sort of feedback has it received, is it getting applied to a subsystem maintainer's tree, etc?

People affected by this bug are probably wondering why the kernel team doesn't just apply the patch and fix it. The reason is that the kernel team is reluctant (not opposed) to apply any patch to a stable kernel that is not from upstream. Applying patches that don't come from upstream add greatly to the support of the kernel as other upstream patches may touch the same area as the non-upstream patch and may prevent them from applying cleanly.

To submit your patch, send your patch with the detailed description/changelog and your Signoff (ending with Signed-off-by: your name <email>), to the emails listed from ./scripts/get_maintainer.pl drivers/SUBSYSTEM-DETAILS (the get_maintainer.pl is from the kernel sources). Once you have sent the patch upstream and it's accepted, please drop a note here so that we can cherry-pick/include the patch into Ubuntu kernel.

Changed in linux-hwe (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Mathias Radtke (raddirad) wrote :

Hi,
I just submitter my patch to the corresponding maintainers and let's see what happens

Launchpad Janitor (janitor) wrote :

[Expired for linux-hwe (Ubuntu) because there has been no activity for 60 days.]

Changed in linux-hwe (Ubuntu):
status: Incomplete → Expired
Corben (tobias-krummen) wrote :

Hey Mathias. Did you get any updates on this?

I'm now on Ubuntu 18.04.1 LTS with kernel 4.15, but this issue is still present.

As I'm using the USB to Ethernet adapter all the time, I kinda forgot about this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers