no sound cards found afer kernel update from 6.2.0-26 to 6.2.0-32

Bug #2036342 reported by Lars W
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-hwe-6.2 (Ubuntu)

Bug Description

After the update from kernel 6.2.0-26 to 6.2.0-32 under Ubuntu 22.04 LTS, there are no more sound cards found. I can reliably reproduce this by switching in the grub boot menu between the kernel versions.

I used sound over HDMI of the NVIDIA Corporation GP108 [GeForce GT 1030] and it used to use the module snd_hda_intel. Now, a symptom is that `aplay -l` reports "no soundcards found", and neither does any other program.

I had similar problems after the Ubuntu update from 5.19.0-43 to 5.19.0-45.

I reported this to the offical linux kernel mailinglist yesterday ( ). They have sent me here. Indeed, I now tried the vanilla "mainline" kernels 6.2.0-rc8 and 6.5.3 - and there the sound cards are correctly found.

I am attaching logfiles and info from /proc for the different tried kernel version that are hopefully useful. Please let me know if there is more info I can provide or things I could try to narrow down the problem.

ProblemType: Bug
DistroRelease: Ubuntu 22.04
Package: linux-image-6.2.0-32-generic (not installed)
ProcVersionSignature: Ubuntu 6.2.0-26.26~22.04.1-generic 6.2.13
Uname: Linux 6.2.0-26-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu82.5
Architecture: amd64
CasperMD5CheckResult: unknown
CurrentDesktop: KDE
Date: Sun Sep 17 09:52:19 2023
InstallationDate: Installed on 2023-04-16 (153 days ago)
InstallationMedia: Kubuntu 22.04.2 LTS "Jammy Jellyfish" - Release amd64 (20230223)
SourcePackage: linux-signed-hwe-6.2
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Lars W (lavs) wrote :
Revision history for this message
Juerg Haefliger (juergh) wrote :

Hm. Is this the only thing that's not working after the upgrade? What about bluetooth and wifi?

affects: linux-signed-hwe-6.2 (Ubuntu) → linux-hwe-6.2 (Ubuntu)
Revision history for this message
Lars W (lavs) wrote :

It resolved itself. Sorry to bother you.

I listed all installed Linux kernel packages (dpkg -l | grep "linux\-[a-z]*\-") and kept only the 6.2.0-26 versions. Then I removed unused packages (sudo apt autoremove) and afterwards reinstalled 6.2.0-32 (sudo apt install linux-image-6.2.0-32-generic linux-modules-6.2.0-32-generic linux-modules-extra-6.2.0-32-generic linux-modules-nvidia-525-6.2.0-32-generic linux-objects-nvidia-525-6.2.0-32-generic linux-signatures-nvidia-6.2.0-32-generic). Now sounds works again! (I don't know if WiFi was affected, but it works now.)

For reference, I attach the dmesg logs without timestamps (sed 's/^\[ *[0-9]*\.[0-9]*\] //') from the original problematic 6.2.0-32 kernel and again after reinstall. The first substantial difference I could spot is after "PM: Magic number" it no longer says "acpi AMDI0020:02: hash matches".

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.