linux-gcp: 4.15.0-1002.2 -proposed tracker

Bug #1757168 reported by Seth Forshee on 2018-03-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Kernel SRU Workflow
Medium
Unassigned
Automated-testing
Medium
Canonical Kernel Team
Prepare-package
Medium
Marcelo Cerri
Prepare-package-meta
Medium
Marcelo Cerri
Promote-to-proposed
Medium
Canonical Kernel Team
Promote-to-release
Medium
Ubuntu Package Archive Administrators
Regression-testing
Medium
Po-Hsu Lin
linux-gcp (Ubuntu)
Medium
Unassigned
Bionic
Medium
Unassigned

Bug Description

This bug is for tracking the <version to be filled> upload package. This bug will contain status and testing results related to that upload.

For an explanation of the tasks and the associated workflow see: https://wiki.ubuntu.com/Kernel/kernel-sru-workflow
-- swm properties --
kernel-master-bug: 1757164
phase: Promoted to proposed
proposed-announcement-sent: true
proposed-testing-requested: true

Seth Forshee (sforshee) on 2018-03-20
tags: added: kernel-release-tracking-bug
tags: added: kernel-release-tracking-bug-live
tags: added: bionic
Changed in linux-gcp (Ubuntu Bionic):
status: New → Confirmed
Changed in linux-gcp (Ubuntu):
importance: Undecided → Medium
Changed in kernel-sru-workflow:
status: New → In Progress
importance: Undecided → Medium
tags: added: kernel-sru-cycle-devel-2018.03.16-1
tags: added: kernel-sru-derivative-of-1757164
Brad Figg (brad-figg) on 2018-03-20
description: updated
description: updated
Marcelo Cerri (mhcerri) on 2018-03-27
summary: - linux-gcp: <version to be filled> -proposed tracker
+ linux-gcp: 4.15.0-1002.2 -proposed tracker
Brad Figg (brad-figg) on 2018-03-27
tags: added: block-proposed-bionic
tags: added: block-proposed
description: updated
description: updated
Brad Figg (brad-figg) on 2018-03-28
description: updated
description: updated
Po-Hsu Lin (cypressyew) wrote :

No 1804 image for GCP

gcloud compute instances create b-lgcp-gcp-4-15-0-f1-micro-aufs-smoke-test --zone us-west1-a --network "default" --no-restart-on-failure --image-project ubuntu-os-cloud --image-family ubuntu-1804'

 - The resource 'projects/ubuntu-os-cloud/global/images/family/ubuntu-1804' was not found

Brad Figg (brad-figg) on 2018-03-29
tags: removed: block-proposed-bionic
tags: removed: block-proposed
Launchpad Janitor (janitor) wrote :
Download full text (113.2 KiB)

This bug was fixed in the package linux-gcp - 4.15.0-1003.3

---------------
linux-gcp (4.15.0-1003.3) bionic; urgency=medium

  * linux-gcp: 4.15.0-1003.3 -proposed tracker (LP: #1761182)

  * Miscellaneous Ubuntu changes
    - [Packaging] do_tools_hyperv = false for gcp
    - [Packaging] Remove gcp cloud-tools packages from control stubs

  [ Ubuntu: 4.15.0-15.16 ]

  * linux: 4.15.0-15.16 -proposed tracker (LP: #1761177)
  * FFe: Enable configuring resume offset via sysfs (LP: #1760106)
    - PM / hibernate: Make passing hibernate offsets more friendly
  * /dev/bcache/by-uuid links not created after reboot (LP: #1729145)
    - SAUCE: (no-up) bcache: decouple emitting a cached_dev CHANGE uevent
  * Ubuntu18.04:POWER9:DD2.2 - Unable to start a KVM guest with default machine
    type(pseries-bionic) complaining "KVM implementation does not support
    Transactional Memory, try cap-htm=off" (kvm) (LP: #1752026)
    - powerpc: Use feature bit for RTC presence rather than timebase presence
    - powerpc: Book E: Remove unused CPU_FTR_L2CSR bit
    - powerpc: Free up CPU feature bits on 64-bit machines
    - powerpc: Add CPU feature bits for TM bug workarounds on POWER9 v2.2
    - powerpc/powernv: Provide a way to force a core into SMT4 mode
    - KVM: PPC: Book3S HV: Work around transactional memory bugs in POWER9
    - KVM: PPC: Book3S HV: Work around XER[SO] bug in fake suspend mode
    - KVM: PPC: Book3S HV: Work around TEXASR bug in fake suspend state
  * Important Kernel fixes to be backported for Power9 (kvm) (LP: #1758910)
    - powerpc/mm: Fixup tlbie vs store ordering issue on POWER9
  * Ubuntu 18.04 - IO Hang on some namespaces when running HTX with 16
    namespaces (Bolt / NVMe) (LP: #1757497)
    - powerpc/64s: Fix lost pending interrupt due to race causing lost update to
      irq_happened
  * fwts-efi-runtime-dkms 18.03.00-0ubuntu1: fwts-efi-runtime-dkms kernel module
    failed to build (LP: #1760876)
    - [Packaging] include the retpoline extractor in the headers

  [ Ubuntu: 4.15.0-14.15 ]

  * linux: 4.15.0-14.15 -proposed tracker (LP: #1760678)
  * [Bionic] mlx4 ETH - mlnx_qos failed when set some TC to vendor
    (LP: #1758662)
    - net/mlx4_en: Change default QoS settings
  * AT_BASE_PLATFORM in AUXV is absent on kernels available on Ubuntu 17.10
    (LP: #1759312)
    - powerpc/64s: Fix NULL AT_BASE_PLATFORM when using DT CPU features
  * Bionic update to 4.15.15 stable release (LP: #1760585)
    - net: dsa: Fix dsa_is_user_port() test inversion
    - openvswitch: meter: fix the incorrect calculation of max delta_t
    - qed: Fix MPA unalign flow in case header is split across two packets.
    - tcp: purge write queue upon aborting the connection
    - qed: Fix non TCP packets should be dropped on iWARP ll2 connection
    - sysfs: symlink: export sysfs_create_link_nowarn()
    - net: phy: relax error checking when creating sysfs link netdev->phydev
    - devlink: Remove redundant free on error path
    - macvlan: filter out unsupported feature flags
    - net: ipv6: keep sk status consistent after datagram connect failure
    - ipv6: old_dport should be a __be16 in __ip6_datagram_connect()
    - ipv6: sr: fix NULL point...

Changed in linux-gcp (Ubuntu Bionic):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers