SATA drive not detected from live image when USB drive plugged in

Bug #556685 reported by Tobin Davis on 2010-04-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-fsl-imx51 (Ubuntu)
High
Unassigned

Bug Description

On imx51 live image dated 20100406, after inserting an 8G USB stick, 16G SSD attached to built-in SATA port was no longer visible to apps, and no longer seen by kernel (/proc/partitions or /proc/scsi/scsi).

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-imx51 2.6.31.607.8
ProcVersionSignature: Ubuntu 2.6.31-607.12-imx51
Uname: Linux 2.6.31-607-imx51 armv7l
Architecture: armel
Date: Tue Apr 6 17:17:53 2010
LiveMediaBuild: Ubuntu-Netbook 10.04 "Lucid Lynx" - Beta armel+imx51 (20100406)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-meta-fsl-imx51

Tobin Davis (gruemaster) wrote :
tags: added: iso-testing
Paul Larson (pwlars) wrote :

Does this just happen on the live image? Which usb port were you plugging it into, and was it going through a hub? I'm having trouble reproducing this at the moment. Also, please attach output of sudo lsusb -v

Changed in linux-fsl-imx51 (Ubuntu):
status: New → Incomplete
Tobin Davis (gruemaster) wrote :

This appears to be an odd occurrence. Here's the scenario:

Babbage 3 development platform
16G SSD on built-in SATA port
powered USB hub on lower usb socket w/ keyboard & mouse.
8G USB pen drive formatted to FAT32 w/ test media (ogg, mp3, mp4, other videos, jpg, png, bmp, gif, odf documents, MS Office documents, etc) inserted in upper usb socket.
2G SD card w/ live image.

After running through all of the live apps and testing what could be tested with the media on the 8G usb stick, selected install icon. 16G SSD was not visible and red LED near SATA port was lit up solid, green LED in same area was dark. Required a powercycle to bring back SATA (hard reset wouldn't recover).

I'll continue to try to reproduce this issue.

Steve Langasek (vorlon) on 2010-04-12
Changed in linux-fsl-imx51 (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

[Expired for linux-fsl-imx51 (Ubuntu) because there has been no activity for 60 days.]

Changed in linux-fsl-imx51 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers