suspend/resume failure on imx51

Bug #456659 reported by Paul Larson on 2009-10-20
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux-fsl-imx51 (Ubuntu)
High
Bryan Wu
Karmic
High
Unassigned
Lucid
High
Bryan Wu

Bug Description

Seems to suspend ok, but fails to resume when pressing the power button again.

ProblemType: KernelOops
Annotation: This occured during a previous suspend and prevented it from resuming properly.
Architecture: armel
Date: Tue Oct 20 16:33:35 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/share/apport/apportcheckresume
Failure: suspend/resume
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate armel+imx51 (20091019.2)
InterpreterPath: /usr/bin/python2.6
Package: linux-image-2.6.31-105-imx51 2.6.31-105.14
ProcCmdline: /usr/bin/python /usr/share/apport/apportcheckresume
ProcEnviron: PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.31-105.14-imx51
SourcePackage: linux-fsl-imx51
Tags: resume suspend
Title: suspend/resume failure
Uname: Linux 2.6.31-105-imx51 armv7l
UserGroups:

Paul Larson (pwlars) wrote :
Paul Larson (pwlars) wrote :

I booted with no_console_suspend and was able to collect the following output:
---------------------------------------------
Freezing user space processes ... (elapsed 0.00 seconds) done.
Freezing remaining freezable tasks ... (elapsed 0.00 seconds) done.
USB Host suspended
USB Host suspended
mmc0: card 8fe4 removed

<6>PWR key pressed
---------------------------------------------

It seems that pressing the power button was detected, but nothing was done with it.

Changed in linux-fsl-imx51 (Ubuntu):
assignee: nobody → Amit Kucheria (amitk)
Tobin Davis (gruemaster) wrote :

I am able to reproduce this as well.

Changed in linux-fsl-imx51 (Ubuntu):
status: New → Confirmed
Paul Larson (pwlars) on 2009-10-23
Changed in linux-fsl-imx51 (Ubuntu):
importance: Undecided → High
tags: added: iso-testing
Paul Larson (pwlars) on 2009-12-04
Changed in linux-fsl-imx51 (Ubuntu Karmic):
importance: Undecided → High
milestone: none → karmic-updates
status: New → Confirmed
Paul Larson (pwlars) wrote :

Something kinda new to report here, on Lucid, it seemed like it was able to get further. I tried suspending with the 20091215 image and some of the lights on the board went out (but not all as before), and got a blank screen. I was able to wake it with keyboard activity, and it brought me back to an unlock screen. I typed my password and was able to get back in. So working, kinda... however, I also noticed that the network does not automatically come back after suspend (will open a separate bug on that), and I had something in dmesg that was new, and at least seems to indicate that I didn't completely suspend:
...
USB Host suspended
USB Host suspended
mmc: card 8fe4 removed
Class driver suspend failed for cpu0
...

Paul Larson (pwlars) wrote :

Should also note that the test from commend #4 was done on babbage 3, not 2.5 as before, not sure if that could have made a difference for me.

Paul Larson (pwlars) wrote :

Tried this again with a current image and it seems to not be working again for me. Same as what I was seeing before. The system seems to suspend, but will not resume.

Bryan Wu (cooloney) wrote :

Paul,

Thanks a lot.

There are some suspend/resume fixing patches pending on my side. I am going to test them soon and will update the status soon.

-Bryan

Changed in linux-fsl-imx51 (Ubuntu Lucid):
assignee: Amit Kucheria (amitk) → Bryan Wu (cooloney)
Changed in linux-fsl-imx51 (Ubuntu Karmic):
assignee: nobody → Bryan Wu (cooloney)
Alexander Sack (asac) on 2010-01-15
Changed in linux-fsl-imx51 (Ubuntu Lucid):
status: Confirmed → In Progress
Bryan Wu (cooloney) wrote :

Paul,

Could you please grab my testing kernel to do the quick suspend/resume testing?
http://people.canonical.com/~roc/kernel/lucid_fsl-bsp-2010-01-07/

And my kernel tree is URL:
http://kernel.ubuntu.com/git?p=roc/ubuntu-lucid.git;a=shortlog;h=refs/heads/fsl-imx51

Thanks,
-Bryan

Paul Larson (pwlars) wrote :

Bug still present in the kernel listed in comment #8

Bryan Wu (cooloney) wrote :

I did some investigation today. Found Bluetooth suspend operation fails:

--
roc@babbage:~$ tail -f -n1 /var/log/pm-suspend.log
Tue Jan 19 18:15:30 CST 2010: performing suspend
Initial commandline parameters:
Tue Jan 19 18:21:44 CST 2010: Running hooks for suspend.
/usr/lib/pm-utils/sleep.d/000kernel-change suspend suspend:success.
/usr/lib/pm-utils/sleep.d/00logging suspend suspend:Linux babbage 2.6.31-602-imx51 #4 Tue Jan 19 17:10:01 CST 2010 armv7l GNU/Linux
Module Size Used by
nls_iso8859_1 3916 1
nls_cp437 5580 1
binfmt_misc 8884 1
ppdev 8192 0
lp 10180 0
parport 38128 2 ppdev,lp
ov3640_camera 20176 0
v4l2_int_device 3564 1 ov3640_camera
joydev 10648 0
uio_pdrv_genirq 3192 0
uio 11568 1 uio_pdrv_genirq
             total used free shared buffers cached
Mem: 478344 301428 176916 0 36256 133516
-/+ buffers/cache: 131656 346688
Swap: 1397612 0 1397612
success.
/usr/lib/pm-utils/sleep.d/00powersave suspend suspend:success.
/usr/lib/pm-utils/sleep.d/01PulseAudio suspend suspend:Welcome to PulseAudio! Use "help" for usage information.
>>> >>> Welcome to PulseAudio! Use "help" for usage information.
>>> >>> Welcome to PulseAudio! Use "help" for usage information.
>>> >>> Welcome to PulseAudio! Use "help" for usage information.
>>> >>> success.
/etc/pm/sleep.d/10_unattended-upgrades-hibernate suspend suspend:success.
/usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend:
--

Bryan Wu (cooloney) wrote :

My bad, in comment #10, I did this test when I login via SSH. I did the same thing on my board console terminal. The whole system can suspend. but can not resume.

Oliver Grawert (ogra) wrote :

right, i did notice the same when trying it in karmic, couldnt find a way to wake up the board again after suspend.
looking at pauls test above it seems to be an issue with the kernel not acting on the power button press.

Alexander Sack (asac) on 2010-01-22
Changed in linux-fsl-imx51 (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-1
Bryan Wu (cooloney) wrote :

I found actually suspend/resume works on my board:

--
roc@babbage:~$ uname -a
Linux babbage 2.6.31-602-imx51 #4-Ubuntu Mon Jan 11 17:05:57 UTC 2010 armv7l GNU/Linux
roc@babbage:~$ dmesg | head
Initializing cgroup subsys cpuset
Initializing cgroup subsys cpu
Linux version 2.6.31-602-imx51 (buildd@huito) (gcc version 4.4.3 20100108 (prerelease) (Ubuntu 4.4.2-9ubuntu3) ) #4-Ubuntu Mon Jan 11 17:05:57 UTC 2010 (Ubuntu 2.6.31-602.4-imx51)
CPU: ARMv7 Processor [412fc081] revision 1 (ARMv7), cr=10c53c7f
CPU: VIPT nonaliasing data cache, VIPT nonaliasing instruction cache
Machine: Freescale MX51 Babbage Board
Memory policy: ECC disabled, Data cache writeback
On node 0 totalpages: 122880
free_area_init_node: node 0, pgdat c060cc24, node_mem_map c0682000
  DMA zone: 128 pages used for memmap
roc@babbage:~$ sudo su
[sudo] password for roc:
root@babbage:/home/roc# echo 9 > /proc/sys/kernel/printk
root@babbage:/home/roc# echo mem > /sys/power/state
PM: Syncing filesystems ... done.
Freezing user space processes ... (elapsed 0.00 seconds) done.
Freezing remaining freezable tasks ... (elapsed 0.00 seconds) done.
USB Host suspended
USB Host suspended
mmc0: card 8fe4 removed
<6>PWR key pressed
mxc_ipu mxc_ipu: Channel already disabled 9
mxc_ipu mxc_ipu: Channel already uninitialized 9
USB Host resumed
USB Host resumed
mmc0: new SD card at address 8fe4
mmc mmc0:8fe4: parent mmc0 should not be sleeping
mmcblk0: mmc0:8fe4 SD02G 1.84 GiB
 mmcblk0: p1 p2
usb 1-1: reset high speed USB device using fsl-ehci and address 2
usb 1-1.2: reset full speed USB device using fsl-ehci and address 3
usb 1-1.6: reset high speed USB device using fsl-ehci and address 4
usb 1-1.2.4: reset low speed USB device using fsl-ehci and address 5
Restarting tasks ... done.
--

Could you guys test on your side?
Thanks,

Oliver Grawert (ogra) wrote :

i just did a fresh install from alpha2 and a dist-upgrade to latest packages:

suspend/resume works fine here, only suspend is showing up in the panel menu (no hibernate anymore).
the system wakes up properly after pressing the power button. i havent tested with uboot yet after my reinstall, it might be the fault of uboot that the power button doesnt send any event to wake up the board, i will do some tests later today using uboot.

there are some graphical fragments on the black screen before the screensaver password dialog comes up, but this doesnt seem critical to me.

anyway, that bug seems to have fixed itself :)

Oliver Grawert (ogra) wrote :

tested under uboot and works as well, closing...

Changed in linux-fsl-imx51 (Ubuntu Lucid):
status: In Progress → Fix Released
Tobin Davis (gruemaster) wrote :

Marked Karmic bug to "Won't Fix" as karmic is now unsupported. Since the kernel is essentially the same as Lucid, it may already be fixed, but I have no way of testing this.

Changed in linux-fsl-imx51 (Ubuntu Karmic):
status: Confirmed → Won't Fix
assignee: Bryan Wu (cooloney) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers