does not power down the system properly

Bug #439282 reported by Oliver Grawert on 2009-09-30
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-fsl-imx51 (Ubuntu)
Medium
Amit Kucheria
Karmic
Medium
Amit Kucheria

Bug Description

sorry for filing this so late, but i rarely actually power down so i didnt really notice it before ...
shutting down the babbage board with the menu item or via sudo halt/shutdown -h now powers off all peripherials and turns off thh green LED on the board, but leaves the NIC and screen powered on. it is just writing "power down" on the screen leaving me with a blinking cursor but doesnt actually power off the board or screen.

CVE References

Oliver Grawert (ogra) wrote :

oh, i forgot to mention, reboot works flawless

Changed in linux-fsl-imx51 (Ubuntu Karmic):
milestone: none → ubuntu-9.10
tags: added: armel
Changed in linux-fsl-imx51 (Ubuntu Karmic):
importance: Undecided → Medium
assignee: nobody → Amit Kucheria (amitk)
Paul Larson (pwlars) on 2009-10-03
Changed in linux-fsl-imx51 (Ubuntu Karmic):
status: New → Confirmed
Paul Larson (pwlars) wrote :

This appears to get fixed using the test kernel from comment #5 in bug 446140

Loïc Minier (lool) wrote :
Download full text (18.6 KiB)

This bug was fixed in the package linux-fsl-imx51 - 2.6.31-105.14

---------------
linux-fsl-imx51 (2.6.31-105.14) karmic; urgency=low

  [ Andy Whitcroft ]

  * rebase to Ubuntu-2.6.31-14.46
  * [Config] update configs since rebase to Ubuntu-2.6.31-14.46
  * lirc update dropped module lirc_mceusb2

  [ Upstream Kernel Changes ]

  * mxc spi: fix spi driver for 2.6.31
    - LP: #427289, #446140

  [ Ubuntu: 2.6.31-14.46 ]

  * reinstate armel.mk with no flavours
    - LP: #449637
  * [Upstream] elevator: fix fastfail checks to allow merge of readahead
    requests
    - LP: #444915 ...

Changed in linux-fsl-imx51 (Ubuntu Karmic):
status: Confirmed → Fix Released
tags: added: iso-testing

I have the same problem, but it seems to be a "gdm" problem, not related with acpi nor with "apm"... le te mexplain why:

If i tell it to hybernate it power off at end of it and when powered on again it resumes well.
If i tell it to shutdown it does not power off at end, but hey only if gdm was running when asked.

More detailed:
If gdm is running and i open a terminal window: no way to power off after shutdown, none commands: shutdown, halt --poweroff,... none works
If gdm is running and i press Ctrl+Alt+F2 to go to a console at full screen (text mode), but i let gdm running: no way to power off after shutdown, none commands: shutdown, halt --poweroff,... none works

But, if i press Ctrl+Alt+F2 to go to a console at full screen (text mode), and do:
#sudo /etc/init.d/gdm stop
So gdm is stopped then after few secconds i can confirm it is stopped with [ps -A | grep gdm], so i ask to shutdown with:
#sudo halt --poweroff
Or with shutdown,... all of them at end turns off the power and power off the notebook correctly.

I have seen on Internet a lot of forums on where they tell something about acpi=force, apm=power-off,... on /boot/grub/menu.lst also about adding apm to modules,... etc. none of that works for me.

And i found that if gdm is not running when calling shutdown it power off correctly.

When i was using Ubuntu Intrepid Ibex and Ubuntu Jaunty Jackalope it allways power off correctly, but when i updated to Ubuntu Karmic Koala it starts to not do the final power off when shutdown... now i know the cause is gdm running when calling shutdown.

Maybe it is related in some way with Kernel or with propietary ATI graphics driver...

Also i can see some near identical lines (more than ten) on /var/messages at the end of it with this error:
Kernel: Assertion fail in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.0 at line: 53

I do not know if such error is related with the shutdown problem, but is the last error logged and it is at end ot /var/messages no more lines after it... but i can only see it when not powered off correctly, if i do the trick of stoping gdm it does not appear.

Hope this can help someone to fix-it. Till them i will do the trick of Ctrl+Alt+F2 -> login -> password -> sudo /etc/init.d/gdm stop -> sudo halt --poweroff

Note:
After doing such, i powered on again and then after some hours of work i press shutdown by mistake (did not remember ro do the trick "stop gdm then halt --poweroff") but what surprise! it turns off the notebook correctly... so when i have time i will re-check if it was only once or can be reproduced.

I mean:
-Power On, then tell destop menu to shutdown normally and check if it turns off.
-If not force turn off, then turn on again, do the trick of stopping gdm and halt --poweroff, then power on again then tell destop menu to shutdown normally and check if it turns off.

But i will not have time till weekend, so if any one can also check that, it would be great.

SOLUTION THAT WORKS FOR ME:
Ctrl+Alt+F2 -> Login -> Password -> sudo /etc/init.d/gdm stop -> sudo halt --poweroff

Oliver Grawert (ogra) wrote :

please note that this is a bug about an armel kernel, if you dont see this issue on a babbage imx51 device please open a new bug, you seem to be on an x86 architecture

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers