kexec broken on imx51

Bug #319240 reported by Michael Casadevall on 2009-01-20
This bug report is a duplicate of:  Bug #517841: KEXEC support broken. Edit Remove
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-fsl-imx51 (Ubuntu)
Wishlist
Bryan Wu

Bug Description

kexec is broken on the imx51. This is confirmed on the Babbage 1 board with v2.6.28 kernel, but still needs confirmation on the Babbage 2 and 2.5 kernels.

Original Bug Report:
The kexec call is broken because it fails to properly call the relocation stub in the kernel, leading to a hung board. This can be resolved with the following patch which corrects the calling problem, and puts machine_kexec in line with other architectures. It's been tested on the QEMU versatile kernel.

Hi Michael,

It seems Tim applied the patch this morning:

https://lists.ubuntu.com/archives/kernel-team/2009-January/004171.html

Changed in linux:
status: New → Fix Committed

Resetting back to Triaged, patch works on QEMU due to fluke. Still needs work.

Changed in linux:
importance: Undecided → Medium
status: Fix Committed → Triaged
Paul Larson (pwlars) on 2009-06-17
tags: added: armel
description: updated
summary: - kexec broken on ARM
+ kexec broken on imx51
Loïc Minier (lool) wrote :

Please confirm on karmic + Babbage 2.5 + 2.6.31

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Loïc Minier (lool) wrote :

Please retest with 2.6.31...

affects: linux (Ubuntu) → linux-fsl-imx51 (Ubuntu)
Changed in linux-fsl-imx51 (Ubuntu):
assignee: nobody → Michael Casadevall (mcasadevall)
Jerone Young (jerone) wrote :

Is their a test case or set of instructions how someone can test out this patch (in a consistent manner) ?

To reproduce this bug, you need to have your kernel compiled with CONFIG_KEXEC and CONFIG_ATAGS. Depending on the version of kexec-tools being used, you may need to patch arch_map_entry in kexec/arch/arm/kexec-arm.c to add the armv7l uname of the kernel. kexec will throw "Unsupported machine type" if you don't.

Then simply load a vmlinux file with: kexec -l /boot/vmlinux --append=root=/dev/hda1
--initrd=/boot/initrd followed by a kexec -e

Amit Kucheria (amitk) wrote :

Are we still trying to ship a kexec-based bootloader in Karmic? If not, lowering the importance of this bug.

Changed in linux-fsl-imx51 (Ubuntu):
importance: Medium → Wishlist
Anmar Oueja (anmar) wrote :

I think it is important that we ship it since it will streamline our kernel updating process.

Anmar Oueja (anmar) wrote :

Acelan: i believe we have some patches that fix this. Can you please confirm.

Alexander Sack (asac) wrote :

any update on this? Acelan? Anmar?

Bryan Wu (cooloney) wrote :

Since kexec is a good and necessary feature, I will keep up to debug this.

-Bryan

Changed in linux-fsl-imx51 (Ubuntu):
assignee: Michael Casadevall (mcasadevall) → Bryan Wu (cooloney)
Bryan Wu (cooloney) wrote :

kexec is not fully supported for ARMv7, so this issue is the same as marvell dove one. And I think we can share the same fix for mvl-dove, armel-versatile and fsl-imx51.

-Bryan

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-fsl-imx51 - 2.6.31-605.9

---------------
linux-fsl-imx51 (2.6.31-605.9) lucid; urgency=low

  [ Andy Whitcroft ]

  * Revert "include modules.builtin in the binary debs"
  * include modules.builtin in the binary debs

  [ Bryan Wu ]

  * SAUCE: IMX51: skip ATA PASS THROUGH command for USB storage disk from
    JMicron
    - LP: #499881

  [ Upstream Kernel Changes ]

  * ARM: 5677/1: ARM support for
    TIF_RESTORE_SIGMASK/pselect6/ppoll/epoll_pwait
    - LP: #319729
  * leds/mc13892: Use workqueue for setting LED brightness
    - LP: #531696
  * ARM: 5882/1: ARM: Fix uncompress code compile for different defines of
    flush(void)
    - LP: #319240
  * ARM: 5884/1: arm: Fix DCC console for v7
    - LP: #319240
  * ARM: 5885/1: arm: Flush TLB entries in setup_mm_for_reboot()
    - LP: #319240
  * ARM: 5886/1: arm: Fix cpu_proc_fin() for proc-v7.S and make kexec work
    - LP: #319240
  * ARM: 5888/1: arm: Update comments in cacheflush.h and remove
    unnecessary V6 and V7 comments
    - LP: #319240
  * arm: disable L2 cache in the v7 finish function
  * arm: invalidate TLBs when enabling mmu
 -- Andy Whitcroft <email address hidden> Tue, 09 Mar 2010 13:52:16 +0000

Changed in linux-fsl-imx51 (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers