Ubuntu

148f:3072 Ralink RT3072 WLAN not working with rt2800usb - firmware missing

Reported by Joshua Kite on 2011-04-25
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Undecided
Unassigned
Natty
Medium
Unassigned

Bug Description

Binary package hint: linux-image-2.6.38-8-generic

HI

I use a USB wifi adapter that uses the rt3070sta driver (lsusb gives 'ID 148f:3072 Ralink Technology, Corp. RT3072 Wireless Adapter'). This driver was included in default Ubuntu 10.10 kernels and worked fine. Sadly I currently have to use 11.04 Beta 2 with Kernel 2.6.35-28-generic (from Maverick) because it has not been included in the current Ubuntu default kernel, backports or firmware packages and I have not been able to build it from source myself or find a suitable PPA. Please could this module be included in the release kernel.

Obvious symptoms:
Boot to Kernel 2.6.35-28-generic, USB Wifi adapter works fine.
Boot to kernel 2.6.38-8-generic, USB Wifi adapter doesn't work and network status says 'firmware missing'

Cheers

Mark Furneaux (markfurneaux) wrote :

This affects me as well. I use the ASUS N-13 WiFi adapter, which requires this driver. I'm using the old kernel for now.

Mark Furneaux (markfurneaux) wrote :

Sorry for the double post, but it seems that the rt3070sta module is depreciated. It seems that the rt2870sta module can take over for it. udev at this time does not know to use the different module.

I used the solution here:

http://ubuntuforums.org/showpost.php?p=9445731&postcount=58

Joshua Kite (joshuamkite-gmail) wrote :

Thanks for the suggested workaround described above Mark. I may try this myself when I have more time. I cannot help feeling that you and I shouldn't have to be doing this though: Your device USB ID is different from mine and presumably there will be further users with different hardware who are also affected by this bug back lack the ability to track it back to here. I do not feel that it is right that we should be having to hack around with local config files, which will then of course sit outside any Ubuntu led update process in future, when there are working drivers available which should be enabled. One of the core strengths of Ubuntu is meant to be ease of use and working out of the box. This driver deprecation clearly fails here. If we consider the case of trying to use a live cd to fix an issue on the only computer available at a site then you or I would be stuck because we would be unable to get network connectivity to find out how to apply the fix needed to get network connectivity in the first place.
To me a fix would involve either
1) Re-enabling the deprecated driver until the hardware handling system catches up and can use the new driver
2) Updating the udev rules or whatever CENTRALLY to apply the appropriate driver module
3) Somehow aliasing the new driver to the old one so that it is loaded either way
I do not even know if the rt3070sta module will work with my hardware as I write this.

Actually, the RT3072 chipset should now be supported by the rt2800usb module:
from the source[1]:
 126 config RT2800USB
 127 tristate "Ralink rt27xx/rt28xx/rt30xx (USB) support"
 [..]
 135 ---help---
 136 This adds support for rt27xx/rt28xx/rt30xx wireless chipset family.
 137 Supported chips: RT2770, RT2870 & RT3070, RT3071 & RT3072
 138
 139 When compiled as a module, this driver will be called "rt2800usb.ko".

So the real bug here is that rt2800usb does not work for those wifi adapters. And to fix this we need to find out why.
Could you please test:
Is rt2800usb loaded? See with:
lsmod | grep rt2800
What does dmesg say?
post:
dmesg > dmesg.txt
Does it work with a newer kernel (which brings a newer rt2800usb module)?
Check with the final 2.6.39 mainline kernel:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.39-oneiric/

[1]http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.38.y.git;a=blob;f=drivers/net/wireless/rt2x00/Kconfig;h=6f383cd684b009a1cee9663768759c32772a7cf1;hb=HEAD

summary: - rt3070sta module missing in kernel 2.6.38-8-generic version 2.6.38-8.42
+ 148f:3072 Ralink RT3072 WLAN not working with rt2800usb
Changed in linux (Ubuntu):
status: New → Incomplete
affects: linux (Ubuntu) → linux-firmware (Ubuntu)
summary: - 148f:3072 Ralink RT3072 WLAN not working with rt2800usb
+ 148f:3072 Ralink RT3072 WLAN not working with rt2800usb - firmware
+ missing

Seems similar to bug 762987.

Try extracting a newer firmware rt2870.bin from here:
https://launchpad.net/ubuntu/oneiric/+source/linux-firmware/1.53/+files/linux-firmware_1.53.tar.gz
and copy it in /lib/firmware (rename the old one to e.g. rt2870.bin.disable)

Joshua Kite (joshuamkite-gmail) wrote :

Dear Wolfgang

Many Thanks- we have progress! In your post #5 here, replacing the file in /lib/firmware has been successful.- thank you!
On my machine:
In kernel 2.6.35-28 the module 'rt2800' is NOT loaded
in kernel 2.6.38-8 the module 'rt2800' IS loaded but the device does not work
in Kernel 2.6.39-020639 the module is loaded but I cannot boot to a graphical environment (I could not install the kernel headers deb in the directory linked in post #4) The LED on the device does not light though so I suspect failure.
in kernel 2.6.38-8 with manually replaced firmware as per post #5 the module 'rt2800' IS loaded and the device DOES work!

I attach the output of the following commands in one file
joshua@Abednego:~$ uname -a > dmesg-2.6.38-8_firmware.txt
joshua@Abednego:~$ lsmod | grep rt2800 >> dmesg-2.6.38-8_firmware.txt
joshua@Abednego:~$ dmesg >> dmesg-2.6.38-8_firmware.txt
I did the same for the other kernels and with the previous firmware as listed above and can provide these files also on request

Many thanks

Joshua Kite

Terry Scott (terrykscott57) wrote :

Hi,

Thanks for this. I've spent the best part of this last week trying to find a solution.
I have a rt 3072 usb, which came with, what is now about nine months old, an ADDON 3650 ADSL modem.
Been a bit slow getting it working through wireless, security and all that.
Got it working ok in XP dead easy, once i'd worked out what to do on the modem to make it secure.
Found this bug log and within 15 mins and post #5, all jumped into life.
I didn't even have to re-boot or log put / back in again.
This has been a VERY frustrating process.

Seth Forshee (sforshee) wrote :

@Joshua: Just to be totally clear, you're saying replacing rt2870.bin with the version from linux-firmware 1.53 fixes your issue, correct?

Seth Forshee (sforshee) wrote :

Also note that I packaged up this firmware for verification of the fix for bug #762987. Testing this package to see if it fixes your issues would also be appreciated.

http://people.canonical.com/~sforshee/lp762987/linux-firmware_1.52~lp762987v201106061858_all.deb

@Seth: Yes it does with the current release kernel 2.6.38-8

Yes, your deb package also works although apt-get sees it as a downgrade from the standard distro package and wants to upgrade it back. Thanks

Seth Forshee (sforshee) wrote :

Setting the development task to Fix Committed and adding a natty task.

Changed in linux-firmware (Ubuntu):
status: Incomplete → Fix Committed
Changed in linux-firmware (Ubuntu Natty):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
status: New → In Progress
Changed in linux-firmware (Ubuntu):
status: Fix Committed → Fix Released
Seth Forshee (sforshee) wrote :

Natty SRU Justification:

Impact: The rt2800 drivers expect firmware for RT307x chipsets to be found in rt2870.bin. This is not the case in natty's linux-firmware package, and thus the driver fails to load firmware for RT307x chipsets.

Fix: Update rt2800 firmware. This is a clean upstream cherry pick.

Testcase: Tested on LP #762987 and #770232.

Tim Gardner (timg-tpi) on 2011-06-07
Changed in linux-firmware (Ubuntu Natty):
status: In Progress → Fix Committed

@Seth & @Tim Thanks for your fixes and commits. Will this be extended to Natty or is only the oneiric version of this package to receive this fix?

Hi Joshua,
thanks to your testing (your comment #6 and confirmation in your comment #10) we know that this bug is fixed by the version of firmware file rt2870.bin which is included in package linux-firmware 1.53. That version 1.53 of linux-firmware had already been published for oneiric on 2011-05-26[1]. So for oneiric nothing more needed to be done.

As can be seen from the line beginning with "Natty" just below "linux-firmware" at the top of this bug and comment #13 Seth is now working on getting this fix into Natty.

From the top of twin bug 762987 (same fix, slightly different hardware) and comment 21 it can be seen that Seth has also started the task of bringing the fix to maverick, lucid and even hardy.

[1] https://launchpad.net/ubuntu/+source/linux-firmware/+publishinghistory

@Wolfgang Thanks, I guess I am unfamilair with the process- I thought that we would go from fix committed to actually implemented more quickly. I appreciate everyone's hard work here although both this bug and 762987 were not manifest in previous versions of Ubuntu

Accepted linux-firmware into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Yes, this works!

Sorry folks, after some more in-depth testing, whilst this driver 'works' there appear to be some significant issues with it:

I have been experiencing very long load times on web pages and poor download speeds which I attributed to my ISP's newly introduced traffic shaping. This past weekend I tried booting into my Windows 7/64 partition with the exact same hardware and these issues disappeared.

Over the last few days my computer would consistently not shutdown or restart, hanging at a purple screen on log out. This happened very rarely, if ever, in the past and other reports of similar issues usually blame a driver. I tried a couple of boot cycles with this device removed from the system and this issue was gone. I would not normally reboot unless I had to, so it is more chance that I had a requirement to do so over the last few days.

Sorry for not identifying these issues previously

Seth Forshee (sforshee) wrote :

@Joshua, thanks for letting us know about the problems. Since you're seeing a regression (shutdown/reboot fail whereas they previously worked) we won't be releasing the firmware updates at this time. If we're able to work through your issues then we may be able to release the updates later on.

Changed in linux-firmware (Ubuntu Natty):
status: Fix Committed → In Progress
getaceres (getaceres) wrote :

Hello, I've tested with the proposed update and although it works:

- With rt2870sta driver I can connet and the dongle works as expected but only on Wifi G. I can't get a N connection.
- With rt2800usb the dongle works at extremely low speeds. It takes a lot to load pages and speed tests give me about 1Mbit connection consistently.

I don't know if it's a bug in the drivers or firmware, but the dongle it's not working at its full potential.
By the way, with the included drivers it works at full speed in Windows 7.

Joke de Buhr (joke) wrote :

I’ve been using the oneiric version on of the package on my natty installation but I think the firmware version is the same. I can confirm the situation.

 • rt2870sta can’t connect at draft-N speed.
 • rt2000usb can connect at draft-N speed.
 • With rt2000usb the connection is extremely slow. It’s hanging often and pings can’t get through.
 • After disabling power saving with rt2000usb (iwconfig wlan0 power off) the connection improves a little bit but it’s still extremely slow and unreliable.

Hugo Shepherd (terabyte1) wrote :

Unfortunately, this bug affects me, and I've had to go back to Ubuntu 10.10 Maverick Meerkat where the wireless network does work for me. The adapter I am using for wireless is a D-Link H/W Version B2 F/W Version T1.02 with a MAC of F07D68F89641 which delivers an 'N' version of wireless Networking via my Huwai router as provided by my TalkTalk ISP. Ordinarily I get around 54mbps on my router/Adapter otherwise - which is good. Hugo Shepherd

Seth Forshee (sforshee) on 2011-09-16
Changed in linux-firmware (Ubuntu Natty):
assignee: Seth Forshee (sforshee) → nobody
status: In Progress → Confirmed
Martin Pitt (pitti) wrote :

Hello Joshua, or anyone else affected,

Accepted linux-firmware into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux-firmware (Ubuntu Natty):
status: Confirmed → Fix Committed
Joke de Buhr (joke) wrote :

I just tested the new firmware with my DWA-140 rev. B2 (07d1:3c0a). The afore mentioned regressions about download speed and connection reliability seems to be fixed now. Everything is working now. At least the last hour.

But the currently reported connection speed (150Mbit/s) is less than the connection speed is reported when using the official ralinktech driver (280Mbit/s). But I didn’t actually test chose speed rates with neither one of them.

Martin Pitt (pitti) on 2011-09-22
tags: added: verification-done
Joke de Buhr (joke) wrote :

I sorry but I think I’ve to correct my earlier statement. Seems it was a bit to enthusiastic.

After a longer period (about an hour) of a good reliable connection the speed begins to diminish before the connection stops working completely.

The only thing that seems to work is unplugging the device. After that connection works again reliable for a longer period of time until it begins to diminish again and finally stops.

Martin Pitt (pitti) wrote :

Setting back to v-needed for now. The original problem was that the firmware was missing, now it seems to be buggy.

tags: added: verification-needed
removed: verification-done
b3nn0 (agib) wrote :

This problem (buggy firmware) still exists in Oneiric today.
Is there any way that this is fixed sooner or later?

I'm also still seeing this issue with my Asus N13-USB, which is an RT2870 chipset. Using rt2800usb results in a very slow and unreliable connection; I can't even transfer a file from my server to my local machine.

Narcis Garcia (narcisgarcia) wrote :

# Provisional and instant workaround for Ubuntu 11.04 (Natty):

sudo modprobe -rf rt2870sta rt2800usb rt2800lib rt2x00usb rt2x00lib
sudo modprobe rt2870sta

# To make it permanent, add the following lines to /etc/modprobe.d/blacklist.conf
blacklist rt2800usb
blacklist rt2800lib
blacklist rt2x00usb
blacklist rt2x00lib

Joke de Buhr (joke) wrote :

There is no module rt2870sta.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.52.4

---------------
linux-firmware (1.52.4) natty-proposed; urgency=low

  * no change upload with version difference.

linux-firmware (1.52.3) natty-proposed; urgency=low

  * Revert: linux-firmware: rt2800pci: rt2800usb: Firmware update
    Causes a shutdown regression.
    -LP: #762987
    -LP: #770232

linux-firmware (1.52.2) natty-proposed; urgency=low

  * Add firmware to support compat-wireless backports
    linux-firmware: add new firmware for RTL8168E-VL
    linux-firmware: update firmware for RTL8111E
    linux-firmware: Add firmware for RTL8168/8111E
    linux-firmware: Add firmware for RTL8105E
    -LP: #804671

linux-firmware (1.52.1) natty-proposed; urgency=low

  * Update rt2800 firmware
    -LP: #762987
    -LP: #770232
 -- Tim Gardner <email address hidden> Mon, 12 Sep 2011 19:28:14 -0600

Changed in linux-firmware (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers