iwlwifi: Add firmware for 6000/6050 adapters

Bug #690222 reported by Tim Gardner on 2010-12-14
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Tim Gardner
Maverick
Undecided
Tim Gardner
Natty
Undecided
Unassigned

Bug Description

Binary package hint: linux-firmware

Firmware for a new series of Intel wifi adapters has been released. These adapters are supported as of Linux 2.6.35, so the addition of these firmware files is appropriate for all compat-wireless packages and LTS backported kernels.

Tim Gardner (timg-tpi) on 2010-12-14
Changed in linux-firmware (Ubuntu Natty):
status: New → Fix Released
Tim Gardner (timg-tpi) wrote :

SRU Justification:

Impact: Some Intel wifi adapters will not work without the right firmware

Patch Description: Add new firmware files to support these wifi adapters

There is little chance for regression since these are new firmware files.

Tim Gardner (timg-tpi) on 2010-12-14
Changed in linux-firmware (Ubuntu Maverick):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → Fix Committed
Changed in linux-firmware (Ubuntu Lucid):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → Fix Committed

Accepted linux-firmware into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Chris Van Hoof (vanhoof) on 2010-12-15
tags: added: hwe-blocker
Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Chris Van Hoof (vanhoof) wrote :

Confirmed iwlwifi-6050-5.ucode in linux-firmware version 1.38.3 allows an Intel 6050 series device to function properly via compat-wireless 2.6.37

Jean-Baptiste Lallement (jibel) wrote :

verification-done for maverick
verification-needed for lucid

tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.38.3

---------------
linux-firmware (1.38.3) maverick-proposed; urgency=low

  * iwlwifi: add new firmware for 6030 devices
    17.168.5.1 iwlwifi-6000g2b-5.ucode
    - LP: #697768

linux-firmware (1.38.2) maverick-proposed; urgency=low

  * iwlwifi: 17.168.5.1 iwlwifi-6000g2a-5.ucode
    - LP: #690222

  * iwlwifi: 41.28.5.1 iwlwifi-6050-5.ucode
    - LP: #690222

linux-firmware (1.38.1) maverick-proposed; urgency=low

  [ Upstream ]

  * wimax: update WiMAX firmwares for 2.6.35
    - LP: #689753
 -- Tim Gardner <email address hidden> Wed, 05 Jan 2011 10:53:47 -0700

Changed in linux-firmware (Ubuntu Maverick):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.34.3

---------------
linux-firmware (1.34.3) lucid-proposed; urgency=low

  * iwlwifi: add new firmware for 6030 devices
    17.168.5.1 iwlwifi-6000g2b-5.ucode
    - LP: #697768

linux-firmware (1.34.2) lucid-proposed; urgency=low

  * iwlwifi: 17.168.5.1 iwlwifi-6000g2a-5.ucode
    - LP: #690222

  * iwlwifi: 41.28.5.1 iwlwifi-6050-5.ucode
    - LP: #690222
 -- Tim Gardner <email address hidden> Wed, 05 Jan 2011 10:59:20 -0700

Changed in linux-firmware (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers