D-Link DWA-140 B2 can't find any AP

Bug #580926 reported by RussianNeuroMancer on 2010-05-15
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
linux-firmware (Ubuntu)
Wishlist
Chase Douglas
Lucid
Undecided
Unassigned

Bug Description

SRU Justification for linux-firmware:

Impact: Without the firmware files, the driver for these cards won't work.

How Addressed: A set of firmware updates from Ralink have been pulled from upstream.

Regression Potential: The firmware added is all new. There should be no regression potential.

=====

linux-firmware package not include firmware rt3070.bin and rt3071.bin for Ralink RT3070/RT3071-based USB WiFi adpaters, like LinkSys WUSB600N v2, D-Link DWA-140 B2 and ASUS USB-N13.

With 2.6.32 kernel and driver by Ralink (installed using DKMSDKMS from this repo: https://launchpad.net/~logari81/+archive/ppa) D-Link DWA-140 B2 working without any problem.
But with 2.6.34 kernel and included driver adapter can't find any AP (I uninstall rt3070 package with Ralink driver before try). dmesg output attached.

Chase Douglas (chasedouglas) wrote :

RussionNeuroMancer:

Please download and install the test package at http://people.canonical.com/~cndougla/bugs/580926/linux-firmware_1.35_all.deb. This package should have the firmware you are missing. Ensure that the firmware from this package enables you to use the affected devices.

If you have already installed the firmware manually, please remove it before you test this package.

Thanks

Changed in linux-firmware (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
status: New → In Progress
importance: Undecided → Wishlist

I tried this package, but device not work, see attached file.

I am using a EDIMAX EW-7711UTn under Lucid, which shows up as:

Bus 001 Device 017: ID 7392:7711

Before installing the above package I was getting in dmesg:

[146557.311102] usb 1-2: firmware: requesting rt3070.bin

After installing the above package, everything started working.

Thanks Chase.

Chase Douglas (chasedouglas) wrote :

RussianNeuroMancer:

The dmesg doesn't give me all the information I need to be sure, but it seems that the driver is loaded and trying to function. Generally, if the firmware doesn't load the driver just gives up. This means that the firmware is ok, but the driver itself has issues. The driver also comes from the staging tree of the kernel, so this is not too surprising :(.

If you look through /var/log/messages and you see warnings about the firmware not loading after you've installed this package (look at the timestamps to be sure), then please let me know. Otherwise, I'm going to assume the firmware is correct.

Thanks

summary: - linux-firmware not include rt3070.bin and rt3071.bin
+ D-Link DWA-140 B2 can
summary: - D-Link DWA-140 B2 can
+ D-Link DWA-140 B2 can't find any AP
description: updated
description: updated
description: updated
description: updated
Changed in linux-firmware (Ubuntu):
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Jeremy Foshee (jeremyfoshee) wrote :

Hi RussianNeuroMancer,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

Please, read description carefully:
> But with 2.6.34 kernel and included driver adapter can't find any AP
This bug about problem in latest upstream kernel.

Grant Bowman (grantbow) wrote :

Installing http://people.canonical.com/~cndougla/bugs/580926/linux-firmware_1.35_all.deb failed to fix the problem of my not being able to see or to connect with any AP using a Rosewill RNX EasyN1 wifi adapter "Bus 001 Device 002: ID 148f:3070 Ralink Technology, Corp." RT 3070 chipset using a 2.6.32-22-generic kernel on a Lucid system - but I guess the original bug is about a 2.6.34 kernel?

If I understand right, 2.6.32-22 not unclude driver for RT3070. Try 2.6.34 kernel: https://wiki.ubuntu.com/KernelTeam/MainlineBuilds

Chase Douglas (chasedouglas) wrote :

I looked into this further, and it seems that the driver is not being built correctly because its build process is not written well for the upstream kernel. This is one of the reasons it exists in the staging drivers tree, where drivers are really just provided on a best effort standpoint. It is possible to build the module separately, and maybe someone has done that (Alex Ainscow?). I have added the firmware to the linux-firmware package so it can be used if you have a working driver.

description: updated
Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
Changed in linux-firmware (Ubuntu):
status: Fix Released → Fix Committed
Martin Pitt (pitti) wrote :

Accepted linux-firmware into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu Lucid):
status: New → Won't Fix
Changed in linux-firmware (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-neededd
Changed in linux-firmware (Ubuntu):
status: Fix Committed → Fix Released
Nick_Hill (nick-nickhill) wrote :

I confirm installing the propsed linux-firmware for lucid fixes the bug for me using an rt2870-based chip.

Martin Pitt (pitti) on 2010-06-22
tags: added: verification-done
removed: verification-neededd
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.34.1

---------------
linux-firmware (1.34.1) lucid-proposed; urgency=low

  [ Chase Douglas ]

  * Add AudioScience ASI series audio device firmware
    -LP: #557037
  * Add RealTek RTL8192E firmware
    -LP: #508746
  * Update firmware from rt2870sta
    -LP: #580926

  [ Tim Gardner ]

  * radeon: add evergreen family microcode.
    -LP: #560306
 -- Chase Douglas <email address hidden> Mon, 24 May 2010 17:51:17 -0400

Changed in linux-firmware (Ubuntu Lucid):
status: Fix Committed → Fix Released
Brian Pitts (bpitts) wrote :

Installing linux-firmware 1.34.1 and running kernel 2.6.34 made my TP-LINK TL-WN727N work. It still does not work with 2.6.32, see Bug #460323

Changed in linux:
status: Unknown → Fix Released
Changed in linux:
importance: Unknown → Medium

New problem with this chipset in Natty:
[ 1474.591221] usbcore: registered new interface driver rt2870
[ 1474.699350] phy1 -> rt2x00lib_request_firmware: Error - Current firmware does not support detected chipset.
then D-Link DWA-140 B2 just didn't work in Natty.

New bug with this device in Natty.

Changed in linux-firmware (Ubuntu):
status: Fix Released → New
tags: added: natty regression-release
removed: needs-upstream-testing verification-done
tags: added: regression-potential
removed: regression-release
Martin Pitt (pitti) on 2011-03-28
tags: added: verification-done
Matic Zgur (mr-zgur) wrote :

I had the same problem with the firmware not supporting detected chipset for D-Link DWA-140 B2 in Natty and I've managed to resolve it by blacklisting rt2800usb module in /etc/modprobe.d/blacklist.conf.

tags: added: regression-release
removed: regression-potential
silver_james (silver-james) wrote :

Doing #16 it has problems with hidden networks and it connects at 54mbps (the router supports WiFi N 300 mbps)

Julian Wiedmann (jwiedmann) wrote :

See comment #17 in bug 762987 - that should fix the issue for rt2800usb.

Yes, I already seen link in comment #9 of bug 770232, but didn't test it yet before yesterday. Today I checked this version of linux-firmware package (thank for your reminder!) and I can also confirm - it's works now!

Tim Gardner (timg-tpi) on 2011-12-15
Changed in linux-firmware (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.