Intel WiMAX/WiFi Link 6050 series wireless does not work

Bug #532451 reported by David Strauss on 2010-03-05
134
This bug affects 20 people
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.32 (Ubuntu)
Undecided
Unassigned
Lucid
Wishlist
Chase Douglas
Maverick
Undecided
Unassigned
linux-firmware (Ubuntu)
High
Chase Douglas
Lucid
Undecided
Unassigned
Maverick
High
Chase Douglas

Bug Description

SRU Justification for Lucid for linux-backports-modules-2.6.32:

The change merely adds the 6050 iwlwifi firmware to the package. The drivers already in the package should be sufficient to utilize the firmware correctly. There is no regression potential because the file did not exist before.

=====

Wireless Controller: Intel WiMAX/WiFi Link 6050 series (Kernel module iwlagn.ko)

Intel wireless controller can be detected, driver is loaded, but clicking network manager shows no access point. Our office has at least 2 APs as I can see them using other systems. Installing linux-backports-modules-karmic did not fix things, nor did installing the 2.6.33 kernel from the PPA. Once I've installed either the backports or the new kernel, there appears to be a missing microcode/firmware issue, specifically for "iwlwiki-6050-4.ucode".

Steps to Reproduce:
1. Boot the system
2. Click network manager
3. Look for available AP for wireless connection

Expected result:
Available APs are listed, select the best one to make connection.

Actual result:
No AP can be seen.

Credit:
I cribbed most of this bug description from bug #496496.

David Strauss (davidstrauss) wrote :

I can't seem to link this bug to Karmic, but that's the Ubuntu release I'm running.

tags: added: kernel-series-unknown
Roman Andriadi (narn) wrote :

As mentioned, Intel's wireless driver refers to missing iwlwifi-6050-r.ucode which is microcode for Intel 6050 series, but for some reason it is not available from Intel's intellinuxwireless.org and as I know was never available there. As this is the only way (would be glad to be wrong) to get this microcode I'm afraid we should just be patient and wait for it.

Roman Andriadi (narn) wrote :

Shurely, iwlwifi-6050-r.ucode should be read as iwlwifi-6050-4.ucode. BTW, this concerns not only 4th version of ucode. No microcodes for 6050 series at all was ever provided by Intel.

UrkoM (urko-masse) wrote :

I just tested Lucid latest daily, and wireless wasn't working on a Lenovo Thinkpad Edge, using Intel WiMAX/WiFi Link 6050 series, id 8086:0089.

According to the Debian Wiki, the current iwlagn driver should work.
It seems the microcode for the 6000 series is the one to use.
http://wiki.debian.org/iwlagn#SupportedDevices

Changed in linux (Ubuntu):
status: New → Confirmed
Roman Andriadi (narn) wrote :

Current iwlagn driver should work only with appropriate microcode and it's not the one for 6000 series.
At this moment iwlwifi driver in the latest 2.6.32-9 kernel (from debian sid) requres specific 6050 series microcode up to 4th API version. It should not work with 6000 microcode (and it does not). Latest kernel from git.kernel.org has no changes concerning 6050 microcode since 2.6.32, therefore it also does not really support 6050 series cards.

David Strauss (davidstrauss) wrote :

Reply to my email (send to the people at Intel who added the 6050 kernel support):

===

hello David

On Thu, 2010-03-04 at 22:14 +0000, David Strauss wrote:
> I'm researching how to enable the WiMax and WiFi hardware on our
> Thinkpad T510s in Ubuntu. I found a patch that you were each involved in
> submitting or reviewing that adds support for the 6050 series to the
> 2.6.33 kernel. I've installed that kernel, but I still lack the
> necessary firmware, and it doesn't appear available for download from
> the Intel Linux Wireless or the Linux WiMAX site.
>
> Any guidance here would be helpful, and I'm happy to share it on my
> company's public wiki once things are working.
>

The Linux WiMAX software for the 6x50 series is still incomplete; the
kernel drivers have been enabled ahead of time, but the user space
support, including the firmware file is still in the final stages of
completion.

Availability time is still TBD, but should be sooner than later.

David Strauss (davidstrauss) wrote :

Just a note on why I marked #537814 as a duplicate: the 6250 card is a 6050-series card.

Corey Quinn (kb1jwq) wrote :

Once the firmware is released by Intel, how much packaging work is likely to be involved to get this pushed out to the repositories? I'm not that up to speed on Ubuntu packaging, but I'm willing to learn / pitch in.

David Strauss (davidstrauss) wrote :

@KB1JWQ The packaging work should be minimal. It seems like the kernel module just needs the firmware blob without any other change.

Erik Wahlstrom (edub) wrote :

Is there any status update on the 6050 series firmware from Intel?

"Availability time is still TBD, but should be sooner than later." - this is now a month old and this USB wifi dongle is getting really annoying :-P

Corey Quinn (kb1jwq) wrote :

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=3199&DwnldID=17045&lang=eng looks like it has a driver that supports this card as of 3/23. What has to happen to get this into the repos?

Roman Andriadi (narn) wrote :

Yes, it looks like there is such driver, and be sure it is already present in repos. But there's still no firmware for 6050 series WiMAX cards. That is what we're waiting for, not the driver.

Corey Quinn (kb1jwq) wrote :

Right, I get that. But what I saw that struck me as "new" was the iwlwifi-6000-4.ucode firmware bundle; I haven't seen it before, and I THINK that it's being referred to in the 6250 (and other) drivers as the appropriate firmware blob in the latest development snapshots.

Am I wrong?

On Tue, 13 Apr 2010, KB1JWQ wrote:

> Right, I get that. But what I saw that struck me as "new" was the
> iwlwifi-6000-4.ucode firmware bundle; I haven't seen it before, and I
> THINK that it's being referred to in the 6250 (and other) drivers as the
> appropriate firmware blob in the latest development snapshots.
>
> Am I wrong?

The -6000 is different from the -6050. I even tried renaming the
-6000-4.ucode file to -6050 to see if it would work, and got an error like
"microcode loading failed". So we still need Intel to produce -6050
firmware (aka microcode).

  - RL "Bob"

Roman Andriadi (narn) wrote :

6000's firmware is for other adapters. It's for 6000AGN series cards, that are WiFi adapters only.

Florian (exameme) wrote :

hm. i guess we'll have to wait a bit longer:

---
Please note that firmware for 6250 hardware (also referred to as 6050 series) is not available yet. When it becomes available we will announce it on the linux-wireless mailing list and also post it on this webpage under the Downloads section. We hope to be able to make this announcement some time in the third quarter.
---

is what it says on http://intellinuxwireless.org since recently.

:/

fijal (fijal) wrote :

This is what they added to the page when I complained that intel.com website claims it's supported. I don't think this is precisely the kind of response I would like to have.

Florian (exameme) wrote :

*** somewhat OT... sorry! ***

i know this is actually fairly ot but at least related in so far as i have to deal with it because of the missing firmware and others here probably have too...
can anyone recommend any _small_ usb wifi dongles that do g/n? i bought 2 different one that are both ralink based and cannot get them to play nice with wpa.

cheers
_f

David Strauss (davidstrauss) wrote :

@fijal I'm not aware of any place on the Intel website that says the 6050-series Wi-Fi adapters are supported on Linux. I've only see support for the 6000-series ones.

fijal (fijal) wrote :

Here you go:

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=17045&ProdId=3199&lang=eng

It clearly says "-Intel® Centrino® Advanced-N + WiMAX 6250" as an item. Since it leads to intellinuxwireless website, maybe you can figure out that it does not work, but it was not completely trivial before they added info that it's not supported (difference between marketing names on one site and development names on other site does not help folks like me).

Cheers,
fijal

Erik Wahlstrom (edub) wrote :

In agreement/solidarity with fijal on this one. I remember checking for Linux support when I configured my T510 and coming to the conclusion (based on the information available on Intel's site) that the 6250 card was supported.

It's now several months after the product has shipped and we still do not have the proper firmware available for this Intel hardware. This is piss-poor and can't help but undermine Intel attempts at convincing the community that it treats Linux as a first-class environment.

Erik

RL 'Bob' Morgan (rlmorgan) wrote :

I communicated my unhappiness on this issue to Intel via the
<email address hidden> address offered on the intellinuxwireless.org page.
Perhaps others should do so too (politely, I suggest), focusing on damage
to the Intel brand, loss of revenues to WiMAX services, etc.

Roman Andriadi (narn) wrote :

> damage to the Intel brand
They surely know this, but either it's really diffulcult to complete this firmware or nobody cares. And it's most likely the last. It's buisiness, and if opensource does not make money for Intel - they doesn't care at all.

I have just succeeded in running the 64-bit WinXP driver from Intel under a modified trunk version of ndiswrapper. No data on stability or speed just yet. I will submit my patches to ndiswrapper (2 extended APIs from XP SP2 have to be stubbed out or the driver won't load) and post updates here as things develop.

My testbed system is a Dell Studio 1557 (brand new -- delivered less than a week ago); lspci says that it's got a 6050 series adaptor rev 3.5, device ID 1321. I run Ubuntu Lucid, kernel 2.6.32-21

One consistent problem thus far: after a disconnect, ndiswrapper has to be unloaded and loaded back with modprobe to connect again. Doesn't matter if the disconnect is explicit or caused by sleep/resume. Careful analysis of the logs didn't yield much: no specific errors; sometimes there's nothing from wpa_supplicant at all and sometimes wpa seems to proceed normally but DHCP requests are never responded to. Maybe transmitter gets turned off for good?

Benn (benn-blessing) wrote :

Intel has released microcode for 6250 on 02.06.10 (Wifi only). Seems to work ok so far. http://www.intellinuxwireless.org/?n=Downloads and apparently it's included in kernel from 2.6.34.

Benn (benn-blessing) wrote :

Is it possible to add it as an update? It's just a single file that sits in firmware folder.
/lib/firmware/iwlwifi-6050-4.ucode

The existing kernel module will pick it up.

Jeremy Foshee (jeremyfoshee) wrote :

changing task to linux-firmware

affects: linux (Ubuntu) → linux-firmware (Ubuntu)
Changed in linux-firmware (Ubuntu):
status: Confirmed → New
Changed in linux-firmware (Ubuntu):
importance: Undecided → High
status: New → Triaged
assignee: nobody → Chase Douglas (chasedouglas)
Tim Gardner (timg-tpi) wrote :

Won't fix for Lucid - The driver in 2.6.32 for this series adapter was never functional.

Changed in linux-firmware (Ubuntu Lucid):
status: New → Won't Fix
Tim Gardner (timg-tpi) wrote :

Firmware released for Maverick:

linux-firmware (1.36) maverick; urgency=low

  * Added iwlwifi-6050-4.ucode

 -- Tim Gardner <email address hidden> Fri, 04 Jun 2010 13:55:06 -0600

Changed in linux-firmware (Ubuntu Maverick):
milestone: none → maverick-alpha-2
status: Triaged → Fix Released
Janne Moren (jan-moren-gmail) wrote :

"Won't fix for Lucid - The driver in 2.6.32 for this series adapter was never functional."

So.. How come adding the firmware makes the adapter work? Not perfectly I readily agree (it seems hit and miss whether it actually connects) but non-functional it isn't.

So I'll need to upgrade to Maverick then?

-
Theodore Reed

On Tue, Jun 8, 2010 at 05:55, Tim Gardner <email address hidden> wrote:

> Won't fix for Lucid - The driver in 2.6.32 for this series adapter was
> never functional.
>
> ** Also affects: linux-firmware (Ubuntu Maverick)
> Importance: High
> Assignee: Chase Douglas (chasedouglas)
> Status: Triaged
>
> ** Also affects: linux-firmware (Ubuntu Lucid)
> Importance: Undecided
> Status: New
>
> ** Changed in: linux-firmware (Ubuntu Lucid)
> Status: New => Won't Fix
>
> --
> Intel WiMAX/WiFi Link 6050 series wireless does not work
> https://bugs.launchpad.net/bugs/532451
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Changed in linux-backports-modules-2.6.32 (Ubuntu Maverick):
status: New → Invalid
Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
importance: Undecided → Wishlist
status: New → Triaged
assignee: nobody → Chase Douglas (chasedouglas)
Chase Douglas (chasedouglas) wrote :

The iwlagn 2.6.32 driver support for the 6050 series of cards in Ubuntu 10.04 LTS is a skeleton driver that may work for users but is not supported by Ubuntu because we couldn't test it before release, among other reasons. However, we do have the linux-backports-modules-wireless package which will contain the 2.6.34 version of the iwlagn driver when the 2.6.32-22.15 version releases. It is recommended that users install this package for support for these cards.

However, the package as it stands right now does not have the firmware in it yet. I have added a task to this bug for adding the firmware to it.

Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: Triaged → In Progress
description: updated

Accepted linux-backports-modules-2.6.32 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Chase Douglas (chasedouglas) wrote :

Everything looks good to me with the package in lucid-proposed. Wireless came up just fine.

Martin Pitt (pitti) on 2010-06-16
tags: added: verification-done
removed: verification-needed
carltonh (carlton-hobbs) wrote :

I know this fix is not supported officially, but I thought I'd at least report that upgrading to the packages in lucid-proposed caused the laptop to run in low graphics mode when booting the new kernel that uses the fix.

The laptop was running the Nvidia proprietary driver for a NVS 3100 before the fix. I went ahead and installed every update in lucid-proposed, but still am stuck in low graphics mode.

Chase Douglas (chasedouglas) wrote :

carltonh,

If things are broken due to a lucid-proposed package, you should open a bug against the package that caused the issue. Likely this is the "nvidia-current" package that is causing you issues.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-backports-modules-2.6.32 - 2.6.32-23.16

---------------
linux-backports-modules-2.6.32 (2.6.32-23.16) lucid-proposed; urgency=low

  [ Chase Douglas ]

  * Add in staging rt28x0 drivers from 2.6.34
    - LP: #496093
  * Added iwlwifi 6050 series firmware
    - LP: #532451
  * Don't munge iwlwifi firmware filenames anymore
    - LP: #591822
 -- Stefan Bader <email address hidden> Mon, 14 Jun 2010 10:31:02 +0200

Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Joseph Salisbury (jsalisbury) wrote :

I just installed Ubuntu 10.04.1 LTS on an out of the box Thinkpad x201 with the following wireless card: Intel Corporation WiMAX/WiFi Link 6050 Series. Wireless would not work out of the box.

I installed the 2.6.32-25-generic and can confirm that linux-backports-modules-2.6.32 fixed the wifi issue on my x201.

Joseph Salisbury (jsalisbury) wrote :

Upgraded to Maverick and wireless broke again... boo, happy halloween :-)

Janne Moren (jan-moren-gmail) wrote :

I upgraded to Maverick and Wifi still works fine. Lots of other stuff has broken but not Wifi, this time :)

vanessa fan (lowbvan) wrote :

I don't know if it works, but looks like there is a driver released for this. Can anyone confirm?

http://intellinuxwireless.org/?n=downloads

scroll to the last one for the

6050 Images – for Intel Wireless WiFi Link 6250AGN Adapter
iwlwifi-6050-ucode-9.201.4.1.tgz 06-02-10 15:46:07 R L

vanessa fan (lowbvan) wrote :

I tried this backports module, but it did not work for me.

However, downloading this intel driver does work!

To post a comment you must log in.