Move dib0700 1.20 firmware out of linux-firmware-nonfree

Bug #446454 reported by Devin Heitmueller
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Fix Released
Undecided
Tim Gardner
Karmic
Fix Released
Undecided
Tim Gardner
linux-firmware-nonfree (Ubuntu)
Fix Released
Undecided
Tim Gardner
Karmic
Fix Released
Undecided
Tim Gardner

Bug Description

Binary package hint: linux-firmware

We worked with DibCom to get them to clarify their licensing for the dib0700 1.20 firmware, and it can now be freely redistributed.

The license terms can be found here:

http://www.kernellabs.com/firmware/dib0700/README.dib0700

We will be working to get this into dwm2's upstream linux-firmware tree, but given Karmic's schedule it would be worthwhile if we could get this moved out of linux-firmware-nonfree and back into linux-firmware before the release.

Without this change, users will see a regression when they upgrade to Karmic and don't know that they need to install the new linux-firmware-nonfree package.

Revision history for this message
Devin Heitmueller (devin-heitmueller) wrote :

Note that this has been pulled into David Woodhouse's linux-firmware tree, so now only a git pull is required:

http://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git;a=commit;h=f20b0674534a444ae74239843cac19f72c64912b

git://git.kernel.org/pub/scm/linux/kernel/git/dwmw2/linux-firmware.git

Revision history for this message
Tim Gardner (timg-tpi) wrote :
Changed in linux-firmware (Ubuntu Karmic):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.22

---------------
linux-firmware (1.22) karmic; urgency=low

  * Added firmware for dib0700 USB bridge
    -LP: #446454
    https://lists.ubuntu.com/archives/kernel-team/2009-October/007462.html

 -- Tim Gardner <email address hidden> Tue, 13 Oct 2009 13:35:20 -0600

Changed in linux-firmware (Ubuntu Karmic):
status: Fix Committed → Fix Released
Revision history for this message
Tim Gardner (timg-tpi) wrote :

Removed dvb/dvb-usb-dib0700-1.20.fw

Changed in linux-firmware-nonfree (Ubuntu Karmic):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Revision history for this message
Tim Gardner (timg-tpi) wrote :

linux-firmware-nonfree (1.1) karmic; urgency=low

  * Moved dvb/dvb-usb-dib0700-1.20.fw to linux-firmware since it is
    now compatibly licensed.
    -LP: 446454

 -- Tim Gardner <email address hidden> Tue, 13 Oct 2009 13:45:41 -0600

Changed in linux-firmware-nonfree (Ubuntu Karmic):
status: In Progress → Fix Released
Changed in linux-firmware-nonfree (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers