package linux-firmware None [modified: /var/lib/dpkg/info/linux-firmware.list] failed to install/upgrade: trying to overwrite `/lib/firmware/ipw2100-1.3-i.fw', which is also in package nic-firmware

Bug #285280 reported by Nathan Miller on 2008-10-18
4
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-firmware

Attempted to install update via update manager, got this crash report.

ProblemType: Package
Architecture: amd64
Dependencies:

DistroRelease: Ubuntu 8.10
ErrorMessage: trying to overwrite `/lib/firmware/ipw2100-1.3-i.fw', which is also in package nic-firmware
Package: linux-firmware None [modified: /var/lib/dpkg/info/linux-firmware.list]
PackageArchitecture: all
SourcePackage: linux-firmware
Title: package linux-firmware None [modified: /var/lib/dpkg/info/linux-firmware.list] failed to install/upgrade: trying to overwrite `/lib/firmware/ipw2100-1.3-i.fw', which is also in package nic-firmware
Uname: Linux 2.6.27-7-generic x86_64

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Can you please provide the output of :
$ apt-cache policy linux-firmware nic-firmware

Thanks in advance.

Changed in linux-firmware:
status: New → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

For reference I'm pasting your message here:
"
Sure. Just so its noted, after a recent Kernel Update, my WLAN card didn't work so I had to apply a firmware update off launchpad called nic-firmware_1.1_all.udeb

Below is the output of $ apt-cache policy linux-firmware nic-firmware

linux-firmware:
  Installed: (none)
  Candidate: 1.1
  Version table:
     1.1 0
        500 http://us.archive.ubuntu.com intrepid/main Packages
nic-firmware:
  Installed: 1.1
  Candidate: 1.1
  Version table:
 *** 1.1 0
        100 /var/lib/dpkg/status

I had to install a package so get my WLAN card working again after the last kernel update.
"

Jean-Baptiste Lallement (jibel) wrote :

The drivers shipped in the package nic-firmware (atmel, ipw2100, prism isl3890) are included in linux-firmware. So, you can safely remove nic-firmware and install linux-firmware instead.

Let us know if that works.

Thanks.

Seems to be fixed. Ran the following to remove nic-firmware:

# apt-get remove linux-image-generic

# apt-get remove linux-firmware

# apt-get remove nic-firmware

I then ran updater and it updated fine, no crashing. Everything seems to be fine now. Thanks for your help.

Jean-Baptiste Lallement (jibel) wrote :

I'm closing this report due to your last comment. Thanks for your time and don't hesitate to submit any new bug.

Changed in linux-firmware:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers