Add missing firmware for HWE 5.15 kernel

Bug #1962299 reported by Juerg Haefliger
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Invalid
Undecided
Unassigned
Focal
Fix Released
Undecided
Juerg Haefliger

Bug Description

[Impact]

Firmware files required by the HWE kernel 5.15 which are present in Jammy but missing in Focal:

amd/amd_sev_fam17h_model3xh.sbin
amd/amd_sev_fam19h_model0xh.sbin
amdgpu/aldebaran_mec.bin
amdgpu/aldebaran_mec2.bin
amdgpu/aldebaran_rlc.bin
amdgpu/aldebaran_sdma.bin
amdgpu/aldebaran_smc.bin
amdgpu/aldebaran_sos.bin
amdgpu/aldebaran_ta.bin
amdgpu/aldebaran_vcn.bin
amdgpu/arcturus_asd.bin
amdgpu/arcturus_gpu_info.bin
amdgpu/arcturus_mec.bin
amdgpu/arcturus_rlc.bin
amdgpu/arcturus_sdma.bin
amdgpu/arcturus_smc.bin
amdgpu/arcturus_sos.bin
amdgpu/arcturus_ta.bin
amdgpu/arcturus_vcn.bin
amdgpu/cyan_skillfish2_ce.bin
amdgpu/cyan_skillfish2_me.bin
amdgpu/cyan_skillfish2_mec.bin
amdgpu/cyan_skillfish2_mec2.bin
amdgpu/cyan_skillfish2_pfp.bin
amdgpu/cyan_skillfish2_rlc.bin
amdgpu/cyan_skillfish2_sdma.bin
amdgpu/cyan_skillfish2_sdma1.bin
amdgpu/navy_flounder_ce.bin
amdgpu/navy_flounder_dmcub.bin
amdgpu/navy_flounder_me.bin
amdgpu/navy_flounder_mec.bin
amdgpu/navy_flounder_mec2.bin
amdgpu/navy_flounder_pfp.bin
amdgpu/navy_flounder_rlc.bin
amdgpu/navy_flounder_sdma.bin
amdgpu/navy_flounder_smc.bin
amdgpu/navy_flounder_sos.bin
amdgpu/navy_flounder_ta.bin
amdgpu/navy_flounder_vcn.bin
amdgpu/vangogh_asd.bin
amdgpu/vangogh_ce.bin
amdgpu/vangogh_dmcub.bin
amdgpu/vangogh_me.bin
amdgpu/vangogh_mec.bin
amdgpu/vangogh_mec2.bin
amdgpu/vangogh_pfp.bin
amdgpu/vangogh_rlc.bin
amdgpu/vangogh_sdma.bin
amdgpu/vangogh_toc.bin
amdgpu/vangogh_vcn.bin
atmel/wilc1000_wifi_firmware-1.bin
brcm/brcmfmac43340-sdio.predia-basic.txt
brcm/brcmfmac43430-sdio.friendlyarm,nanopi-r1.txt
brcm/brcmfmac43430-sdio.raspberrypi,model-zero-w.txt
brcm/brcmfmac43430-sdio.sinovoip,bpi-m2-plus.txt
brcm/brcmfmac43430-sdio.sinovoip,bpi-m2-ultra.txt
brcm/brcmfmac43430-sdio.sinovoip,bpi-m2-zero.txt
brcm/brcmfmac43430-sdio.sinovoip,bpi-m3.txt
brcm/brcmfmac43430a0-sdio.ilife-S806.txt
brcm/brcmfmac43455-sdio.Raspberry Pi Foundation-Raspberry Pi 4 Model B.txt
brcm/brcmfmac43455-sdio.Raspberry Pi Foundation-Raspberry Pi Compute Module 4.txt
brcm/brcmfmac43455-sdio.acepc-t8.txt
brcm/brcmfmac43455-sdio.raspberrypi,3-model-a-plus.txt
brcm/brcmfmac4356-sdio.khadas,vim2.txt
brcm/brcmfmac4356-sdio.vamrs,rock960.txt
brcm/brcmfmac43012-sdio.bin
brcm/brcmfmac43012-sdio.clm_blob
brcm/brcmfmac43430-sdio.clm_blob
brcm/brcmfmac43455-sdio.clm_blob
brcm/brcmfmac4354-sdio.clm_blob
brcm/brcmfmac4356-pcie.clm_blob
brcm/brcmfmac4356-sdio.clm_blob
brcm/brcmfmac43570-pcie.clm_blob
brcm/brcmfmac4373-sdio.clm_blob
i915/adlp_guc_62.0.3.bin
i915/bxt_guc_62.0.0.bin
i915/cml_guc_62.0.0.bin
i915/ehl_guc_62.0.0.bin
i915/glk_guc_62.0.0.bin
i915/icl_guc_62.0.0.bin
i915/kbl_guc_62.0.0.bin
i915/rkl_dmc_ver2_03.bin
i915/skl_guc_62.0.0.bin
i915/tgl_dmc_ver2_12.bin
i915/tgl_guc_62.0.0.bin
i915/tgl_huc_7.9.3.bin
iwlwifi-Qu-b0-hr-b0-66.ucode
iwlwifi-Qu-b0-jf-b0-66.ucode
iwlwifi-Qu-c0-hr-b0-66.ucode
iwlwifi-QuZ-a0-hr-b0-66.ucode
iwlwifi-QuZ-a0-jf-b0-66.ucode
iwlwifi-cc-a0-66.ucode
iwlwifi-ty-a0-gf-a0-66.ucode
mellanox/mlxsw_spectrum-13.2008.2406.mfa2
mellanox/mlxsw_spectrum2-29.2008.2406.mfa2
mellanox/mlxsw_spectrum3-30.2008.2406.mfa2
nvidia/tegra194/vic.bin
rtl_bt/rtl8821a_config.bin
rtl_nic/rtl8153c-1.fw
rtl_nic/rtl8156a-2.fw
rtl_nic/rtl8156b-2.fw

[Fix]

Add relevant commits for the above files. Except for the brcm files. Some of them are provided by the linux-firmware-raspi2 package and could cause conflicts.

[Test Case]

Verify that above files are present after package installation (except brcm/*).

[Where Problems Could Occur]

These are all new firmware files so no regression is expected.

Juerg Haefliger (juergh)
Changed in linux-firmware (Ubuntu):
status: New → Invalid
Changed in linux-firmware (Ubuntu Focal):
assignee: nobody → Juerg Haefliger (juergh)
summary: - Update firmware for HWE 5.14
+ Update firmware for HWE 5.14 kernel
summary: - Update firmware for HWE 5.14 kernel
+ Update/add firmware for HWE 5.14 kernel
Juerg Haefliger (juergh)
description: updated
Juerg Haefliger (juergh)
description: updated
Juerg Haefliger (juergh)
summary: - Update/add firmware for HWE 5.14 kernel
+ Add missing firmware for HWE 5.14 kernel
Juerg Haefliger (juergh)
description: updated
Juerg Haefliger (juergh)
tags: added: kern-2594
Juerg Haefliger (juergh)
summary: - Add missing firmware for HWE 5.14 kernel
+ Add missing firmware for HWE 5.15 kernel
description: updated
Changed in linux-firmware (Ubuntu Focal):
status: New → In Progress
Juerg Haefliger (juergh)
description: updated
Juerg Haefliger (juergh)
description: updated
Juerg Haefliger (juergh)
Changed in linux-firmware (Ubuntu Focal):
status: In Progress → Fix Committed
Revision history for this message
Andy Whitcroft (apw) wrote : Please test proposed package

Hello Juerg, or anyone else affected,

Accepted linux-firmware into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/1.187.28 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Andy Whitcroft (apw) wrote :

Hello Juerg, or anyone else affected,

Accepted linux-firmware into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/1.187.29 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Juerg Haefliger (juergh)
tags: added: verification-done-focal
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Please include information about what tests have been performed and on which package version (per the acceptance comment on the bug). Since this time it was an easy 'file addition' fix, I could check that myself - but other SRU members might not want to lose time doing their own validation of the validation.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.187.29

---------------
linux-firmware (1.187.29) focal; urgency=medium

  * mt7921e device disappear after warm boot stress (LP: #1963614)
    - linux-firmware: update firmware for MT7921 WiFi device

linux-firmware (1.187.28) focal; urgency=medium

  * bnx2x: Add FW 7.13.21.0 (LP: #1962155)
    - bnx2x: Add FW 7.13.20.0
    - bnx2x: Add FW 7.13.21.0
  * Add missing firmware for HWE 5.15 kernel (LP: #1962299)
    - linux-firmware: wilc1000: add wilc1000 v15.4 FW
    - linux-firmware: Update AMD SEV firmware
    - linux-firmware: Update AMD SEV firmware
    - linux-firmware: Update AMD SEV firmware
    - Mellanox: Add new mlxsw_spectrum firmware xx.2008.2406
    - amdgpu: add initial support for navy flounder
    - amdgpu: add arcturus firmware
    - rtl_nic: add new firmware for RTL8153 and RTL8156 series
    - amdgpu: update navy flounder firmware from 21.10
    - amdgpu: update arcturus firmware from 21.10
    - firmware: nvidia: Add VIC firmware for Tegra194
    - amdgpu: update navy flounder firmware from 21.20
    - amdgpu: update arcturus firmware from 21.20
    - firmware/i915/guc: Add GuC v62.0.0 for all platforms
    - firmware/i915/guc: Add GuC v62.0.3 for ADL-P
    - firmware/i915/guc: Add HuC v7.9.3 for TGL & DG1
    - iwlwifi: add ty firmware from Core63-43
    - i915: Add v2.12 DMC for TGL
    - i915: Add v2.03 DMC for RKL
    - amdgpu: update arcturus firmware from 21.30
    - amdgpu: update navy flounder firmware from 21.30
    - amdgpu: add initial vangogh support
    - rtl_nic: update firmware of RTL8153C
    - linux-firmware: Update AMD SEV firmware
    - amdgpu: update VCN firmware for vangogh
    - amdgpu: update VCN firmware for navy flounder
    - amdgpu: update arcturus firmware from 21.40
    - amdgpu: update navy flounder firmware from 21.40
    - amdgpu: add cyan skillfish firmware from 21.40
    - amdgpu: update vangogh firmware from 21.40
    - amdgpu: update vangogh DMCUB firmware
    - linux-firmware: wilc1000: update WILC1000 firmware to v15.4.1
    - iwlwifi: add new FWs from core63-136 release
    - amdgpu: Add aldebaran firmware from 21.50
    - amdgpu: Update arcturus firmware from 21.50
    - amdgpu: Update cyan skillfish2 firmware from 21.50
    - amdgpu: Update navy flounder firmware from 21.50
    - amdgpu: Update vangogh firmware from 21.50
    - WHENCE: link to similar config file for rtl8821a support
  * Intermittent AX211 iwlwifi RT ucode init failed -110 at boot (LP: #1962515)
    - iwlwifi: add new FWs from core64-96 release
  * mt7921e device disappear after warm boot stress (LP: #1963614)
    - linux-firmware: update firmware for mediatek bluetooth chip(MT7921)

 -- Juerg Haefliger <email address hidden> Thu, 10 Mar 2022 08:05:39 +0100

Changed in linux-firmware (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for linux-firmware has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
ATIpro (somebody2112) wrote :

There is also missing rtl8761bu firmware. Support for this bluetooth chip was added in kernel 5.14. Should I create another bug report for that?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers