Missing CNVi firmware for Intel AX211/AX201/9560/9462 on ADL-S/ADL-P

Bug #1933938 reported by You-Sheng Yang
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
intel
Undecided
Unassigned
linux (Ubuntu)
High
You-Sheng Yang
Focal
Undecided
Unassigned
Impish
High
You-Sheng Yang
linux-firmware (Ubuntu)
High
You-Sheng Yang
Focal
High
You-Sheng Yang
Impish
High
You-Sheng Yang
linux-oem-5.13 (Ubuntu)
Undecided
Unassigned
Focal
High
You-Sheng Yang
Impish
Undecided
Unassigned
linux-oem-5.14 (Ubuntu)
Undecided
Unassigned
Focal
High
You-Sheng Yang
Impish
Undecided
Unassigned

Bug Description

[SRU Justfication]

[Impact]

Intel CNVi moves key elements of Wi-Fi and Bluetooth Technology into
Intel processors. As a result, their driver may have to be revised
across processor generations.

[Fix]

This depends on a few changes set to address all issues on supporting:
* PCI [8086:7af0] Subsystem [8086:4090] (AX211)
  * WiFi: iwlwifi-so-a0-gf-a0-*
  * BT: intel/ibt-1040-0041.* (ADL-S)
  * BT: intel/ibt-0040-0041.* (ADL-P)
* PCI [8086:7af0] Subsystem [8086:4070] (AX201)
  * WiFi: iwlwifi-so-a0-hr-b0-*
  * BT: intel/ibt-1040-4150.*
  * BT: intel/ibt-0040-4150.*
* PCI [8086:7af0] Subsystem [8086:0aaa] (9462)
  * WiFi: iwlwifi-so-a0-jf-b0-*
  * BT: intel/ibt-1040-1020.*

AX201 wifi firmware for ADL platforms will be available with FW
API >= 64, so a patchset "iwlwifi: bump FW API to 64 for AX devices"
will be required. Depending fixes are pulled as well.

For reset of them, 3 additional commits for iwlwifi, also in mainline
now, are required.

The last patch for 9462 Bluetooth is still under review at the time of
writing. This is the only patch that is not yet in unstable.

[Test Case]

Install these CRF on ADL-S/ADL-P platforms and check if WiFi/Bluetooth
is working.

[Where problems could occur]

While this is a new generation, we may have common issues like power
consumption, network throughput, suspend/resume issues.

[Other Info]

Intel is to release the corresponding firmware blobs next week. These
are verified with pre-released firmware.

========== original bug report ==========

* PCI [8086:7af0] Subsystem [8086:4090] (AX211)
  * WiFi: iwlwifi-so-a0-gf-a0-*
  * BT: intel/ibt-1040-0041.sfi
* PCI [8086:7af0] Subsystem [8086:4070] (AX201)
  * WiFi: iwlwifi-so-a0-hr-b0-*
  * BT: ibt-1040-4150.sfi
* PCI [8086:7af0] Subsystem [8086:0264] (9462)
  * WiFi: iwlwifi-so-a0-jf-b0-*
  * BT: intel/ibt-1040-1020.*
  * BT: intel/ibt-0040-1020.*

Revision history for this message
You-Sheng Yang (vicamo) wrote :
You-Sheng Yang (vicamo)
tags: added: oem-priority originate-from-1929544 somerville
tags: added: originate-from-1929545
tags: added: originate-from-1929546
tags: added: originate-from-1930881
tags: added: originate-from-1930882
Revision history for this message
You-Sheng Yang (vicamo) wrote :
You-Sheng Yang (vicamo)
description: updated
description: updated
Revision history for this message
Kai-Chuan Hsieh (kchsieh) wrote :

Using the ppa in #2, the fw init failed. Log is attached.

Revision history for this message
You-Sheng Yang (vicamo) wrote :

Attach also AX211 (PCI 8086:7fa0 subsys 8086:4090) on Intel ADL-S RVP running kernel with wireless-drivers-next master HEAD commit ff8744b5eb11 merged into v5.13:

  iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5

tags: added: fossa-edge-staging
tags: removed: fossa-edge-staging
Revision history for this message
You-Sheng Yang (vicamo) wrote :

With CONFIG_IWLWIFI_DEBUG enabled.

You-Sheng Yang (vicamo)
Changed in linux (Ubuntu Focal):
status: New → Won't Fix
Changed in linux (Ubuntu Impish):
assignee: nobody → You-Sheng Yang (vicamo)
importance: Undecided → High
status: New → Incomplete
Changed in linux-firmware (Ubuntu Focal):
assignee: nobody → You-Sheng Yang (vicamo)
importance: Undecided → High
status: New → Incomplete
Changed in linux-firmware (Ubuntu Impish):
importance: Undecided → High
status: New → Incomplete
Changed in linux-oem-5.13 (Ubuntu Focal):
assignee: nobody → You-Sheng Yang (vicamo)
importance: Undecided → High
status: New → Incomplete
Changed in linux-oem-5.13 (Ubuntu Impish):
status: New → Invalid
Revision history for this message
You-Sheng Yang (vicamo) wrote :

Moved PPA in comment #2 to https://launchpad.net/~vicamo/+archive/ubuntu/linux-staging to have a single origin containing all planned fixes.

Revision history for this message
Harrison Hemstreet (harrison-m-h) wrote :

This bug is affecting me too!!!!!! Please fix!!!!!!!!!

You-Sheng Yang (vicamo)
tags: added: originate-from-1941066
Revision history for this message
You-Sheng Yang (vicamo) wrote :
description: updated
description: updated
Changed in linux-oem-5.13 (Ubuntu Focal):
status: Incomplete → In Progress
Changed in linux (Ubuntu Impish):
status: Incomplete → In Progress
Revision history for this message
You-Sheng Yang (vicamo) wrote :

Pushed iwlwifi fw release to https://launchpad.net/~vicamo/+archive/ubuntu/linux-firmware-staging starting from version 1.187.16+staging.17

Revision history for this message
You-Sheng Yang (vicamo) wrote :

Incorrect filenames in WHENCE found: https://lore<email address hidden>/ . Fixed in version 1.187.16+staging.18.

You-Sheng Yang (vicamo)
description: updated
Revision history for this message
You-Sheng Yang (vicamo) wrote :

Included patchset starting from https://<email address hidden>/ in version 1.187.17+staging.22 in ppa:vicamo/linux-firmware-staging.

We're still missing bt fw for 9462 intel/ibt-1040-1020.* .

You-Sheng Yang (vicamo)
description: updated
Revision history for this message
You-Sheng Yang (vicamo) wrote :

With linux-firmware version 1.187.17+staging.22 from ppa:vicamo/linux-firmware-staging, verified following configurations:

* ADL-S:
  * AX211 [8086:7AF0] subsystem [8086:4090]:
    * 5.13.0-1014-oem: no, expected,
    * 5.13.0-9014+staging19
    * 5.14.0-1004-oem
    * 5.14.0-9004.4+staging.20
  * AX210 [8086:2725] subsystem [8086:0020]:
    * 5.13.0-1014-oem
    * 5.13.0-9014+staging19
    * 5.14.0-1004-oem
    * 5.14.0-9004.4+staging.20
  * AX201 [8086:7AF0] subsystem [8086:0074]
    * 5.13.0-1014-oem: no, expected,
    * 5.13.0-9014+staging19
    * 5.14.0-1004-oem: no bt, expected
    * 5.14.0-9004.4+staging.20
  * AX200 [8086:2723] subsystem [8086:0084]
    * 5.13.0-1014-oem
    * 5.13.0-9014+staging19
    * 5.14.0-1004-oem
    * 5.14.0-9004.4+staging.20
  * 9560NGW [8086:7AF0] subsystem [8086:0030]
    * 5.13.0-1014-oem: no, expected,
    * 5.13.0-9014+staging19
    * 5.14.0-1004-oem: no bt, expected
    * 5.14.0-9004.4+staging.20
  * 9462NGW [8086:7AF0] subsystem [8086:42A4]
    * 5.13.0-1014-oem: no, expected,
    * 5.13.0-9014+staging19
    * 5.14.0-1004-oem: no bt, expected
    * 5.14.0-9004.4+staging.20
* ADL-P:
  * AX211 [8086:51F0] subsystem [8086:4090]:
    * 5.14.0-1004-oem
    * 5.14.0-9004.4+staging.20
  * AX210 [8086:2725] subsystem [8086:0020]:
    * 5.14.0-1004-oem
    * 5.14.0-9004.4+staging.20
  * AX201 [8086:51F0] subsystem [8086:0074]
    * 5.14.0-1004-oem: no bt, expected
    * 5.14.0-9004.4+staging.20
  * AX200 [8086:2723] subsystem [8086:0084]
    * 5.14.0-1004-oem
    * 5.14.0-9004.4+staging.20
  * 9560NGW [8086:51F0] subsystem [8086:0030]
    * 5.14.0-1004-oem: no bt, expected
    * 5.14.0-9004.4+staging.20
  * 9462NGW [8086:51F0] subsystem [8086:42A4]
    * 5.14.0-1004-oem: no bt, expected
    * 5.14.0-9004.4+staging.20: no bt (<-------- problem)

Revision history for this message
You-Sheng Yang (vicamo) wrote :

While ADL-P is not PV yet, I will ignore following case and send SRU when intel/ibt-1040-1020.* is publicly available.

* ADL-P:
  * 9462NGW [8086:51F0] subsystem [8086:42A4]
    * 5.14.0-9004.4+staging.20: no bt (<-------- problem)

You-Sheng Yang (vicamo)
Changed in linux-firmware (Ubuntu Focal):
status: Incomplete → In Progress
Changed in linux-firmware (Ubuntu Impish):
status: Incomplete → In Progress
Revision history for this message
You-Sheng Yang (vicamo) wrote :
summary: - Missing CNVi firmware for Intel AX211/AX201 on ADL
+ Missing CNVi firmware for Intel AX211/AX201/9560/9462 on ADL-S/ADL-P
You-Sheng Yang (vicamo)
Changed in linux-oem-5.14 (Ubuntu Impish):
status: New → Invalid
Changed in linux-oem-5.14 (Ubuntu Focal):
assignee: nobody → You-Sheng Yang (vicamo)
importance: Undecided → High
status: New → In Progress
Revision history for this message
You-Sheng Yang (vicamo) wrote :

Now all the commits are in linux-firmware/impish version 1.201.

Changed in linux-firmware (Ubuntu Impish):
status: In Progress → Invalid
Timo Aaltonen (tjaalton)
Changed in linux-firmware (Ubuntu Impish):
status: Invalid → Fix Released
You-Sheng Yang (vicamo)
tags: added: originate-from-1942311
tags: added: originate-from-1930521
You-Sheng Yang (vicamo)
tags: added: originate-from-1943204
Revision history for this message
Andy Whitcroft (apw) wrote : Please test proposed package

Hello You-Sheng, or anyone else affected,

Accepted linux-firmware into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/1.187.19 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in linux-firmware (Ubuntu Focal):
status: In Progress → Fix Committed
Timo Aaltonen (tjaalton)
tags: added: verification-needed-focal
Revision history for this message
You-Sheng Yang (vicamo) wrote :

verified linux-firmware/focal-proposed version 1.187.19 has identical blobs with those tested and proposed.

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
You-Sheng Yang (vicamo) wrote (last edit ):
Revision history for this message
Chris Halse Rogers (raof) wrote : Update Released

The verification of the Stable Release Update for linux-firmware has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.187.19

---------------
linux-firmware (1.187.19) focal; urgency=medium

  * Add Intel WiFi/Bluetooth firmware for ADL-S/ADL-P (LP: #1933938)
    - iwlwifi: add FWs for new So device types with multiple RF modules
    - linux-firmware: Update firmware file for Intel Bluetooth AX211
    - linux-firmware: Update firmware file for Intel Bluetooth 9560
    - linux-firmware: Update firmware file for Intel Bluetooth AX201
    - linux-firmware: Update firmware file for Intel Bluetooth AX211
    - linux-firmware: Update firmware file for Intel Bluetooth 9462
  * Revert "amdgpu: update renoir firmware from 21.20" (LP: #1945565)
  * [Packaging] Add close-release helper script and debian rule
  * i915: Update ADLP DMC v2.12 (LP: #1945438)
  * amdgpu: add initial firmware for Yellow Carp (LP: #1945227)

 -- Timo Aaltonen <email address hidden> Thu, 30 Sep 2021 16:29:46 +0300

Changed in linux-firmware (Ubuntu Focal):
status: Fix Committed → Fix Released
Timo Aaltonen (tjaalton)
Changed in linux-oem-5.13 (Ubuntu Focal):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-5.13 - 5.13.0-1017.21

---------------
linux-oem-5.13 (5.13.0-1017.21) focal; urgency=medium

  * focal/linux-oem-5.13: 5.13.0-1017.21 -proposed tracker (LP: #1946722)

  * Intel AX201 8086:7af0 subsys 8086:4070 hardware reset periodically: FW error
    in SYNC CMD UNKNOWN (LP: #1941665)
    - iwlwifi: mvm: support BIOS enable/disable for 11ax in Russia
    - iwlwifi: mvm: Read acpi dsm to get unii4 enable/disable bitmap.

 -- Timo Aaltonen <email address hidden> Tue, 12 Oct 2021 11:54:40 +0300

Changed in linux-oem-5.13 (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Yuan-Chen Cheng (ycheng-twn) wrote :

5.14-oem still not close because https://lists.ubuntu.com/archives/kernel-team/2021-October/124690.html is not merged yet.

Given so, the kernel AFTER linux-image-5.14.0-1005-oem will be the blessed one.

Timo Aaltonen (tjaalton)
Changed in linux-oem-5.14 (Ubuntu Focal):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-5.14 - 5.14.0-1007.7

---------------
linux-oem-5.14 (5.14.0-1007.7) focal; urgency=medium

  * focal/linux-oem-5.14: 5.14.0-1007.7 -proposed tracker (LP: #1949349)

  * Intel I225-IT ethernet controller: igc: probe of 0000:02:00.0 failed with
    error -1 (LP: #1945576)
    - igc: Remove _I_PHY_ID checking
    - igc: Remove phy->type checking

  * Fix Screen freeze after resume from suspend with iGPU [1002:6987]
    (LP: #1949050)
    - drm/amdgpu: reenable BACO support for 699F:C7 polaris12 SKU
    - drm/amdgpu: add missing cleanups for Polaris12 UVD/VCE on suspend
    - drm/amdgpu: Fix crash on device remove/driver unload

  * Fail to detect audio output from external monitor (LP: #1948767)
    - ALSA: hda: intel: Allow repeatedly probing on codec configuration errors

  * Fix System hangs on black screen when reboot (LP: #1949321)
    - SAUCE: drm/i915: Don't request GMBUS to generate irqs when called while irqs
      are off
    - SAUCE: drm/i915/hdmi: Turn DP++ TMDS output buffers back on in
      encoder->shutdown()

 -- Timo Aaltonen <email address hidden> Mon, 01 Nov 2021 12:38:15 +0200

Changed in linux-oem-5.14 (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers