linux-firmware: missing sof-cfl.ri symbol link for Bionic and Eoan

Bug #1875263 reported by Hui Wang on 2020-04-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Kai-Chuan Hsieh
linux-firmware (Ubuntu)
Critical
Hui Wang
Bionic
Critical
Unassigned
Eoan
Undecided
Unassigned

Bug Description

[Impact]
some ubuntu eoan/bionic users reported that the audio driver failed
to initialize, then the audio didn't work. I checked the dmesg, found
the sof driver planed to load sof-cfl.ri, but there is no this
firmware under eoan or bionic.

[Fix]
I consulted with Intel audio team, they told me that the coffeelake
platform could share the firmware with cnl/whl platoforms, so we could
build a symbol link sof-cfl->sof-cnl.

[Test Case]
A couple of ubuntu users already tested it on Dell and Asus coffeelake
laptops, it worked well.

[Regression Risk]
Low, users already tested it, and Intel audio team confirmed it is safe.

Hui Wang (hui.wang) on 2020-04-27
Changed in linux-firmware (Ubuntu):
importance: Undecided → High
Hui Wang (hui.wang) on 2020-04-27
description: updated
Seth Forshee (sforshee) on 2020-05-14
Changed in linux-firmware (Ubuntu Bionic):
status: New → Fix Committed
Changed in linux-firmware (Ubuntu Eoan):
status: New → Fix Committed
Kai-Chuan Hsieh (kchsieh) wrote :

@hui.wang

Hello,

do you know when the package be SRUed?

Thanks,

Seth Forshee (sforshee) on 2020-05-18
Changed in linux-firmware (Ubuntu Bionic):
status: Fix Committed → In Progress
Changed in linux-firmware (Ubuntu Eoan):
status: Fix Committed → In Progress
Hui Wang (hui.wang) on 2020-05-26
Changed in linux-firmware (Ubuntu Eoan):
status: In Progress → Fix Committed
Changed in linux-firmware (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in linux-firmware (Ubuntu):
status: New → Fix Committed

Hello Hui, or anyone else affected,

Accepted linux-firmware into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/1.183.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Timo Aaltonen (tjaalton) wrote :

Hello Hui, or anyone else affected,

Accepted linux-firmware into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/1.173.19 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Rex Tsai (chihchun) wrote :

The microphone is broken on the certfieid Dell Inspiron 7591, Dell Inspiron 7590, and Dell Inspiron 3590. due to missing this new firmware.

We need to verify and land the solution ASAP.

Changed in linux-firmware (Ubuntu Bionic):
importance: Undecided → Critical
Changed in linux-firmware (Ubuntu):
importance: High → Critical
Changed in oem-priority:
importance: Undecided → Critical
assignee: nobody → Kai-Chuan Hsieh (kchsieh)
tags: added: verification-done-bionic
Kai-Chuan Hsieh (kchsieh) wrote :

Verify pass on Inspiron 7591.

Rex Tsai (chihchun) on 2020-07-07
tags: added: oem-priority
Brian Murray (brian-murray) wrote :

Could some details regarding the testing undertaken be provided? It is not enough to just change a bug tag from verification-need to verification-done.

tags: added: verification-needed-eoan
Changed in linux-firmware (Ubuntu Bionic):
status: Fix Committed → Incomplete
Hui Wang (hui.wang) wrote :

On a Dell cfl machine, install the eoan on it, boot the system and check the dmesg, the sof driver print a error log "can't find the firmware sof-cfl.ri" and audio doesn't work after boot.

enable the proposed, sudo apt-get update;sudo apt install linux-firmware, now the linux-firmware 1.183.6 is installed. reboot the system, check the dmesg, there is no that error anymore, and after boot, the audio works well.

verified it works on eoan

Hui Wang (hui.wang) wrote :

On a Dell cfl machine, install the bionic on it, boot the system and check the dmesg, the sof driver print a error log "can't find the firmware sof-cfl.ri" and audio doesn't work after boot.

enable the proposed, sudo apt-get update;sudo apt install linux-firmware, now the linux-firmware 1.173.19 is installed. reboot the system, check the dmesg, there is no that error anymore, and after boot, the audio works well.

verified it works on bionic

tags: added: verification-done-eoan
removed: verification-needed-eoan
Kai-Chuan Hsieh (kchsieh) wrote :

Test Dell Inspiron 7591 on bionic.

1. sudo apt dist-upgrade
2. sudo reboot

not alsa card, show 'Dummy output' in gnome-control-center

4. add proposed source list
5. sudo apt update
6. sudo apt install linux-firmware
7. sudo reboot
8. sound card is appeared in gnome-control-center

[test]

speaker + DMIC: ok
headset input + headset output: ok

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.183.6

---------------
linux-firmware (1.183.6) eoan; urgency=medium

  * Missing sof-cfl.ri symbol link for Bionic and Eoan (LP: #1875263)
    - SAUCE: linux-firmware: symbol link sof-cfl.ri and sof-cfl.ldc

 -- Seth Forshee <email address hidden> Wed, 17 Jun 2020 07:48:49 -0500

Changed in linux-firmware (Ubuntu Eoan):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for linux-firmware has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.173.19

---------------
linux-firmware (1.173.19) bionic; urgency=medium

  * Missing sof-cfl.ri symbol link for Bionic and Eoan (LP: #1875263)
    - SAUCE: linux-firmware: symbol link sof-cfl.ri and sof-cfl.ldc

  * Missing amdgpu navi14 firmware (LP: #1881525)
    - amdgpu: add initial navi14 firmware form 19.30
    - amdgpu: update navi14 firmware for 19.30
    - amdgpu: add new navi14 wks gfx firmware for 19.30
    - amdgpu: update navi14 vcn firmware
    - amdgpu: update navi14 microcode for 19.50

  * Add missing sof-hda-generic-2ch/4ch.tplg symlinks (LP: #1880623)
    - SAUCE: generate 2 symbollinks for sof-hda-generic.tplg

 -- Seth Forshee <email address hidden> Wed, 17 Jun 2020 08:01:09 -0500

Changed in linux-firmware (Ubuntu Bionic):
status: Incomplete → Fix Released
Changed in oem-priority:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers