Intel Bluetooth AX201 HarrisonPeak (HrP) firmware causes system hang in deep suspend

Bug #1850738 reported by You-Sheng Yang on 2019-10-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Yuan-Chen Cheng
linux-firmware (Ubuntu)
Undecided
You-Sheng Yang
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

When system has been paired with BLE devices, bluetooth firmware may fail to suspend, or even hangs the whole system that it can only be rebooted with SysRq keys.

[Reproduce steps]:

1. pair with BLE devices. They doesn't have to stay connected/powered on during the test.

2. make sure Bluetooth is now receiving LE ADV broadcats, which should leave messages in dmesg like:

     Bluetooth: hci0: advertising data len corrected

3. suspend the system a few times. With 5.0.0-1025-oem-osp1 kernel, symptoms would usually appear in <= 5 times.

[Results]

1. one may observed following errors in between the suspend messages:

     PM: pci_pm_suspend(): hcd_pci_suspend+0x0/0x30 returns -16
     PM: dpm_run_callback(): pci_pm_suspend+0x0/0x150 returns -16
     PM: Device 0000:00:14.0 failed to suspend async: error -16
     PM: Some devices failed to suspend, or early wake event detected

   where 0000:00:14.0 is the xHCI Usb hub.

2. with or without above error messages appear first, system may hang and leave only "PM: suspend entry (deep)" in the syslog.

[Notes]

* kernels newer than v5.2.1, inclusive of latest v5.4-rc5, still have those PM suspend errors, but they doesn't seem to cause system block. Instead, they may resume immediately.

* this was found on one platform with Intel Dual Band Wireless AC 9462 [8086:02f0] subsystem id [8086:42a4], linux-firmware 1.173.11 with intel/ibt-19-0-0.sfi REL0282. However, it's not reproducible on another platform with same hw/fw/kernel configuration.

kernel: [ 78.136285] PM: suspend entry (deep)
kernel: [ 78.139836] Filesystems sync: 0.003 seconds
kernel: [ 78.140461] Freezing user space processes ... (elapsed 0.002 seconds) done.
kernel: [ 78.142669] OOM killer disabled.
kernel: [ 78.142669] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
kernel: [ 78.143875] printk: Suspending console(s) (use no_console_suspend to debug)
kernel: [ 78.335256] sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
kernel: [ 78.457675] sof-audio-pci 0000:00:1f.3: firmware boot complete
kernel: [ 78.460486] PM: pci_pm_suspend(): hcd_pci_suspend+0x0/0x30 returns -16
kernel: [ 78.460494] PM: dpm_run_callback(): pci_pm_suspend+0x0/0x150 returns -16
kernel: [ 78.460497] PM: Device 0000:00:14.0 failed to suspend async: error -16
kernel: [ 78.567263] PM: Some devices failed to suspend, or early wake event detected
kernel: [ 78.580871] sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
kernel: [ 78.713018] sof-audio-pci 0000:00:1f.3: firmware boot complete
kernel: [ 78.733982] Bluetooth: hci0: advertising data len corrected
kernel: [ 78.792707] nvme nvme0: Shutdown timeout set to 8 seconds
kernel: [ 78.841602] nvme nvme0: 8/0/0 default/read/poll queues
kernel: [ 78.859328] usb 1-4: reset high-speed USB device number 12 using xhci_hcd
kernel: [ 79.113113] Bluetooth: hci0: advertising data len corrected
kernel: [ 79.331948] usb 1-4.4: reset high-speed USB device number 14 using xhci_hcd
kernel: [ 79.432122] Bluetooth: hci0: advertising data len corrected
kernel: [ 79.559747] usb 1-4.1: reset full-speed USB device number 13 using xhci_hcd
kernel: [ 79.887006] acpi LNXPOWER:05: Turning OFF
kernel: [ 79.887265] OOM killer enabled.
kernel: [ 79.887266] Restarting tasks ... done.
kernel: [ 79.926848] PM: suspend exit

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-firmware 1.173.11 [modified: lib/firmware/intel/ibt-19-0-0.sfi lib/firmware/intel/sof/sof-cnl.ri]
ProcVersionSignature: Ubuntu 5.0.0-1025.28-oem-osp1 5.0.21
Uname: Linux 5.0.0-1025-oem-osp1 x86_64
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: u 2037 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Wed Oct 30 22:11:48 2019
Dependencies:

DistributionChannelDescriptor:
 # This is the distribution channel descriptor for the OEM CDs
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-bionic-amd64-20190418-59+beaver-osp1-tywin+X17
InstallationDate: Installed on 2019-10-29 (1 days ago)
InstallationMedia: Ubuntu 18.04 "Bionic" - Build amd64 LIVE Binary 20190418-12:10
MachineType: Dell Inc. Latitude 3311
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-1025-oem-osp1.efi.signed root=UUID=57287512-19f5-4aea-9704-f47ca532c877 ro mem_sleep_default=deep quiet splash vt.handoff=1
RelatedPackageVersions:
 linux-restricted-modules-5.0.0-1025-oem-osp1 N/A
 linux-backports-modules-5.0.0-1025-oem-osp1 N/A
 linux-firmware 1.173.11
SourcePackage: linux-firmware
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/28/2019
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.0.1
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.0.1:bd06/28/2019:svnDellInc.:pnLatitude3311:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct10:cvr:
dmi.product.family: Latitude
dmi.product.name: Latitude 3311
dmi.product.sku: 0971
dmi.sys.vendor: Dell Inc.

You-Sheng Yang (vicamo) wrote :
You-Sheng Yang (vicamo) wrote :

This can be fixed with intel/ibt-19-0-0.sfi REL0313, which is carried by Eoan linux-firmware since version 1.182.

You-Sheng Yang (vicamo) wrote :
Changed in linux-firmware (Ubuntu Bionic):
status: New → In Progress
Changed in linux-firmware (Ubuntu Disco):
status: New → In Progress
Changed in oem-priority:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Yuan-Chen Cheng (ycheng-twn)
tags: added: oem-priority
You-Sheng Yang (vicamo) on 2019-11-08
Changed in linux-firmware (Ubuntu Bionic):
status: In Progress → Fix Committed

Hello You-Sheng, or anyone else affected,

Accepted linux-firmware into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/1.178.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in linux-firmware (Ubuntu Disco):
status: In Progress → Fix Committed
Timo Aaltonen (tjaalton) wrote :

Hello You-Sheng, or anyone else affected,

Accepted linux-firmware into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/1.173.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

You-Sheng Yang (vicamo) wrote :

Verified disco version 1.178.6:

  $ md5sum intel/ibt-19-0-0.sfi
  70364d26dffff619c3dbedf3376ff876 intel/ibt-19-0-0.sfi

Verified bionic version 1.173.12:

  $ md5sum intel/ibt-19-0-0.sfi
  70364d26dffff619c3dbedf3376ff876 intel/ibt-19-0-0.sfi

tags: added: verification-done-bionic verification-done-disco
Changed in oem-priority:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.173.12

---------------
linux-firmware (1.173.12) bionic; urgency=medium

  * Firmware for Radeon RX5700 (navi10) missing / boot failure
    (LP: #1848848)
    - amdgpu: add initial navi10 firmware

  * update-initramfs complains of missing amdgpu firmware files
    (LP: #1850654)
    - amdgpu: add new raven rlc firmware

  * Add RTL8822cu bluetooth support (LP: #1849598)
    - rtl_bt: Add firmware and configuration files for the Bluetooth part of RTL8822CU
    - rtl_bt: Update firmware for BT part of RTL8822C
    - rtl_bt: Update RTL8822C BT FW to V0x098A_94A4
    - rtl_bt: Update configuration file for BT part of RTL8822CU

  * System will auto resume from sleep on receiving LE ADV after paired
    with BT LE devices(LP: #1849779)
    - linux-firmware: Update firmware file for Intel Bluetooth 9260

  * Intel Bluetooth AX201 HarrisonPeak (HrP) firmware causes system hang
    in deep suspend (LP: #1850738)
    - linux-firmware: Update firmware file for Intel Bluetooth AX201

  * Revert the firmware update for sound/sof (LP: #1850739)
    - Revert "UBUNTU: SAUCE: update firmware for sound sof driver to fix hang issues"

  * Add support for Realtek 8723DE wireless adapter (LP: #1780590)
    - rtw88: RTL8723D: add firmware file v48

linux-firmware (1.173.11) bionic; urgency=medium

  * Intel Bluetooth AX201, aka HarrisonPeak (HrP), not supported
    (LP: #1842893)
    - linux-firmware: Add firmware file for Intel Bluetooth AX201
    - linux-firmware: Update firmware file for Intel Bluetooth AX201

  * update firmware for sound sof driver to fix the hang issue on several
    Dell machines (LP: #1847250)
    - SAUCE: update firmware for sound sof driver to fix hang issues

linux-firmware (1.173.10) bionic; urgency=medium

  * Intel Wireless-AC 9462/9560 not supported on ICL (LP: #1835879)
    - linux-firmware: Update firmware file for Intel Bluetooth AX201

  * Bluetooth fails with "Bluetooth: hci0: request failed to create LE
    connection: status 0x0c" message with Kernel 4.20 and up [9df0:0034]
    (LP: #1836467)
    - linux-firmware: Update firmware file for Intel Bluetooth 9560

  * [Intel CyclonePeak] Pairing new BT mouse fails sometimes Edit
    (LP: #1836983)
    - linux-firmware: Update firmware file for Intel Bluetooth 22161

 -- Seth Forshee <email address hidden> Tue, 05 Nov 2019 16:14:05 -0600

Changed in linux-firmware (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.178.6

---------------
linux-firmware (1.178.6) disco; urgency=medium

  * Add RTL8822cu bluetooth support (LP: #1849598)
    - rtl_bt: Update RTL8822C BT FW to V0x098A_94A4
    - rtl_bt: Update configuration file for BT part of RTL8822CU

  * System will auto resume from sleep on receiving LE ADV after paired
    with BT LE devices(LP: #1849779)
    - linux-firmware: Update firmware file for Intel Bluetooth 9260

  * Intel Bluetooth AX201 HarrisonPeak (HrP) firmware causes system hang
    in deep suspend (LP: #1850738)
    - linux-firmware: Update firmware file for Intel Bluetooth AX201

  * Revert the firmware update for sound/sof (LP: #1850739)
    - Revert "UBUNTU: SAUCE: update firmware for sound sof driver to fix hang issues"

  * Add support for Realtek 8723DE wireless adapter (LP: #1780590)
    - rtw88: RTL8723D: add firmware file v48

linux-firmware (1.178.5) disco; urgency=medium

  * Intel Bluetooth AX201, aka HarrisonPeak (HrP), not supported
    (LP: #1842893)
    - linux-firmware: Add firmware file for Intel Bluetooth AX201
    - linux-firmware: Update firmware file for Intel Bluetooth AX201

  * update firmware for sound sof driver to fix the hang issue on several
    Dell machines (LP: #1847250)
    - SAUCE: update firmware for sound sof driver to fix hang issues

linux-firmware (1.178.4) disco; urgency=medium

  * Intel Wireless-AC 9462/9560 not supported on ICL (LP: #1835879)
    - linux-firmware: Update firmware file for Intel Bluetooth AX201

  * Bluetooth fails with "Bluetooth: hci0: request failed to create LE
    connection: status 0x0c" message with Kernel 4.20 and up [9df0:0034]
    (LP: #1836467)
    - linux-firmware: Update firmware file for Intel Bluetooth 9560
    - linux-firmware: Update firmware file for Intel Bluetooth 9560

  * [Intel CyclonePeak] Pairing new BT mouse fails sometimes Edit
    (LP: #1836983)
    - linux-firmware: Update firmware file for Intel Bluetooth 22161

 -- Seth Forshee <email address hidden> Tue, 05 Nov 2019 15:56:27 -0600

Changed in linux-firmware (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for linux-firmware has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in oem-priority:
status: Fix Committed → Fix Released
Changed in linux-firmware (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers