Firmware for Radeon RX5700 (navi10) missing / boot failure

Bug #1848848 reported by Christian Borss on 2019-10-19
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Medium
Seth Forshee
Bionic
Medium
Seth Forshee
Eoan
Medium
Seth Forshee

Bug Description

As an owner of a Radeon RX5700 GPU, I was really looking forward to the Eoan release which includes the Linux Kernel 5.3 and Mesa 19.2 - both with finally Radeon RX5700 (navi10) support. However, upgrading my system from Kubuntu 18.10 (working) via 19.04 (does not boot) to 19.10 resulted in a boot failure. Last message shown on the screen is:

fb0: switching to amdgpudrmfb from EFI VGA

After some research I found that the package linux-firmware does not include the necessary files /lib/firmware/amdgpu/navi10_*. After I manually copied the missing files from the repository git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git, I was able to boot normally.

Please update the package linux-firmware and add the needed firmware.

$ lsb_release -rd
Description: Ubuntu 19.10
Release: 19.10
$ apt-cache policy linux-firmware
linux-firmware:
  Installiert: 1.183
  Installationskandidat: 1.183
  Versionstabelle:
 *** 1.183 500
        500 http://de.archive.ubuntu.com/ubuntu eoan/main amd64 Packages
        500 http://de.archive.ubuntu.com/ubuntu eoan/main i386 Packages
        100 /var/lib/dpkg/status

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-firmware (Ubuntu):
status: New → Confirmed
Seth Forshee (sforshee) wrote :

Thanks for the report. Looks like that firmware was added upstream pretty recently, so we did not notice to get it added to eoan before release. I'll get that pulled in now.

Changed in linux-firmware (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
status: Confirmed → In Progress
Changed in linux-firmware (Ubuntu Bionic):
status: New → Fix Committed
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
Changed in linux-firmware (Ubuntu Eoan):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
status: New → Fix Committed

Hello Christian, or anyone else affected,

Accepted linux-firmware into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/1.183.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in linux-firmware (Ubuntu Bionic):
status: Fix Committed → In Progress
Adam Conrad (adconrad) on 2019-10-22
tags: added: verification-needed-eoan
Christian Borss (rahimtux) wrote :

I can confirm that the new linux-firmware package in eoan-proposed solves this issue. I'm getting some warnings, but the system boots and graphics is fine:

$ sudo update-initramfs -u -k all
update-initramfs: Generating /boot/initrd.img-5.3.0-19-generic
W: Possible missing firmware /lib/firmware/amdgpu/vega20_ta.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/raven_kicker_rlc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navi10_mes.bin for module amdgpu
update-initramfs: Generating /boot/initrd.img-5.3.0-18-generic
W: Possible missing firmware /lib/firmware/amdgpu/vega20_ta.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/raven_kicker_rlc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navi10_mes.bin for module amdgpu

$ apt-cache policy linux-firmware
linux-firmware:
  Installiert: 1.183.1
  Installationskandidat: 1.183.1
  Versionstabelle:
 *** 1.183.1 500
        500 http://de.archive.ubuntu.com/ubuntu eoan-proposed/main amd64 Packages
        500 http://de.archive.ubuntu.com/ubuntu eoan-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1.183 500
        500 http://de.archive.ubuntu.com/ubuntu eoan/main amd64 Packages
        500 http://de.archive.ubuntu.com/ubuntu eoan/main i386 Packages

How can I change the verification tag? Sorry, I'm new to launchpad.

tags: added: verification-done-eoan
removed: verification-needed-eoan
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.183.1

---------------
linux-firmware (1.183.1) eoan; urgency=medium

  * Firmware for Radeon RX5700 (navi10) missing / boot failure
    (LP: #1848848)
    - amdgpu: add initial navi10 firmware

 -- Seth Forshee <email address hidden> Tue, 22 Oct 2019 07:05:09 -0500

Changed in linux-firmware (Ubuntu):
status: In Progress → Fix Released
Adam Conrad (adconrad) wrote :

@sforshee: Given the severity of this issue, and that it's only adding new files, I'm inclined to say we fasttrack the release, but I'd also like to see a follow-up upload that includes the missing files the drivers reference (if they exist), or patch the drivers to stop referencing them (if they don't, and won't).

Any opinions on both those things?

Seth Forshee (sforshee) wrote :

Looks like we have a mix ... vega20_ta.bin and navi10_mes.bin do not exist upstream, while raven_kicker_rlc.bin was recently added. I'll have to inquire about whether or not the missing files will be added upstream.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.183.1

---------------
linux-firmware (1.183.1) eoan; urgency=medium

  * Firmware for Radeon RX5700 (navi10) missing / boot failure
    (LP: #1848848)
    - amdgpu: add initial navi10 firmware

 -- Seth Forshee <email address hidden> Tue, 22 Oct 2019 07:05:09 -0500

Changed in linux-firmware (Ubuntu Eoan):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for linux-firmware has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hello Christian, or anyone else affected,

Accepted linux-firmware into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/1.173.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in linux-firmware (Ubuntu Bionic):
status: In Progress → Fix Committed
Christian Borss (rahimtux) wrote :

I'm afraid I won't be able to test the Bionic version before the end of the year. I don't have a Bionic installation on my machine, and the next free weekend for installing a new system and doing tests like that would be in 2020...
Anybody else, who could give it a try?

Seth Forshee (sforshee) wrote :

I've confirmed that the new files are present with 1.173.12. In combination with the verification for eoan I think this should be sufficient.

tags: added: verification-done-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.173.12

---------------
linux-firmware (1.173.12) bionic; urgency=medium

  * Firmware for Radeon RX5700 (navi10) missing / boot failure
    (LP: #1848848)
    - amdgpu: add initial navi10 firmware

  * update-initramfs complains of missing amdgpu firmware files
    (LP: #1850654)
    - amdgpu: add new raven rlc firmware

  * Add RTL8822cu bluetooth support (LP: #1849598)
    - rtl_bt: Add firmware and configuration files for the Bluetooth part of RTL8822CU
    - rtl_bt: Update firmware for BT part of RTL8822C
    - rtl_bt: Update RTL8822C BT FW to V0x098A_94A4
    - rtl_bt: Update configuration file for BT part of RTL8822CU

  * System will auto resume from sleep on receiving LE ADV after paired
    with BT LE devices(LP: #1849779)
    - linux-firmware: Update firmware file for Intel Bluetooth 9260

  * Intel Bluetooth AX201 HarrisonPeak (HrP) firmware causes system hang
    in deep suspend (LP: #1850738)
    - linux-firmware: Update firmware file for Intel Bluetooth AX201

  * Revert the firmware update for sound/sof (LP: #1850739)
    - Revert "UBUNTU: SAUCE: update firmware for sound sof driver to fix hang issues"

  * Add support for Realtek 8723DE wireless adapter (LP: #1780590)
    - rtw88: RTL8723D: add firmware file v48

linux-firmware (1.173.11) bionic; urgency=medium

  * Intel Bluetooth AX201, aka HarrisonPeak (HrP), not supported
    (LP: #1842893)
    - linux-firmware: Add firmware file for Intel Bluetooth AX201
    - linux-firmware: Update firmware file for Intel Bluetooth AX201

  * update firmware for sound sof driver to fix the hang issue on several
    Dell machines (LP: #1847250)
    - SAUCE: update firmware for sound sof driver to fix hang issues

linux-firmware (1.173.10) bionic; urgency=medium

  * Intel Wireless-AC 9462/9560 not supported on ICL (LP: #1835879)
    - linux-firmware: Update firmware file for Intel Bluetooth AX201

  * Bluetooth fails with "Bluetooth: hci0: request failed to create LE
    connection: status 0x0c" message with Kernel 4.20 and up [9df0:0034]
    (LP: #1836467)
    - linux-firmware: Update firmware file for Intel Bluetooth 9560

  * [Intel CyclonePeak] Pairing new BT mouse fails sometimes Edit
    (LP: #1836983)
    - linux-firmware: Update firmware file for Intel Bluetooth 22161

 -- Seth Forshee <email address hidden> Tue, 05 Nov 2019 16:14:05 -0600

Changed in linux-firmware (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers