QCA6174 slow transfer speeds

Bug #1828304 reported by Kristian Robertsen on 2019-05-08
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 19.04
Package version 1.178

After the upgrade the transfer speeds dropped dramatically.
Download/incoming is affected to a greater degree than upload/outgoing.

A temporary solution as downloading linux-firmware 1.175.3 from cosmic-updates, and overwriting binaries in ath10k/QCA6174/hw3.0/ with the binaries from this package.

Detailed hardware information

lshw -C network

  *-network
       description: Wireless interface
       product: QCA6174 802.11ac Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:6e:00.0
       logical name: wlp110s0
       version: 32
       serial: 6c:0b:84:26:e5:e1
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath10k_pci driverversion=5.0.0-13-generic firmware=WLAN.RM.4.4.1-00079-QCARMSWPZ-1 ip=192.168.10.133 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:142 memory:dc400000-dc5fffff
  *-network
       description: Wireless interface
       product: Wil6200 802.11ad Wireless Network Adapter
       vendor: Wilocity Ltd.
       physical id: 0
       bus info: pci@0000:6f:00.0
       logical name: wlp111s0
       version: 02
       serial: 04:ce:14:07:92:26
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wil6210 driverversion=5.0.0-13-generic firmware=5.2.0.18 latency=0 multicast=yes wireless=IEEE 802.11
       resources: irq:138 memory:dc200000-dc3fffff

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-firmware (Ubuntu):
status: New → Confirmed
Daan van Dijk (daan.van.d) wrote :

I have the same card and experience similar problems. For me downloading is normal, but uploading is significantly slower.

I inspected with iperf3 to a ubuntu server on my network.
It is interesting to note that increasing the parallel streams increased and eventually saturated the network throughput.

The command 'iperf3 -c myserver' yielded:
[ 4] 0.00-10.00 sec 15.3 MBytes 12.8 Mbits/sec 0 sender
[ 4] 0.00-10.00 sec 15.3 MBytes 12.8 Mbits/sec receiver

And the command 'iperf3 -P 40 -c daanserver' yielded:
[SUM] 0.00-10.00 sec 277 MBytes 232 Mbits/sec 91 sender
[SUM] 0.00-10.00 sec 275 MBytes 231 Mbits/sec receiver

lshw -class network
  *-network
       description: Wireless interface
       product: QCA6174 802.11ac Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 32
       serial: 9c:b6:d0:8a:6d:87
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath10k_pci driverversion=4.15.0-58-generic firmware=WLAN.RM.4.4.1-00079-QCARMSWPZ-1 ip=192.168.0.151 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:132 memory:dc000000-dc1fffff
  *-network
       description: Ethernet interface
       physical id: 2
       logical name: enx4865ee185d66
       serial: 48:65:ee:18:5d:66
       size: 10Mbit/s
       capacity: 1Gbit/s
       capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8152 driverversion=v1.09.9 duplex=half link=no multicast=yes port=MII speed=10Mbit/s

Daan van Dijk (daan.van.d) wrote :

It seems that this bug was fixed in Ubuntu 20, which is nice :)

You-Sheng Yang (vicamo) on 2020-06-22
tags: added: hwe-networking-wifi
Changed in linux-firmware (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers