linux-firmware package not available in server installer

Bug #1824852 reported by Matt on 2019-04-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Undecided
Unassigned
subiquity (Ubuntu)
Undecided
Unassigned

Bug Description

I downloaded the latest Ubuntu 18.04 LTS Server image from the website, verified the image and wrote it using Startup Disk Creator to a USB drive. Everything worked just fine up until the Network Configuration section.

It auto-detected both Broadcom NetXtreme II 5708 network adapters and I am given the option to configure the IPv4/6 networking, Create a Bond, etc. No matter which option I try to choose there is no way to move forward from this screen.

Upon checking the dmesg output on tty2, I see the installer failing to find the firmware file bnx2-mips-06-6.2.3.fw which is required for the network adapters. And upon looking further into the issue I discovered this file should be in the linux-firmware package.

Now here is where it gets weird, to bypass the issue of the stuck installer, I simply entered my BIOS and disabled my network adapters and the installer was able to continue and I was able to get the OS installed. After the installer completed I entered the BIOS again and re-enabled the network adapters to begin troubleshooting the issue, and to my surprise on first boot of the freshly installed OS, the network adapters worked without an apt update, upgrade or anything. dpkg shows linux-firmware installed.

Is the linux-firmware package simply missing from the installer image itself?

Also I should note this issue affects the latest daily server image as well, which I also tried.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers