add i915/glk_dmc_ver1_04.bin

Bug #1752507 reported by Timo Aaltonen on 2018-03-01
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Artful
Medium
Seth Forshee

Bug Description

SRU Justification

Impact: New firmware is needed to fix issues with S3 for i915 on Geminilake hardware.

Fix: Add the mising firmware.

Test Case: Test S3 on affected hardware.

Regression Potential: Limited as the firmware is only loaded for specific hardware. Regressions are possible, but none are known, and the new firmware does fix a known problem.

---

Intel Gemini Lake needs DMC firmware to fix some S3 issues on xenial.

Timo Aaltonen (tjaalton) wrote :

looks like artful is missing it too

Changed in linux-firmware (Ubuntu):
status: New → Invalid
Seth Forshee (sforshee) wrote :

For xenial the firmware has been added as part of bug 1763823, "Update firmware for 18.04 hwe kernel." Still needed for artful, and since there's no way to dup only the xenial task I'm marking it fix committed.

Changed in linux-firmware (Ubuntu Xenial):
status: New → Fix Committed
Changed in linux-firmware (Ubuntu Artful):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
status: New → Triaged
Seth Forshee (sforshee) on 2018-04-24
description: updated
Changed in linux-firmware (Ubuntu Artful):
status: Triaged → Fix Committed
Linuxium (linuxium.com.au) wrote :

Note that actually loading the firmware by the kernel is affected by https://bugs.launchpad.net/intel/+bug/1760545 or requires (currently) manually updating the kernel's initramfs with the added firmware.

Hello Timo, or anyone else affected,

Accepted linux-firmware into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/1.169.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Linuxium (linuxium.com.au) wrote :

Tested and verified using cod/tip/drm-tip/2018-05-04 mainline build with upgraded linux-firmware from xenial-proposed:

ubuntu@ubuntu:~$ dmesg | egrep 'Linux version|DMI:|i915'
[ 0.000000] Linux version 4.17.0-994-generic (kernel@kathleen) (gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)) #201805040859 SMP Fri May 4 09:01:29 UTC 2018
[ 0.000000] DMI: Intel Corporation NUC7CJYS/NUC7JYB, BIOS JYGLKCPX.86A.0024.2017.1229.1454 12/29/2017
[ 1.770743] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
[ 1.771295] [drm] Finished loading DMC firmware i915/glk_dmc_ver1_04.bin (v1.4)
[ 1.774763] [drm] Initialized i915 1.6.0 20180413 for 0000:00:02.0 on minor 0
[ 1.858866] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[ 11.746756] snd_hda_intel 0000:00:0e.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
ubuntu@ubuntu:~$

Linuxium (linuxium.com.au) wrote :

ubuntu@ubuntu:~$ ls -l /lib/firmware/i915/glk_dmc_ver1_04.bin
-rw-r--r-- 1 root root 8800 Apr 24 15:28 /lib/firmware/i915/glk_dmc_ver1_04.bin
ubuntu@ubuntu:~$ dpkg -s linux-firmware
Package: linux-firmware
Status: install ok installed
Priority: optional
Section: misc
Installed-Size: 223599
Maintainer: Ubuntu Kernel Team <email address hidden>
Architecture: all
Multi-Arch: foreign
Version: 1.157.18
Replaces: atmel-firmware, linux-firmware-snapdragon (<= 1.2-0ubuntu1), linux-restricted-common
Provides: atmel-firmware
Breaks: linux-firmware-snapdragon (<= 1.2-0ubuntu1)
Conflicts: atmel-firmware
Description: Firmware for Linux kernel drivers
 This package provides firmware used by Linux kernel drivers.
ubuntu@ubuntu:~$

Linuxium (linuxium.com.au) wrote :

ALso tested and verified using cod/tip/drm-tip/2018-05-04 mainline build with upgraded linux-firmware from artful-proposed:

ubuntu@ubuntu:~$ egrep 'Linux version|DMI:|i915' /tmp/artful-dmesg.txt
[ 0.000000] Linux version 4.17.0-994-generic (kernel@kathleen) (gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)) #201805040859 SMP Fri May 4 09:01:29 UTC 2018
[ 0.000000] DMI: Intel Corporation NUC7CJYS/NUC7JYB, BIOS JYGLKCPX.86A.0024.2017.1229.1454 12/29/2017
[ 2.418477] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
[ 2.419032] [drm] Finished loading DMC firmware i915/glk_dmc_ver1_04.bin (v1.4)
[ 2.422525] [drm] Initialized i915 1.6.0 20180413 for 0000:00:02.0 on minor 0
[ 2.525424] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[ 11.766420] snd_hda_intel 0000:00:0e.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 38.844791] rtsx_pci_ms snd memstick mei_me mei soundcore shpchp ir_rc6_decoder rc_rc6_mce ite_cir rc_core mac_hid parport_pc ppdev lp parport ip_tables x_tables autofs4 isofs nls_iso8859_1 dm_mirror dm_region_hash dm_log pwm_lpss_platform pwm_lpss overlay hid_logitech_hidpp hid_logitech_dj hid_generic usbhid uas usb_storage mmc_block rtsx_pci_sdmmc i915 psmouse i2c_algo_bit sdhci_pci drm_kms_helper cqhci sdhci syscopyarea sysfillrect r8169 rtsx_pci sysimgblt mii fb_sys_fops drm i2c_hid ahci hid libahci video pinctrl_geminilake pinctrl_intel wmi
ubuntu@ubuntu:~$

Linuxium (linuxium.com.au) wrote :

ubuntu@ubuntu:~$ ls -l /lib/firmware/i915/glk_dmc_ver1_04.bin
-rw-r--r-- 1 root root 8800 Apr 24 15:28 /lib/firmware/i915/glk_dmc_ver1_04.bin
ubuntu@ubuntu:~$ dpkg -s linux-firmware
Package: linux-firmware
Status: install ok installed
Priority: optional
Section: misc
Installed-Size: 210549
Maintainer: Ubuntu Kernel Team <email address hidden>
Architecture: all
Multi-Arch: foreign
Version: 1.169.4
Replaces: atmel-firmware, linux-firmware-snapdragon (<= 1.2-0ubuntu1), linux-restricted-common
Provides: atmel-firmware
Breaks: linux-firmware-snapdragon (<= 1.2-0ubuntu1)
Conflicts: atmel-firmware
Description: Firmware for Linux kernel drivers
 This package provides firmware used by Linux kernel drivers.
ubuntu@ubuntu:~$

Linuxium (linuxium.com.au) wrote :

@Łukasz Zemczak (sil2100)

Re: "If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful."

If there is a "tag" then "verification-needed-artful -> verification-done-artful".

Timo Aaltonen (tjaalton) wrote :

looks like the -needed tags were missing..

tags: added: verification-done-artful verification-done-xenial
Changed in linux-firmware (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers