Add i915/skl_guc_ver6.bin to linux-firmware in Trusty

Bug #1642709 reported by Justin King-Lacroix
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Fix Released
Undecided
Unassigned
Trusty
Fix Released
Medium
Seth Forshee

Bug Description

Linux-firmware is missing the following i915 firmware files, required by the i915 driver in 4.4.0-47-generic:

$ update-initramfs -k 4.4.0-47-generic -c
W: Possible missing firmware /lib/firmware/i915/kbl_dmc_ver1.bin for module i915_bpo
W: Possible missing firmware /lib/firmware/i915/skl_guc_ver6.bin for module i915_bpo

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-firmware (Ubuntu):
status: New → Confirmed
Revision history for this message
Justin King-Lacroix (justinkl) wrote :

Bump. Help?

Revision history for this message
Brad Figg (brad-figg) wrote :

Those are just warnings "W: Possible" that can be ignored.

Revision history for this message
Justin King-Lacroix (justinkl) wrote :

They shouldn't be warnings. Their result is that the firmware doesn't end up in the initramfs. The implications of this are discussed at length in LP #1496163.

Revision history for this message
Philipp Kern (pkern) wrote :

Adding Timo explicitly who said in https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1624164/comments/5 that kbl_dmc is optional and for power saving, but skl_guc_ver6 is actually needed on Skylake. Skylake devices are what we have and which don't properly work without the firmware.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

How does adding skl_guc help on your machines? I could've worded that comment a bit differently. Note that KBL is not supported on trusty.

Revision history for this message
Seth Forshee (sforshee) wrote :

These files are actually included in the latest linux-firmware for xenial (1.157.5), so I'm marking this fix released. Note however that the kbl_dmc firmware is actually causing regressions on some kabylake systems, so I'm probably going to have to remove it temporarily until those are resolved.

Changed in linux-firmware (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Justin King-Lacroix (justinkl) wrote :

The problem is that this hasn't yet been backported to Trusty, which is what we care about. It's therefore not "fix released" for Trusty...

Revision history for this message
Justin King-Lacroix (justinkl) wrote :

(This is for Skylake laptops, so agreed that the KBL warnings aren't relevant.)

Changed in linux-firmware (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Seth Forshee (sforshee) wrote :

Ah, sorry, I saw 4.4 and assumed xenial. You're right that we haven't added those files in trusty. That should be no problem.

Changed in linux-firmware (Ubuntu):
status: Confirmed → Fix Released
Changed in linux-firmware (Ubuntu Trusty):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
status: New → Confirmed
Seth Forshee (sforshee)
summary: - linux-firmware on Trusty is missing i915 binaries
+ Add i915/skl_guc_ver6.bin to linux-firmware in Trusty
Changed in linux-firmware (Ubuntu Trusty):
status: Confirmed → In Progress
Seth Forshee (sforshee)
Changed in linux-firmware (Ubuntu Trusty):
status: In Progress → Fix Committed
Revision history for this message
Justin King-Lacroix (justinkl) wrote :

Many thanks!

Revision history for this message
Justin King-Lacroix (justinkl) wrote :

Any idea when this will be released?

Revision history for this message
Seth Forshee (sforshee) wrote :

I don't know when it will be released, but it is unusual that the package hasn't yet hit trust-proposed. I'll see if I can get someone to take care of that.

Revision history for this message
Adam Conrad (adconrad) wrote : Please test proposed package

Hello Justin, or anyone else affected,

Accepted linux-firmware into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/1.127.23 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Justin King-Lacroix (justinkl) wrote :

I can confirm that this contains the appropriate firmware file.

Revision history for this message
Justin King-Lacroix (justinkl) wrote :

s/appropriate/requested/

tags: added: verification-done
Revision history for this message
Justin King-Lacroix (justinkl) wrote :

Hi guys, any idea when this will be released?

Revision history for this message
Chris Halse Rogers (raof) wrote : Update Released

The verification of the Stable Release Update for linux-firmware has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.127.23

---------------
linux-firmware (1.127.23) trusty; urgency=medium

  * Trigger update-initramfs following linux-firmware install (LP: #1646197)
    - UBUNTU: Add postinst script to update initrds

  * Add i915/skl_guc_ver6.bin to linux-firmware in Trusty (LP: #1642709)
    - linux-firmware/i915: Major GuC release for Skylake - ver 6.1

 -- Seth Forshee <email address hidden> Thu, 01 Dec 2016 15:36:41 -0600

Changed in linux-firmware (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers