Possible missing firmware /lib/firmware/i915/kbl_dmc_ver1.bin for module i915_bpo

Bug #1624164 reported by Michael Schurter on 2016-09-15
134
This bug affects 24 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Xenial
Medium
Seth Forshee
linux-firmware (Ubuntu)
Undecided
Abhinav Jawa
Xenial
Medium
Unassigned

Bug Description

SRU Justification

Impact: i915_bpo requests some optional firmware which is not present in xenial due to causing regressions on some hardware. This produces a warning when generating the initrds.

Fix: Remove the MODULE_FIRMWARE statement for this driver, thus removing it from the firmware's modinfo and eliminating the warning.

Regression Potential: Virtually no risk of regression since it only affects the modinfo section of the kernel module and not the runtime behavior.

---

Also: Possible missing firmware /lib/firmware/i915/skl_guc_ver6.bin for module i915_bpo

Possible missing firmware /lib/firmware/i915/kbl_dmc_ver1.bin for module i915_bpo

Ubuntu 16.04 Xenial

Packages:

ii linux-firmware 1.157.3 all Firmware for Linux kernel drivers
ii linux-image-generic 4.4.0.36.38 amd64 Generic Linux kernel image

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-firmware (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

both are available on yakkety, so marking fixed there

Changed in linux-firmware (Ubuntu):
status: Confirmed → Fix Released
Seth Forshee (sforshee) wrote :

Both were upstreamed well after 4.4 was released. I really wish they'd push out firmware more in sync with kernel support.

@tjaalton: We have an older version of the skl_* firmware; I assume the driver will fall back to using that. Is there a reason we want the update?

However we don't have any kbl_* firmware files, so I assume adding that one will enable more hardware?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-firmware (Ubuntu Xenial):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

i915_bpo is from 4.7, and it's the first release that can use kbl_dmc, so it's unsurprising to not have it in xenial yet.. and it's not a must-have, but should enable lower power states. kbl_guc is not used yet nor is it upstream so can be skipped for now

skl_dmc seems uptodate, _guc should be updated to ver6 to match i915_bpo which is used on SKL.

description: updated
yon (thornyon) on 2016-11-15
Changed in linux-firmware (Ubuntu Xenial):
status: Confirmed → New
status: New → Confirmed
status: Confirmed → New
status: New → Confirmed
status: Confirmed → Fix Released
Simon Déziel (sdeziel) wrote :

@thornyon, why did you marked this bug as fix released? As far as I can see, linux-firmware still doesn't ship kbl_dmc_ver1.bin.

I'd like to benefit from lower power usage that should come with this firmware.

knope (yesilikewaffles) wrote :

- confirming on update today, this (W)arn still exists:
`Possible missing firmware /lib/firmware/i915/kbl_dmc_ver1.bin for module i915_bpo`

William Ricker (bill-n1vux) wrote :

This continues to affect LTS Xenial. So i confirm @sdeziel and @yesilikewaffles comments #6 & #7, this is NOT fixed in XENIAL, @thornyon

Seth Forshee (sforshee) wrote :

The kbl_dmc firmware had been added in xenial at one point but was removed because it caused a regression. Since the firmware is optional we can make it so that the module won't cause this message to be generated when regenerating the initramfs. Therefore I'll mark this as "won't fix" for linux-firmware and add a linux task.

Changed in linux-firmware (Ubuntu Xenial):
importance: Undecided → Medium
status: Fix Released → Won't Fix
Changed in linux (Ubuntu):
status: New → Fix Released
status: Fix Released → Invalid
Changed in linux (Ubuntu Xenial):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
status: New → In Progress
Seth Forshee (sforshee) on 2017-02-13
description: updated
Changed in linux (Ubuntu Xenial):
status: In Progress → Fix Committed
William Ricker (bill-n1vux) wrote :

Thanks for the update. Removed because regression makes sense for why it said the Fix was in but it wasn't seen in the field! Mystery resolved.

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'. If the problem still exists, change the tag 'verification-needed-xenial' to 'verification-failed-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial
Simon Déziel (sdeziel) wrote :

4.4.0-65.86 from -proposed produces no warning, thanks.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :
Download full text (14.5 KiB)

This bug was fixed in the package linux - 4.4.0-65.86

---------------
linux (4.4.0-65.86) xenial; urgency=low

  * linux: 4.4.0-65.86 -proposed tracker (LP: #1667052)

  [ Stefan Bader ]
  * Upgrade Redpine RS9113 driver to support AP mode (LP: #1665211)
    - SAUCE: Redpine driver to support Host AP mode

  * NFS client : permission denied when trying to access subshare, since kernel
    4.4.0-31 (LP: #1649292)
    - fs: Better permission checking for submounts

  * [Hyper-V] SAUCE: pci-hyperv fixes for SR-IOV on Azure (LP: #1665097)
    - SAUCE: PCI: hv: Fix wslot_to_devfn() to fix warnings on device removal
    - SAUCE: pci-hyperv: properly handle pci bus remove
    - SAUCE: pci-hyperv: lock pci bus on device eject

  * [Hyper-V/Azure] Please include Mellanox OFED drivers in Azure kernel and
    image (LP: #1650058)
    - net/mlx4_en: Fix bad WQE issue
    - net/mlx4_core: Fix racy CQ (Completion Queue) free
    - net/mlx4_core: Fix when to save some qp context flags for dynamic VST to VGT
      transitions
    - net/mlx4_core: Avoid command timeouts during VF driver device shutdown

  * Xenial update to v4.4.49 stable release (LP: #1664960)
    - ARC: [arcompact] brown paper bag bug in unaligned access delay slot fixup
    - selinux: fix off-by-one in setprocattr
    - Revert "x86/ioapic: Restore IO-APIC irq_chip retrigger callback"
    - cpumask: use nr_cpumask_bits for parsing functions
    - hns: avoid stack overflow with CONFIG_KASAN
    - ARM: 8643/3: arm/ptrace: Preserve previous registers for short regset write
    - target: Don't BUG_ON during NodeACL dynamic -> explicit conversion
    - target: Use correct SCSI status during EXTENDED_COPY exception
    - target: Fix early transport_generic_handle_tmr abort scenario
    - target: Fix COMPARE_AND_WRITE ref leak for non GOOD status
    - ARM: 8642/1: LPAE: catch pending imprecise abort on unmask
    - mac80211: Fix adding of mesh vendor IEs
    - netvsc: Set maximum GSO size in the right place
    - scsi: zfcp: fix use-after-free by not tracing WKA port open/close on failed
      send
    - scsi: aacraid: Fix INTx/MSI-x issue with older controllers
    - scsi: mpt3sas: disable ASPM for MPI2 controllers
    - xen-netfront: Delete rx_refill_timer in xennet_disconnect_backend()
    - ALSA: seq: Fix race at creating a queue
    - ALSA: seq: Don't handle loop timeout at snd_seq_pool_done()
    - drm/i915: fix use-after-free in page_flip_completed()
    - Linux 4.4.49

  * NFS client : kernel 4.4.0-57 crash with nfsv4 enries in /etc/fstab
    (LP: #1650336)
    - SUNRPC: fix refcounting problems with auth_gss messages.

  * [0bda:0328] Card reader failed after S3 (LP: #1664809)
    - usb: hub: Wait for connection to be reestablished after port reset

  * linux-lts-xenial 4.4.0-63.84~14.04.2 ADT test failure with linux-lts-xenial
    4.4.0-63.84~14.04.2 (LP: #1664912)
    - SAUCE: apparmor: fix link auditing failure due to, uninitialized var

  * ibmvscsis: Add SGL LIMIT (LP: #1662551)
    - ibmvscsis: Add SGL limit

  * [Hyper-V] Bug fixes for storvsc (tagged queuing, error conditions)
    (LP: #1663687)
    - scsi: storvsc: Enable tracking of queue depth
    - scsi: storvsc: Remove the ...

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
Chico Miraglia (miraglia) wrote :

Problem persists in kernel 4.10 (XUbuntu) or Ubuntu 16.04.03, with same warning messages.

It is unwise, in my opinion, to recommend developer options in Synaptics to the general public. Just put the required fixes in the main repository!!

Cheers,

Chico Miraglia

Abhinav Jawa (jawa29) on 2017-10-16
Changed in linux-firmware (Ubuntu):
assignee: nobody → Abhinav Jawa (jawa29)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers