iwlwifi 3160 regression - wifi is unstable, bluetooth does not work anymore

Bug #1568815 reported by Michele Mattioni on 2016-04-11
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Undecided
Unassigned

Bug Description

With the latest upgrade, the wireless card it is not working anymore as it should.

The problems:

1. Wireless connection signal is extremely weak. Other laptop in the same room can connect to the wireless with full signal.
2. The bluetooth is not anymore operational. No Bluetooth hardware component is found.
I had successfully used the bluetooth on this laptop, connecting it to a bluetooth mouse before with no problem.

This is the output of lshw

```
mattions@apollo:~$ sudo lshw -C network
[sudo] password for mattions:
  *-network
       description: Wireless interface
       product: Wireless 3160
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlp1s0
       version: 83
       serial: 78:0c:b8:6b:57:ec
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.2.0-35-generic firmware=25.17.12.0 ip=192.168.1.35 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:127 memory:df000000-df001fff

```

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: linux-firmware 1.149.3
ProcVersionSignature: Ubuntu 4.2.0-35.40-generic 4.2.8-ckt5
Uname: Linux 4.2.0-35-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Apr 11 12:29:55 2016
Dependencies:

EcryptfsInUse: Yes
InstallationDate: Installed on 2016-01-27 (74 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
PackageArchitecture: all
SourcePackage: linux-firmware
UpgradeStatus: No upgrade log present (probably fresh install)

Michele Mattioni (mattions) wrote :
Michele Mattioni (mattions) wrote :

The problem is still here with me.
I even tried to swap the wireless card with a new one, thinking that the old one was faulty, but I get the same result.

Can I get more information to make the debug easier?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-firmware (Ubuntu):
status: New → Confirmed
Herminio (herminio-hernandezjr) wrote :

I am having similar issues on 16.04. My wifi keeps dropping and I have to select my SSID to reconnect multiple times a day. I am seeing errors in journalctl that show a firmware error. (attahcing part of journalctl)

hhernandez@hhernandez-Precision-M4800:~$ sudo lshw -C network
[sudo] password for hhernandez:
  *-network
       description: Ethernet interface
       product: Ethernet Connection I217-LM
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eno1
       version: 04
       serial: 20:47:47:be:e2:a3
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.13-3 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:28 memory:f7100000-f711ffff memory:f7139000-f7139fff ioport:f040(size=32)
  *-network
       description: Wireless interface
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: bb
       serial: ac:fd:ce:87:67:3e
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-22-generic firmware=16.242414.0 ip=192.168.254.38 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:32 memory:f7000000-f7001fff

Herminio (herminio-hernandezjr) wrote :

ok I have move from 2.4ghz to 5ghz band and my signal has not dropped once.

Munish Kumar (itstyro) wrote :

@Herminio
My laptop bluetooth is working fine but wifi signals are quite low.

I didn't get what needs to be updated from 2.4ghz to 5ghz?

Thank you

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers