using wacom tablet crashes the whole system in 16.04

Bug #1548581 reported by Chris on 2016-02-23
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Undecided
Unassigned

Bug Description

Just tried the daily build and - as I expected, because I tried many times - if I try to use my Wacom tablet, the whole system freezes.

I'm not sure what it is, maybe it gets a kernel panic or it's because X.org, but I can't even restart the session, just if I turn off my laptop by pressing the power button for seconds, because after trying to use the graphics tablet, even the mouse and keyboard are frozen. I reproduced this many times and I got the same results every single time. But this doesn't even need to be in a drawing software. If I move the pen over the tablet the whole system crashes.

Of course, if I pull it out and after restart I use Ubuntu without it, then everything is normal, but in my opinion this is a heavily serious issue, considering that we are talking about an LTS release, which has to mean rock-solid stability over non-LTS distros. Now I'm in Linux Mint, because this happens since 15.10 and Mint is the only Linux distribution which has full support for my graphics and art project workflow. Whatever they do, it just works, but Ubuntu is seriously unstable these days.

Here are my outputs:
Linux CNB-NoteBook-Pro 4.4.0-11-generic #26-Ubuntu SMP Sat Mar 5 14:25:21 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Ubuntu 4.4.0-11.26-generic 4.4.4

dmesg.log -> http://pastebin.com/WjLQpbvk
lspci-vvnn.log -> http://pastebin.com/6aYymGAG

Chris (chris020891) on 2016-02-23
description: updated
description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1548581/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
yuehan (nae-ioan) wrote :

Hi,

It seems like a driver issue.

affects: ubuntu → linux-firmware (Ubuntu)
yuehan (nae-ioan) wrote :

Hi,

As this looks like a driver issue, please follow one of this guides to provide more information about your problem :

https://wiki.ubuntu.com/Kernel/Bugs
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies

As you can see from the links, as a last resort, at a minimum, your bug report should contain the output of the following commands:

$ uname -a > uname-a.log
$ cat /proc/version_signature > version.log
$ dmesg > dmesg.log
$ sudo lspci -vvnn > lspci-vvnn.log

Changed in linux-firmware (Ubuntu):
status: New → Incomplete

Lot's of users have issue with kernel 4.4 and wacom tablets, my wacom freezes my Arch-linux and nothing, even kernel panic message wont get into my journal logs, it just ok and then everything freezes, cant tty cant nothing, you are not alone, my wacom works allright on 4.3 kernel, so you might want to try that series or if your tablet is older, try kernel 4.1 series. We can only hope it will be fixed in 4.5 (as many wacom devs said it has been merged to it), I would appretiate if you could test 4.5 rc4 ? maybe to observe the wacom behavior and report back? I am far from my machine and if you will get freezes on 4.5rc4 kernel series and freezes continue I would try to push devs harder to fix the driver.

---

It's not relevant but heres my output w/o plugged wacom
Linux version 4.4.2-1-MANJARO (builduser@manjaro) (gcc version 5.3.0 (GCC) ) #1 SMP PREEMPT Thu Feb 18 00:17:59 UTC 2016
http://pastebin.com/Ca8jisP7 - dmesg
http://pastebin.com/h9GUhG9z - lspci

Chris (chris020891) wrote :

I've updated my description with my info. I hope, now there will be some kind of solution. Thanks in advance!

description: updated
Chris (chris020891) on 2016-03-24
Changed in linux-firmware (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-firmware (Ubuntu):
status: New → Confirmed
Jason Gerecke (killertofu) wrote :

I'm aware of two Wacom bugs that can cause 4.4 to lockup, both of which have been recently fixed. It would be very good to know if you're experiencing either. Please let us know what Wacom device you are using that causes these lockups.

Issue [1] sounds most like the symptoms you describe and affects multiple tablets (Primarily the newest "Intuos" tablets with model numbers CTL-490, CTH-490, CTL-690, and CTH-690). A fix is included in Linux 4.4.2 as well as the linuxwacom project's backported input-wacom 0.30.2 driver. Updating the kernel or installing the input-wacom driver should narrow down if this is the problem. You might try SSHing into your system prior to the lockup, running `sudo journalctl -f`, and then bringing the pen into prox to trigger the lockup -- if you're lucky, after a short time you'll see a kernel LOCKUP message printed out that you can compare to the bug report.

Issue [2] I believe is specific to the CTL-471 and CTL-671. The fix has been sent for inclusion in later 4.4 releases but has not yet (as far as I'm aware) yet been accepted.

[1]: https://sourceforge.net/p/linuxwacom/bugs/293/
[2]: https://bugzilla.redhat.com/show_bug.cgi?id=1317116

Chris (chris020891) wrote :

It's issue [2]: I have exactly Wacom One S.
So, in this case the patch must arrive at some point in the kernel, right? Then I wait, until something happens. I have a backup tablet (from Genius), but it doesn't have the same precision. Anyways, thanks for the update!

Dusan (dulex123) wrote :

I noticed today this same bug. It is interesting that only plugging the tablet doesn't crash the system, but when I move tablet pen to the field (generate input) it immediately crashes and only reboot can unfreeze it.

Worked flawlessly on 15.10.

CTL-471 Tablet
Ubuntu Gnome 16.04

Chris (chris020891) wrote :

Tried to see if a new version of the kernel is patched and 4.4.8 does the job. Since it's a point release of the LTS version, I don't understand why is Ubuntu still on 4.4.0, when it's the stable branch of the Linux kernel. Or...graphics designers and illustrators don't worth to use Ubuntu? This is a serious bug and it's still not yet decided if it's gonna be patched? Are you kidding me?!?!

Chris (chris020891) wrote :

Just pulled down from the Mainline FTP Linux Kernel 4.4.17, my system works and the problem is solved...manually. Is this still happening? Is Ubuntu still packaged with 4.4.0? Why does a fresh install of an LTS distro contain a bug like this? And what if somebody else (a beginner user) runs into it, who doesn't know how to solve issues?

It's confirmed for months but nothing has changed.

Chris (chris020891) wrote :

Any progress on fixing this?

Vinodkumar K N (vinodkumarhtm) wrote :

I am also having this crash.

Affects me too:
Linux till-Lenovo-B50-30 4.4.0-141-generic #167-Ubuntu SMP Wed Dec 5 10:40:15 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.