Bluetooth (Atheros AR3012) does not work

Bug #1542743 reported by io on 2016-02-06
132
This bug affects 24 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-firmware (Ubuntu)
Medium
Unassigned

Bug Description

Since some Versions of Linux Kernel and Ubuntu Releases this problem exists.

I am now running ubuntu 16.04 prerelease and still have the same problem.

Bluetooth does not work with the atheros device on msi gt 72 2qd notebook.

WORKAROUND FOR [0CF3:3004] DEVICE ONLY with kernel 4.4:

sudo apt install dkms
wget https://launchpad.net/~hanipouspilot/+archive/ubuntu/bluetooth/+files/btusb-lp1542743-dkms_0.1_all.deb
sudo dpkg -i btusb-lp1542743-dkms_0.1_all.deb

FOR KERNEL 4.8 A WORKAROUND DKMS DEB IS

https://launchpad.net/~hanipouspilot/+archive/ubuntu/bluetooth/+files/btusb-lp1542743-dkms_0.2~4.8_all.deb

dmesg | grep Bluetooth:
[ 2.655360] Bluetooth: Core ver 2.21
[ 2.655373] Bluetooth: HCI device and connection manager initialized
[ 2.655377] Bluetooth: HCI socket layer initialized
[ 2.655379] Bluetooth: L2CAP socket layer initialized
[ 2.655385] Bluetooth: SCO socket layer initialized
[ 6.612790] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 6.612794] Bluetooth: BNEP filters: protocol multicast
[ 6.612798] Bluetooth: BNEP socket layer initialized
[ 9.016880] Bluetooth: Patch file not found ar3k/AthrBT_0x00000200.dfu
[ 9.016882] Bluetooth: Loading patch file failed

hwinfo | grep Bluetooth:
<6>[ 6.612790] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
  <6>[ 6.612794] Bluetooth: BNEP filters: protocol multicast
  <6>[ 6.612798] Bluetooth: BNEP socket layer initialized
  <3>[ 9.016880] Bluetooth: Patch file not found ar3k/AthrBT_0x00000200.dfu
  <3>[ 9.016882] Bluetooth: Loading patch file failed
60: USB 00.0: 11500 Bluetooth Device
  Model: "Atheros AR3012 Bluetooth 4.0"
  Device: usb 0x3004 "AR3012 Bluetooth 4.0"

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: bluez 5.36-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-2.16-generic 4.4.0
Uname: Linux 4.4.0-2-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
ApportVersion: 2.19.4-0ubuntu2
Architecture: amd64
Date: Sun Feb 7 00:38:04 2016
ExecutablePath: /usr/lib/bluetooth/bluetoothd
InstallationDate: Installed on 2015-10-24 (105 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
InterestingModules: bnep btusb bluetooth
MachineType: Micro-Star International Co., Ltd. GT72 2QD
ProcEnviron:
 LANG=de_DE.UTF-8
 PATH=(custom, no user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-2-generic root=UUID=f7880b23-39b5-423a-bdbf-62b111783450 ro quiet splash
SourcePackage: bluez
UpgradeStatus: Upgraded to xenial on 2016-02-02 (4 days ago)
dmi.bios.date: 12/19/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: E1781IMS.10I
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: MS-1781
dmi.board.vendor: Micro-Star International Co., Ltd.
dmi.board.version: REV:0.C
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 10
dmi.chassis.vendor: Micro-Star International Co., Ltd.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrE1781IMS.10I:bd12/19/2014:svnMicro-StarInternationalCo.,Ltd.:pnGT722QD:pvrREV0.C:rvnMicro-StarInternationalCo.,Ltd.:rnMS-1781:rvrREV0.C:cvnMicro-StarInternationalCo.,Ltd.:ct10:cvrToBeFilledByO.E.M.:
dmi.product.name: GT72 2QD
dmi.product.version: REV:0.C
dmi.sys.vendor: Micro-Star International Co., Ltd.
hciconfig:

rfkill:
 0: phy0: Wireless LAN
  Soft blocked: yes
  Hard blocked: no

io (schmidta1) wrote :
Jeremy (wa113y3s) wrote :

This issue will have to be resolved upstream for a permanent solution. The issue is that you have a Rome chipset with a bluetooth device with an ID that matches a pre-Rome bluetooth device. It is possible for you to patch the kernel source to support your device ID as a Rome device

Post #8 from https://bbs.archlinux.org/viewtopic.php?id=201646 is a solution

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
Changed in bluez (Ubuntu):
importance: Undecided → High
importance: High → Medium
Jeremy (wa113y3s) wrote :

io

Can you post the result of

usb-devices | awk '/3004/' RS=

Jeremy (wa113y3s) wrote :

I have the older non-Rome version with the same lsusb ID and my result is

T: Bus=01 Lev=01 Prnt=01 Port=07 Cnt=05 Dev#= 8 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=e0(wlcon) Sub=01 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=0cf3 ProdID=3004 Rev=00.02
S: Manufacturer=Atheros Communications
S: Product=Bluetooth USB Host Controller
S: SerialNumber=Alaska Day 2006
C: #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb
I: If#= 1 Alt= 0 #EPs= 2 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb

io (schmidta1) wrote :

@Jeremy:

usb-devices | awk '/3004/' RS=
T: Bus=01 Lev=02 Prnt=02 Port=02 Cnt=01 Dev#= 3 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=e0(wlcon) Sub=01 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=0cf3 ProdID=3004 Rev=00.01
C: #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=e0(wlcon) Sub=01 Prot=01 Driver=(none)
I: If#= 1 Alt= 0 #EPs= 2 Cls=e0(wlcon) Sub=01 Prot=01 Driver=(none)

greatings
io

Pilot6 (hanipouspilot) wrote :

Jeremy,

Se that there is different revision of these chips.

At the moment kernel does not filter by revision. I will look into it.

Pilot6 (hanipouspilot) wrote :

You can try this

{ USB_DEVICE_VER (0cf3, 3004, 00.02, 00.02), .driver_info = BTUSB_ATH3012 }

{ USB_DEVICE_VER (0cf3, 3004, 00.01, 00.01),.driver_info = BTUSB_QCA_ROME }

Pilot6 (hanipouspilot) wrote :

I am afraid, nothing can be done at kernel level. Atheros made a very poor thing to re-use the PID.

Kernel can't distinguish these adapters. Revision won't help, because we can't be sure that there is no pre-rome adapter with Rev=00.01.

I see the only way to sort this out on a distro level. A DKMS package can be provided for Rome adapters in repositories.

I can write upstream and ask for their opinion, but I doubt that they will commit a patch that will cause a regression for pre-rome users.

Jeremy (wa113y3s) wrote :

This is what Marcel said about it http://www.spinics.net/lists/linux-bluetooth/msg62584.html
It does appear that that device had the Rev=00.01 as does this one https://bbs.archlinux.org/viewtopic.php?id=201646 in post 19

Pilot6 (hanipouspilot) wrote :

We see that it is not easy to resolve because of Qualcomm team fault.

So I made a DKMS package that can be used to fix this issue.

https://launchpad.net/~hanipouspilot/+archive/ubuntu/bluetooth/+files/btusb-lp1542743-dkms_0.1_all.deb

This package will build btusb.ko with the patch that changes [0cf3:3004] from AR3012 to QCA_ROME.

Bluetooth works now with this patch.
Thanks for the effort.

kind regards
io

Am Dienstag, den 28.06.2016, 14:16 +0000 schrieb Pilot6:
> We see that it is not easy to resolve because of Qualcomm team fault.
>
> So I made a DKMS package that can be used to fix this issue.
>
> https://launchpad.net/~hanipouspilot/+archive/ubuntu/bluetooth/+files
> /btusb-lp1542743-dkms_0.1_all.deb
>
> This package will build btusb.ko with the patch that changes
> [0cf3:3004]
> from AR3012 to QCA_ROME.
>

Pilot6 (hanipouspilot) on 2016-06-28
description: updated
description: updated

The patch provided by Pilot6 at #14 works fine for me.
Thanks you !

Chandravadan (chandravadans) wrote :

Tried the patch provided by @Pilot6 at #14, however I get the following error log :

```
DKMS make.log for btusb-lp1542743-0.1 for kernel 4.8.0-32-generic (x86_64)
Fri Dec 30 15:42:33 IST 2016
make: Entering directory '/usr/src/linux-headers-4.8.0-32-generic'
  LD /var/lib/dkms/btusb-lp1542743/0.1/build/built-in.o
  CC [M] /var/lib/dkms/btusb-lp1542743/0.1/build/btusb.o
/var/lib/dkms/btusb-lp1542743/0.1/build/btusb.c: In function ‘btusb_probe’:
/var/lib/dkms/btusb-lp1542743/0.1/build/btusb.c:2886:20: error: ‘HCI_BREDR’ undeclared (first use in this function)
   hdev->dev_type = HCI_BREDR;
                    ^~~~~~~~~
/var/lib/dkms/btusb-lp1542743/0.1/build/btusb.c:2886:20: note: each undeclared identifier is reported only once for each function it appears in
scripts/Makefile.build:295: recipe for target '/var/lib/dkms/btusb-lp1542743/0.1/build/btusb.o' failed
make[1]: *** [/var/lib/dkms/btusb-lp1542743/0.1/build/btusb.o] Error 1
Makefile:1491: recipe for target '_module_/var/lib/dkms/btusb-lp1542743/0.1/build' failed
make: *** [_module_/var/lib/dkms/btusb-lp1542743/0.1/build] Error 2
make: Leaving directory '/usr/src/linux-headers-4.8.0-32-generic'
```

Did anyone else face this issue?

Pilot6 (hanipouspilot) wrote :

My DKMS package was made for the 4.4 kernel. It does not build for 4.8.

To get it work on 4.8 you need to patch the btusb.c from that kernel.

Pilot6 (hanipouspilot) on 2016-12-30
description: updated
Pilot6 (hanipouspilot) wrote :

I uploaded the 4.8 version of this package. After it builds it will be available at

https://launchpad.net/~hanipouspilot/+archive/ubuntu/bluetooth/+files/btusb-lp1542743-dkms_0.1~4.8_all.deb

Chandravadan (chandravadans) wrote :

Just installed the new deb. It didn't throw up any errors, except for a couple of 'missing firmware' warnings as displayed in the attached log (btusb_log.txt). I did an lsmod to confirm the module has been loaded correctly, as the output shows below. However, I ended up with the same error as before, 'patch file not found' and consequently the 'loading patch file failed' error.

---- lsmod output ----
Module Size Used by
.
.
.
ath3k 20480 0
btusb 45056 0
btrtl 16384 1 btusb
btbcm 16384 1 btusb
btintel 16384 1 btusb
bluetooth 552960 12 btrtl,btintel,bnep,btbcm,ath3k,btusb
.
.
.
-----------------------

----- dmesg log --------
.
.
.
[ 3.936044] Bluetooth: Core ver 2.21
[ 3.936058] Bluetooth: HCI device and connection manager initialized
[ 3.936061] Bluetooth: HCI socket layer initialized
[ 3.936063] Bluetooth: L2CAP socket layer initialized
[ 3.936068] Bluetooth: SCO socket layer initialized
[ 3.949939] Bluetooth: Patch file not found ar3k/AthrBT_0x00000200.dfu
[ 3.949940] Bluetooth: Loading patch file failed
[ 9.268697] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 9.268698] Bluetooth: BNEP filters: protocol multicast
[ 9.268702] Bluetooth: BNEP socket layer initialized
.
.
.
------------------------

I can confirm the id of my bluetooth card to be the one specified above,

```
$ lsusb | grep -i blue
Bus 002 Device 005: ID 0cf3:3004 Atheros Communications, Inc. AR3012 Bluetooth 4.0
```

Pilot6 (hanipouspilot) wrote :

Your adapter is not Rome. Remove that deb. You need to update linux-firmware. Your problem is not related to this but report.

Pilot6 (hanipouspilot) wrote :
Chandravadan (chandravadans) wrote :

Looks like linux-firmware is already in its latest version...

$ sudo apt-get install linux-firmware
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-firmware is already the newest version (1.161.1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Chandravadan (chandravadans) wrote :

A strange thing happened -
I removed the deb and rebooted : Same error as before regarding missing patch file not being found.

I installed the *new* deb : No errors, successful installation

Rebooted : Same error as before regarding missing patch file, *BUT* after that there are some logs regarding a rampatch file (logs attached) and Bluetooth works successfully.

I guess something in the deb triggered this?

Pilot6 (hanipouspilot) wrote :

Install the last deb file. I fixed the issue with the module version.

Pilot6 (hanipouspilot) wrote :

The 0.1~4.8 вуи did not install properly, because I forgot to increment module version. now It should be OK.

description: updated
Pilot6 (hanipouspilot) wrote :

The patch file error is because I did not remove the ID from ath3k.c, but it does not matter. Just ignore it.

Chandravadan (chandravadans) wrote :

Ah. Sure. The latest deb solves the problem for me. Thanks! :)

chevrier (tc-s) wrote :

Thank you so much!! This works for Kernel 4.9.2
Your deb files allowed me to get bluetooth to work on all possible kernels...
you are the man!

i just need to figure out now how to get the sound to come out from the earphones when plugged in - that driver I downloaded for the old kernels does not seem to work for the newer one - a bit of a nuisance - i am using recon 3d i soundblaster, i think... it's the standard on dell alienware i believe (m17 r 2 for me)
many thanks

chevrier (tc-s) wrote :

Upgraded to kernel 4.9.3... ;-p works just as well... thanks again!!

AD (leadnovel) wrote :

I can confirm this also works on 4.8.0... on a MSI GT80-2QE w/ QCA6174 802.11ac combo card. Thank you!

chevrier (tc-s) wrote :

Might be of interest since Ubuntu 17.04 coming out shortly... works perfectly fine with all the kernels from 4.8.0 all the way to 4.10.8... thanks again and again.

The Raf 90 (theraf90) wrote :
Download full text (5.7 KiB)

Hi there, I've installed the latest patch given because I was suffering from the same bluetooth issue. Unfortunately after the patch my boot sequence has become excruciatingly long!!! this is where it stops for ~2 minutes:

[CODE]
May 10 09:55:58 Aaron-Linux systemd[1]: Started Tell Plymouth To Write Out Runtime Data.
May 10 09:55:58 Aaron-Linux systemd[1]: dev-disk-by\x2dpartlabel-Basic\x5cx20data\x5cx20partition.device: Dev dev-disk-by\x2dpartlabel-Basic\x5cx20data\x5cx20partition.device appeared twice with different sysfs paths /sys/devices/pci0000:00/0000:00:1d.0/0000:3c:00.0/nvme/nvme0/nvme0n1/nvme0n1p1 and /sys/devices/pci0000:00/0000:00:17.0/ata4/host3/target3:0:0/3:0:0:0/block/sda/sda4
May 10 09:55:58 Aaron-Linux systemd[1]: Found device Crucial_CT1050MX300SSD1 HAL.
May 10 09:55:58 Aaron-Linux apparmor[665]: * Starting AppArmor profiles
May 10 09:55:58 Aaron-Linux systemd[1]: Mounting /mnt/HAL...
May 10 09:55:58 Aaron-Linux systemd[1]: Activating swap Swap Partition...
May 10 09:55:58 Aaron-Linux systemd[1]: Starting Network Time Synchronization...
May 10 09:55:58 Aaron-Linux systemd[1]: Starting Update UTMP about System Boot/Shutdown...
May 10 09:55:58 Aaron-Linux apparmor[665]: Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox
May 10 09:55:58 Aaron-Linux systemd[1]: Activated swap Swap Partition.
May 10 09:55:58 Aaron-Linux systemd[1]: Started Set console font and keymap.
May 10 09:55:58 Aaron-Linux apparmor[665]: Skipping profile in /etc/apparmor.d/disable: usr.sbin.rsyslogd
May 10 09:55:58 Aaron-Linux systemd-timesyncd[760]: The system is configured to read the RTC time in the local time zone. This mode can not be fully supported. All system time to RTC updates are disabled.
May 10 09:55:58 Aaron-Linux systemd[1]: Started Network Time Synchronization.
May 10 09:55:58 Aaron-Linux systemd[1]: Reached target System Time Synchronized.
May 10 09:55:58 Aaron-Linux systemd[1]: Created slice system-getty.slice.
May 10 09:55:58 Aaron-Linux systemd[1]: Started Update UTMP about System Boot/Shutdown.
May 10 09:55:58 Aaron-Linux apparmor[665]: ...done.
May 10 09:55:58 Aaron-Linux systemd[1]: Started LSB: AppArmor initialization.
May 10 09:55:58 Aaron-Linux systemd[1]: Starting Raise network interfaces...
May 10 09:55:58 Aaron-Linux systemd[1]: Started Raise network interfaces.
May 10 09:55:58 Aaron-Linux ntfs-3g[844]: Version 2015.3.14AR.1 integrated FUSE 28
May 10 09:55:58 Aaron-Linux ntfs-3g[844]: Mounted /dev/sda4 (Read-Write, label "HAL", NTFS 3.1)
May 10 09:55:58 Aaron-Linux ntfs-3g[844]: Cmdline options: rw,nosuid,nodev
May 10 09:55:58 Aaron-Linux ntfs-3g[844]: Mount options: rw,nosuid,nodev,allow_other,nonempty,relatime,fsname=/dev/sda4,blkdev,blksize=4096
May 10 09:55:58 Aaron-Linux ntfs-3g[844]: Ownership and permissions disabled, configuration type 7
May 10 09:55:58 Aaron-Linux systemd[1]: Mounted /mnt/HAL.
May 10 09:55:58 Aaron-Linux mtp-probe: checking bus 1, device 5: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-11"
May 10 09:55:58 Aaron-Linux mtp-probe: checking bus 1, device 2: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-1"
May 10 09:55:58 Aaron-Linux mtp-probe: checking bus 1, device 3: "/sys/devices/pci0000:00...

Read more...

The Raf 90 (theraf90) wrote :

Sorry, previous post was UNRELATED to the bug, I changed the swap partition location and my PC (strangely after to perfect reboots) started looking for it elsewhere...

The .deb file has worked fine for me as well!

Adam Ryczkowski (adam-9) wrote :

The patch doesn't work for the 4.13 kernel from mainline ppa:

$ cat /var/lib/dkms/btusb-lp1542743/0.2~4.8/build/make.log
DKMS make.log for btusb-lp1542743-0.2~4.8 for kernel 4.13.0-041300-generic (x86_64)
pon, 9 paź 2017, 13:00:15 CEST
make: Entering directory '/usr/src/linux-headers-4.13.0-041300-generic'
  AR /var/lib/dkms/btusb-lp1542743/0.2~4.8/build/built-in.o
  CC [M] /var/lib/dkms/btusb-lp1542743/0.2~4.8/build/btusb.o
/var/lib/dkms/btusb-lp1542743/0.2~4.8/build/btusb.c: In function ‘inject_cmd_complete’:
/var/lib/dkms/btusb-lp1542743/0.2~4.8/build/btusb.c:1825:2: warning: dereferencing ‘void *’ pointer
  *skb_put(skb, 1) = 0x00;
  ^
/var/lib/dkms/btusb-lp1542743/0.2~4.8/build/btusb.c:1825:2: error: invalid use of void expression
/var/lib/dkms/btusb-lp1542743/0.2~4.8/build/btusb.c: In function ‘alloc_diag_urb’:
/var/lib/dkms/btusb-lp1542743/0.2~4.8/build/btusb.c:2697:2: warning: dereferencing ‘void *’ pointer
  *skb_put(skb, 1) = 0xf0;
  ^
/var/lib/dkms/btusb-lp1542743/0.2~4.8/build/btusb.c:2697:2: error: invalid use of void expression
/var/lib/dkms/btusb-lp1542743/0.2~4.8/build/btusb.c:2698:2: warning: dereferencing ‘void *’ pointer
  *skb_put(skb, 1) = enable;
  ^
/var/lib/dkms/btusb-lp1542743/0.2~4.8/build/btusb.c:2698:2: error: invalid use of void expression
scripts/Makefile.build:308: recipe for target '/var/lib/dkms/btusb-lp1542743/0.2~4.8/build/btusb.o' failed
make[1]: *** [/var/lib/dkms/btusb-lp1542743/0.2~4.8/build/btusb.o] Error 1
Makefile:1512: recipe for target '_module_/var/lib/dkms/btusb-lp1542743/0.2~4.8/build' failed
make: *** [_module_/var/lib/dkms/btusb-lp1542743/0.2~4.8/build] Error 2
make: Leaving directory '/usr/src/linux-headers-4.13.0-041300-generic'

Pilot6 (hanipouspilot) wrote :

This DKMS package was never supposed to work on any other kernel but the 4.4.

jean-marc (jmaxou) wrote :

The latest patch does work when you realize that the skb_put function has recently changed from (unsigned char*) to (void *) ( see https://patchwork.ozlabs.org/patch/776580/ for fix).

The lines where appears "*skb_put" need to be changed to "*(u8 *)skb_put". This was enough for me to get my bluetooth adapter to work (MSI GS60 6QC). This may not be the best way but I am not a competent programmer

Thanks for the package !

Rubber Ducky (rd1945) wrote :

The patch doesn't work on a GT72 2QE Dominator Pro. It compiled and installed succesfully with the patch but the system keeps reporting that no adapter is found. It also keeps saying that the ar3k/AthrBT_0x00000200.dfu patch file could not be found.

Hi all, this issue affect me too, and I would like to built the DKMS package for different kernels,

@Pilot6 could you share your recipe to built the DKMS package?

Thanks a lot.

Geovane (geeo-sp) wrote :

This bug also affects me,
I have made what @jmaxou suggested.
It is working now on kkernel 4.13
@radiovirusgenerator, It should work for you too

@geeo-sp thanks for the info!
I imagiine you have built the deb file starting from the source, could you share the recipe to built the deb package? thanks!

Geovane (geeo-sp) wrote :

I had no idea how to proceed either.
Since @jmaxou sugested that we could edit the source code, and I couldnt see where this source were, I assumed it could be get from the .deb file.
I searched how to do it from the deb package. Turned out its like a zip, we can extract its contents.
I got the last deb package, the one built to kernel 4.8, depacked, edited and repacked.
this site shows how to do it
https://unix.stackexchange.com/questions/138188/easily-unpack-deb-edit-postinst-and-repack-deb
actually is pretty simple.
If I understood well, it should be packed using the kernel you want to target. But I can be wrong in this point
Sorry if I cant be of more help, first time doing it as well.
Anyway, anybody knows how can we make those fixes to be part of ubuntu itself?
Tired of the bluetooth not working each update

Daniel van Vugt (vanvugt) wrote :

Missing firmware has nothing to do with bluez. Plus those "Bluetooth" log messages are from the kernel, not bluez.

It appears the linux-firmware package contains some related firmware, but just not the right one...
/lib/firmware/ar3k/AthrBT_0x01020001.dfu
/lib/firmware/ar3k/AthrBT_0x01020200.dfu
/lib/firmware/ar3k/AthrBT_0x01020201.dfu
/lib/firmware/ar3k/AthrBT_0x11020000.dfu
/lib/firmware/ar3k/AthrBT_0x11020100.dfu
/lib/firmware/ar3k/AthrBT_0x31010000.dfu
/lib/firmware/ar3k/AthrBT_0x31010100.dfu
/lib/firmware/ar3k/AthrBT_0x41020000.dfu

So a fix would either come in the 'linux-firmware' package or in the kernel itself ('linux').

affects: bluez (Ubuntu) → linux-firmware (Ubuntu)
Changed in linux (Ubuntu):
status: New → Confirmed
summary: - Bluetooth: Patch file not found ar3k/AthrBT_0x00000200.dfu
+ Bluetooth (Atheros AR3012): Patch file not found
+ ar3k/AthrBT_0x00000200.dfu

io can you test https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1764645/comments/43 and comment there. I know this fixes the older 0cf3:3004 bluetooth devices but I wonder if it fixes your issue also

Daniel van Vugt (vanvugt) wrote :

I am seeing users of 18.04 report a different error for the same AR3012 hardware. I'm going to assume it's the same problem, just a newer kernel:

[ 22.402475] Bluetooth: hci0: don't support firmware rome 0x31010000

and

[ 228.109562] Bluetooth: hci0: don't support firmware rome 0x1020200

and

[ 18.722951] Bluetooth: hci0: don't support firmware rome 0x11020000

summary: - Bluetooth (Atheros AR3012): Patch file not found
- ar3k/AthrBT_0x00000200.dfu
+ Bluetooth (Atheros AR3012) does not work
io (schmidta1) wrote :

Jeremy, I installed and tested
linux-modules-4.15.0-22-generic_4.15.0-22.25~lp1764645_amd64.deb
and
linux-modules-extra-4.15.0-22-generic_4.15.0-22.25~lp1764645_amd64.deb

bluetooth is active.
 bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset
   Active: active (running) since Thu 2018-06-14 06:15:44 CEST; 5min ago
     Docs: man:bluetoothd(8)
 Main PID: 900 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/bluetooth.service
           └─900 /usr/lib/bluetooth/bluetoothd

################
dmesg | grep Blue
[ 2.663568] Bluetooth: Core ver 2.22
[ 2.663584] Bluetooth: HCI device and connection manager initialized
[ 2.663587] Bluetooth: HCI socket layer initialized
[ 2.663589] Bluetooth: L2CAP socket layer initialized
[ 2.663592] Bluetooth: SCO socket layer initialized
[ 4.183936] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 4.183938] Bluetooth: BNEP filters: protocol multicast
[ 4.183942] Bluetooth: BNEP socket layer initialized
[ 24.844841] Bluetooth: RFCOMM TTY layer initialized
[ 24.844845] Bluetooth: RFCOMM socket layer initialized
[ 24.844849] Bluetooth: RFCOMM ver 1.11

greetings

tags: added: bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers