Comment 20 for bug 1520343

Oliver (aunicorn) wrote :

Thank you Dennis, happy that it worked for you!
Unfortunately it didn't work in my case. Maybe it is another problem since I'm not able to see the "wifi" in the toolbar.

lspci -nn | grep -i net

07:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:003e] (rev 32)

after reboot:

dmesg | grep ath10k

[ 1.912355] ath10k_pci 0000:07:00.0: pci irq msi-x interrupts 8 irq_mode 0 reset_mode 0
[ 2.143818] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/cal-pci-0000:07:00.0.bin failed with error -2
[ 2.151383] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/board-pci-168c:003e:11ad:0807.bin failed with error -2
[ 2.151387] ath10k_pci 0000:07:00.0: failed to load spec board file, falling back to generic: -2
[ 2.151400] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/board.bin failed with error -2
[ 2.151402] ath10k_pci 0000:07:00.0: failed to fetch generic board data: -2
[ 2.151405] ath10k_pci 0000:07:00.0: failed to fetch board file: -2
[ 2.151406] ath10k_pci 0000:07:00.0: could not fetch firmware files (-2)
[ 2.151408] ath10k_pci 0000:07:00.0: could not probe fw (-2)

iwconfig

eth0 no wireless extensions.

lo no wireless extensions.

lshw -c network

  *-network
       description: Network controller
       product: Qualcomm Atheros
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:07:00.0
       version: 32
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: driver=ath10k_pci latency=0
       resources: irq:126 memory:84000000-841fffff